Our vBulletin migration is complete.
Welcome vBulletin users! All content and user information from the Micro Focus Forums (vBulletin) site has been migrated to this site. READ MORE.
Highlighted
TomasGarcia
Established Member.
1297 views

Cannot recognize Object in Chrome Native Browser

Hi, 

I'm trying record an application in Chrome native browser, but I only get a "Device" object in any case. I don't get either Browser.Page.... or Device.App.... 

Could you help me?

Thanks, 

Tags (1)
0 Likes
6 Replies
Micro Focus Expert
Micro Focus Expert

Re: Cannot recognize Object in Chrome Native Browser

Hi,

Please specify which version of MC you are using and what are the record settings for your script (including web page address that you are trying to launch).

While using Browser, you should get Browser object in the script and the relevant steps there.

0 Likes
tomek86 Valued Contributor.
Valued Contributor.

Re: Cannot recognize Object in Chrome Native Browser

Hello

I have a similar problem. When recording the actions on Chrome Browser in Android I get either a "Device" and nothing else (no App or Browser), sometimes the Browser object is recognized during recording, but then it's not recognized during playback. I have also used descriptive programming in UFT (e.g. Browser("micClass:=Browser")) and also no results.

I have a bunch of objects identified for Desktop Browsers and I would like to use them on mobile devices as well.

In the Record and Run Settings I have selected "Use Mobile Center" radio button. Remainig options are unchecked. I'm using UFT v14.03

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Cannot recognize Object in Chrome Native Browser

Did you selected Chrome browser as Mobile application in "record and run settings" of UFT?

You need to select mobile device, then in the drop-down box of mobile applicaiton, select Browser.

0 Likes
tomek86 Valued Contributor.
Valued Contributor.

Re: Cannot recognize Object in Chrome Native Browser

Thanks, in the "Mobile" tab I have "App Settings" section. But I can see only MC Browser icon. There's no Chrome or Firefox. Should I add them first?

Tomasz
0 Likes
tomek86 Valued Contributor.
Valued Contributor.

Re: Cannot recognize Object in Chrome Native Browser

Btw the MC version is 2.6.
The server is running on Redhat Linux 9.6
0 Likes
tomek86 Valued Contributor.
Valued Contributor.

Re: Cannot recognize Object in Chrome Native Browser

I found the solution by specifying the parameters in UFT Datasheet:

Parameterize browser and device values for Web tests

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.