NA should allow advanced scripts to run through available password rules as it does other scripts

Idea ID 1682473

NA should allow advanced scripts to run through available password rules as it does other scripts

NA should allow advanced (Diagnostic and Command) scripts to run through available password rules as it does for other scripts. 

MicroFocus should provide modules for the supported scripting languages for advanced scripts that developers could use to authenticate to devices the same way standard (Diagnostic and Command) scripts do.

Meaning advanced scripts could roll through the available and appropriate password rules for a device based on the password rule criteria and learn the correct password rule and update the database this the new credentials. 

This is a particular problem when passwords change on a device but the NA application/database have not yet been updated. 

Today developers only have access to “tc_” variables and cannot learn new credentials even if they do exist in existing password rules.

1 Comment
Micro Focus Expert
Micro Focus Expert
Status changed to: Waiting for Votes
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.