Absent Member.
Absent Member.
1677 views

MFSORT from server express 5.0 (Anyone using?)

Jump to solution

[Migrated content. Thread originally posted on 10 May 2011]

Hi everyone,

Was wondering if anyone is using mfsort in their environment?
My side was thinking of using mfsort as their sorting tool for their development.
The performance is not bad as it seem to be able to keep up with syncsort's performance.

Just that it is truncating trailing blanks from my line sequential data files and I still haven't figured out how to stop it from doing that. 😞

Any help would be appreciated. 🙂
Thank you.
0 Likes
1 Solution

Accepted Solutions
Absent Member.
Absent Member.
Hi again everyone,

Though it might be weird to be answering my own question but I feel that I should share the answer here in case someone else hits the same problem as I did. 🙂

There seems to be a support document relating to this:
http://www.microfocus.com/000/NEMFSORT_tcm21-11601.pdf

Referring to the documentation here:
http://supportline.microfocus.com/documentation/books/sx50ws03/sx50indx.htm
Read under "File Handling - 6 File Handler Configuration"
you will find the way to set the default setting of STRIPSPACE to OFF (Default is ON).
According to the documentation that parameter actually does this: When performing WRITE or REWRITE operations on line sequential or line advancing files, determines whether to remove trailing space characters.

Therefore, I probably just need to set EXTFH=/home/myconfig.cfg in my environment setting file.
Then, set the following in the config:
[XFH-DEFAULT]
STRIPSPACE=OFF

Think that should do the trick. 🙂

View solution in original post

0 Likes
2 Replies
Absent Member.
Absent Member.
Hi again everyone,

Though it might be weird to be answering my own question but I feel that I should share the answer here in case someone else hits the same problem as I did. 🙂

There seems to be a support document relating to this:
http://www.microfocus.com/000/NEMFSORT_tcm21-11601.pdf

Referring to the documentation here:
http://supportline.microfocus.com/documentation/books/sx50ws03/sx50indx.htm
Read under "File Handling - 6 File Handler Configuration"
you will find the way to set the default setting of STRIPSPACE to OFF (Default is ON).
According to the documentation that parameter actually does this: When performing WRITE or REWRITE operations on line sequential or line advancing files, determines whether to remove trailing space characters.

Therefore, I probably just need to set EXTFH=/home/myconfig.cfg in my environment setting file.
Then, set the following in the config:
[XFH-DEFAULT]
STRIPSPACE=OFF

Think that should do the trick. 🙂

View solution in original post

0 Likes
Micro Focus Expert
Micro Focus Expert
Yes setting the STRIPSPACE option to OFF should solve this issue for you.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.