New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Captain
Captain
866 views

SSH is not working

Jump to solution

Hello All,

I am having an issue with the SSH under the action menu, as when I click the SSH button for any device I open a blank page unlike the telnet as when I chose for the first time it asked me once to set the default client and it's working fine for the telnet.

Anyway, can anyone help me in this issue. 

note: I am using NA version 10.40 on windows environment 

 

 

 

Tags (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Fleet Admiral
Fleet Admiral

also forgot to mentioned:

Currently the NA proxy window do not work on Chrome and Firefox given that the plugin [NPAPI] NA relied on has been removed  on Both Browsers by default starting at Firefox 52 and Chrome 45 versions each,

Only Internet Explorer 10 and 11 can launch the proxy window correctly at this date.

Also on our NA 10.11 Release Notes there is a note of this known Browser Issue:

________________________________________

Browser-related Known Issues

The NA Applet does not work in a Google Chrome browser As Google Chrome has disabled Netscape Plugin Application Programming Interface (NPAPI), Java applets no longer work in the browser.

Workaround:

Connect to NA Proxy using an SSH or Telnet utility, log on to your user account, and then connect to the devices using the connect command. For more information, see the Adding Devices and Device Groups chapter of NA User Guide.

________________________________________

Chrome Blog:
https://blog.chromium.org/2014/11/the-final-countdown-for-npapi.html
https://www.chromium.org/developers/npapi-deprecation --> Timeline where they clearly state that Sept 2015 is the drop-dead cut-off for NPAPI obsolescence (i.e. Java Applet disablement).

Pedro A. Batista
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the THUMB at the bottom left of the post and show your appreciation.

View solution in original post

0 Likes
5 Replies
Highlighted
Fleet Admiral
Fleet Admiral

Hi @shady_kozman,

the Proxy window has issues on Firefox and Chrome, since the plugin used is already decommisioned by those browsers, only IE will execute that.

 

Pedro A. Batista
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the THUMB at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Captain
Captain

Hello @Pedro_B_NA

thanks for your mail. i used IE 11 and i've got the same blank screen but when i used IE v 9 i've got a java error 

ClassNotFoundException so any idea to solve this issue 

 

thanks in advance

0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

Hi @shady_kozman,

do you have a loadbalancer between NA and your System? 

also you can add the NA ip as an exception to your JAVA on your laptop/pc,

  1. look for JAVA control Panel in your PC with Configure Java 
  2. look for the security settings tab
  3. add NA your ip or hostname, you can add both if needed [the ip is an example and is not from a live system]:clip_image004.jpg
  4.  Edit Site list and added
  5. go to General and click on Settings
  6. delete files and check all boxes

temp_settings.png

7. close all browsers and try again

Pedro A. Batista
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the THUMB at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

also forgot to mentioned:

Currently the NA proxy window do not work on Chrome and Firefox given that the plugin [NPAPI] NA relied on has been removed  on Both Browsers by default starting at Firefox 52 and Chrome 45 versions each,

Only Internet Explorer 10 and 11 can launch the proxy window correctly at this date.

Also on our NA 10.11 Release Notes there is a note of this known Browser Issue:

________________________________________

Browser-related Known Issues

The NA Applet does not work in a Google Chrome browser As Google Chrome has disabled Netscape Plugin Application Programming Interface (NPAPI), Java applets no longer work in the browser.

Workaround:

Connect to NA Proxy using an SSH or Telnet utility, log on to your user account, and then connect to the devices using the connect command. For more information, see the Adding Devices and Device Groups chapter of NA User Guide.

________________________________________

Chrome Blog:
https://blog.chromium.org/2014/11/the-final-countdown-for-npapi.html
https://www.chromium.org/developers/npapi-deprecation --> Timeline where they clearly state that Sept 2015 is the drop-dead cut-off for NPAPI obsolescence (i.e. Java Applet disablement).

Pedro A. Batista
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the THUMB at the bottom left of the post and show your appreciation.

View solution in original post

0 Likes
Highlighted
Captain
Captain

Hi @Pedro_B_NA

Many thanks. i will try the proposed solution and let you know the updates 

 

Best Regards 

Shady kozman 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.