Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..
586 views

Cannot Install NPS/Metrics iSPI due to IPv6 Loopback address

Jump to solution

When installing a stand alone NPS/Metrics iSPI one of the checks that fails is when it tries to ping itself and gets the IPv6 address.

So, does anyone know how I to get my Windows 2012R2 Server to no longer give an IPv6 loopback address (::1:) when someone pings the hostname from within the server?

0 Likes
1 Solution

Accepted Solutions
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Re: Cannot Install NPS/Metrics iSPI due to IPv6 Loopback address

Jump to solution

I used this procedure

To force the system to use IPv4 first, before IPv6

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents. If it doesn’t exist, you have to create it.

Or if you do not want to do this manual procedure, you can now use the Microsoft “Mr Fix It” script to automatically do it for you. The scripts are in the KB929852 article above.

  1. In Registry Editor, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters \

  2. Double-click DisabledComponents to modify the DisabledComponents entry.
    Note If the DisabledComponents entry is unavailable, you must create it. To do this, follow these steps:
    1. In the Edit menu, point to New, and then click DWORD (32-bit) Value.
    2. Type DisabledComponents, and then press ENTER.
    3. Double-click DisabledComponents.
  3. Type 0x20 to prefer IPv4 over IPv6 by modifying entries in the prefix policy table.
  4. Restart

View solution in original post

4 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Cannot Install NPS/Metrics iSPI due to IPv6 Loopback address

Jump to solution

Hi Mike,

Sorry for the delay answering your question but for any reason that I need to sort out, I am not getting any more the forum post notifications although I subscribed to them.

Are you getting a particular error at some installation stage?

You may want to check if the /etc/hosts file ("C:\Windows\System32\drivers\etc\hosts") could not have the Loopback IPv6 address  '::1' associated with the server hostname instead of localhost, causing the hostname resolution to subsitute the server hostname by the Loopback IPv6 address '::1', in case name resolution is not handled by the DNS server itself.

All the best

Marie-Noelle

 

 

Micro Focus Customer Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone’s response please remember to give them KUDOS and show your appreciation.
0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Cannot Install NPS/Metrics iSPI due to IPv6 Loopback address

Jump to solution

Hi Marie-Noelle,

I've checked the hosts file and everything was commented out. I even uncommented it and added in the hostname with the IP address but I'm still getting the ::1: loopback address. When you ping the server from anywhere on the network you get the IPv4 address. It is only when you ping the hostname from within the server do I get the IPv6 loopback.

I get an error during the preinstallation check phase when installing the NPS stating that the loopback address didn't resolve to an IPv4 address and to correct the problem before I can install.

0 Likes
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Re: Cannot Install NPS/Metrics iSPI due to IPv6 Loopback address

Jump to solution

I used this procedure

To force the system to use IPv4 first, before IPv6

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents. If it doesn’t exist, you have to create it.

Or if you do not want to do this manual procedure, you can now use the Microsoft “Mr Fix It” script to automatically do it for you. The scripts are in the KB929852 article above.

  1. In Registry Editor, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters \

  2. Double-click DisabledComponents to modify the DisabledComponents entry.
    Note If the DisabledComponents entry is unavailable, you must create it. To do this, follow these steps:
    1. In the Edit menu, point to New, and then click DWORD (32-bit) Value.
    2. Type DisabledComponents, and then press ENTER.
    3. Double-click DisabledComponents.
  3. Type 0x20 to prefer IPv4 over IPv6 by modifying entries in the prefix policy table.
  4. Restart

View solution in original post

Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Cannot Install NPS/Metrics iSPI due to IPv6 Loopback address

Jump to solution

Using the Microsoft "Mr Fix It" tool worked. Thanks.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.