Highlighted
Trusted Contributor.
Trusted Contributor.
638 views

Interface_mertic files are not getting consumed in NPS

Jump to solution

Hi Experts,

We are facing problem in NPS interface Metric files are not getting consumed rest all EP files are consumed.

We are not able to provide reports to user related to interface of device , also carriedout different suggestion provided on forum but still unable to resolve issue.Interface metrice status is showing alive .Kindly help us to resolve problem.

Regards,

Deepak T

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..

Re: Interface_mertic files are not getting consumed in NPS

Jump to solution

Hi Deepak,

 

Could you please share the statusall.ovpl output from Nps server and also let us know if NNMi and NPS both installed on same server or on diffrenet servers?

 

Edit:- Plz share the NNMi and NPS version and enviornment details as well.

Thanks. 

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution, If you are satisfied with anyone’s response please remember to give them a KUDOS and show your appreciation.

View solution in original post

0 Likes
2 Replies
Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..

Re: Interface_mertic files are not getting consumed in NPS

Jump to solution

Hi Deepak,

 

Could you please share the statusall.ovpl output from Nps server and also let us know if NNMi and NPS both installed on same server or on diffrenet servers?

 

Edit:- Plz share the NNMi and NPS version and enviornment details as well.

Thanks. 

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution, If you are satisfied with anyone’s response please remember to give them a KUDOS and show your appreciation.

View solution in original post

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Interface_mertic files are not getting consumed in NPS

Jump to solution

Hi Anu,

Thanks for reply

But actually i Logged case with HP and got it resolved. Issue was with NPS Database.

Below are  troubleshooting steps:

Steps done: - NPS in window server HA cluster dedicated with NNMi
-          We observed issue with f_Raw_InterfaceMetrics which was corrupted and prevented ETL from updating DB
-          Following steps were taken to recreate the table:
1) Stop the ETL process with stopETL.ovpl
2) Login to IQ (/opt/OV/nonOV/sybaseiq/IQ-16_0/bin64/dbisql -c "DSN=PerfSPIDSN" -nogui )
3) In the DBA prompt execute following command:
#select * into f_Raw_IH_copyone from f_Raw_InterfaceMetrics
#commit
4) Take a backup of Metrics DB using backup.ovpl command (per example: /opt/OV/NNMPerformanceSPI/bin/backup.ovpl -d -b )
5) Stop all NPS services and start the database only: stopALL.ovpl startDB.ovpl
6) login to Sybase IQ: /opt/OV/nonOV/sybaseiq/IQ-16_0/bin64/dbisql -c "DSN=PerfSPIDSN" -nogui
7) Execute following commands in DBA prompt:
#drop table f_Raw_InterfaceMetrics
#sp_iqrename f_Raw_IH_copyone, f_Raw_InterfaceMetrics
😎 exit out of the DBA prompt.
9) Rebuild the indexes for Interface_Health extensionpack using: dbCheckIndexes.ovpl -p Interface_Health -r
10) Start all NPS services startALL.ovpl
=> After this, Interface metric files are being processed
 
Regards,
Deepak T
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.