Highlighted
New Member.
804 views

Interfaces are not showing in NNMi.

Jump to solution

Hi,

I'm using NNMi 10.01 on Windows and SNMP Proxy agent (net-snmp-utils) on Linux. I'm not able to view topology map, because there are no links between devices at all. And very less number of interfaces are displayed in "Interfaces" tab of devices. What may cause the problem?

Thanks,

Igor

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Interfaces are not showing in NNMi.

Jump to solution

The first thing to check is whether nodes are discovered as SNMP devices? What do you see in the Inventory -> Nodes tab, Non-SNMP devices or regular SNMP-ware devices where device types, vendor, iscons, location etc. are discovered and populated? For Non-SNMP devices you normally have only 1 Pseudo-Interface. If that's the case you need to start by fixing SNMP communications to make sure NNMi can communicate with devices by SNMP. You configure this in Configuration -> Communiaction Configuration window. Set up correct, default, Regional, Specific node settings, SNMPv3. Read online Help or NNMi Deployment Reference to see how it is done. Check yourself with command:

nnmsnmpwalk.ovpl <node.name> system.

Once this works without additional keywords (unless you are reaching out to SNMPv3 node) you are all set and done.
If that was not what you are asking about, please list few more details or share relevant screen-shots to see where you are with node discovery and monitoring.

Mikayel Grigoryan
HPE Software

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Interfaces are not showing in NNMi.

Jump to solution

The first thing to check is whether nodes are discovered as SNMP devices? What do you see in the Inventory -> Nodes tab, Non-SNMP devices or regular SNMP-ware devices where device types, vendor, iscons, location etc. are discovered and populated? For Non-SNMP devices you normally have only 1 Pseudo-Interface. If that's the case you need to start by fixing SNMP communications to make sure NNMi can communicate with devices by SNMP. You configure this in Configuration -> Communiaction Configuration window. Set up correct, default, Regional, Specific node settings, SNMPv3. Read online Help or NNMi Deployment Reference to see how it is done. Check yourself with command:

nnmsnmpwalk.ovpl <node.name> system.

Once this works without additional keywords (unless you are reaching out to SNMPv3 node) you are all set and done.
If that was not what you are asking about, please list few more details or share relevant screen-shots to see where you are with node discovery and monitoring.

Mikayel Grigoryan
HPE Software

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

Highlighted
New Member.

Re: Interfaces are not showing in NNMi.

Jump to solution

Mikayel,

Thank you very much for your help. The issue is resolved now.

Thanks,

Igor

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.