Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..
317 views

NNM not working after installation

HI ,

I have recently installed NNMi 9.20 on RHEL 7 , I want to upgrade NNMi 9.20 to 10.10 , currently its on RHEL 5.

So first I am installing 9.20 to RHEL 7 , but its not working, the url is opening with 404 error.

Installed version is 

NNM 9.20,9.23.005
NNM Patch: NNM920_00005

 

checking in the logs I see following.

nnm.log

2017-02-14 06:28:55.247 ERROR [org.jboss.ws.core.CommonClient] Exception caught while (preparing for) performing the invocation: : javax.xml.ws.soap.SOAPFaultException: java.lang.NullPointerException
at org.jboss.ws.core.jaxws.SOAPFaultHelperJAXWS.getSOAPFaultException(SOAPFaultHelperJAXWS.java:88)
at org.jboss.ws.core.jaxws.binding.SOAP11BindingJAXWS.throwFaultException(SOAP11BindingJAXWS.java:107)
at org.jboss.ws.core.CommonSOAPBinding.unbindResponseMessage(CommonSOAPBinding.java:605)
at org.jboss.ws.core.CommonClient.invoke(CommonClient.java:412)
at org.jboss.ws.core.jaxws.client.ClientImpl.invoke(ClientImpl.java:302)
at org.jboss.ws.core.jaxws.client.ClientProxy.invoke(ClientProxy.java:181)
at org.jboss.ws.core.jaxws.client.ClientProxy.invoke(ClientProxy.java:161)
at $Proxy474.readPropertyValue(Unknown Source)
at com.hp.ov.nnm.im.NnmIMClient.readPropertyValue(NnmIMClient.java:125)
at com.hp.ov.nnm.im.NnmIntegrationModule.getConfig(NnmIntegrationModule.java:218)
at com.hp.ov.nnm.im.NnmIntegrationModule.init(NnmIntegrationModule.java:94)
at com.hp.ov.nnm.im.NnmIntegrationModule$Enabler$EnableTask.run(NnmIntegrationModule.java:488)
at java.util.TimerThread.mainLoop(Timer.java:512)
at java.util.TimerThread.run(Timer.java:462)

2017-02-14 06:28:55.247 ERROR [org.jboss.ws.core.jaxws.SOAPFaultHelperJAXWS] SOAP request exception: java.lang.NullPointerException
at org.jboss.webservices.integration.ioc.IoCContainerProxyImpl.getBean(IoCContainerProxyImpl.java:84)
at org.jboss.webservices.integration.invocation.InvocationHandlerEJB3.getEjb3Container(InvocationHandlerEJB3.java:106)
at org.jboss.webservices.integration.invocation.InvocationHandlerEJB3.getJNDIContext(InvocationHandlerEJB3.java:153)

 

in boot.log we can see

 

2017-02-14 06:25:38.451 SEVERE [SpiNotificationMdb] Exception processing Spi notification: : javax.management.InstanceNotFoundException: com.hp.ov.nms.apa:service=NmsApa is not registered.
at org.jboss.mx.server.registry.BasicMBeanRegistry.get(BasicMBeanRegistry.java:529) [:6.0.0.GA]

 

in health.log we see

 

Service Health Agent
+--------------------------------------------------------------------+-----------+
| Service | State |
+--------------------------------------------------------------------+-----------+
| com.hp.ov.nms:service=NmsModel | NOT_FOUND |
| com.hp.ov.nms.as.shared:service=NmsAuthService | STARTED |
| com.hp.ov.nms.as.shared:service=NmsCrlManager | STARTED |
| com.hp.ov.nms.as.shared:service=NmsTrustManager | STARTED |
| com.hp.ov.nms.geo.bridge:name=BridgeManager | NOT_FOUND |
| com.hp.ov.nms.geo.bridge:name=RequestCache | STARTED |
| com.hp.ov.nms.topo:service=DatabaseMaintenance | NOT_FOUND |
| com.hp.ov.nms.topo:service=KeyManager | NOT_FOUND |
| com.hp.ov.nms.topo:service=NetworkApplication | NOT_FOUND |
| com.hp.ov.nms.topo.services.customexport:mbean=CustomExportService | NOT_FOUND |
| com.hp.ov.nnm.security:service=TrustManager | STARTED |
+--------------------------------------------------------------------+-----------+

 

Thanks

stsgp_ov

0 Likes
5 Replies
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: NNM not working after installation

Hi,

As you said, you are installing NNMi version 9.20 on the RHEL 7. If you read the document support matrix of NNMi version 9.20, there is NO RHEL 7 on the OS version supported. NNMi version 10.20 can be installed on RHEL 7 but not for NNMi version 9.20. So, if you need to upgrade from 9.20 to 10.10, please install NNMi 9.20 on the RHEL 5 then doing upgrade following instruction from 9.20 patch 5 ( remember that 9.20 should be installed the latest patch 5 on it first) to 10.x, you can get reference on this KM link:

NNMi 10.10 NNMi interactive Installation and Upgrade Guilde

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01900843

 

Hope this is helpful for you.

 

“Regards,

Nga Do Thi Tuyet | SW Technical Support
Network Node Manager
Hewlett-Packard (SSO Portal)


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.”
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: NNM not working after installation

Hi,

  Just to add one point to the previous comment.  If you need to migrate from RHEL 2.5 to 2.7 then it is supported to install 9.2 on the 2.7 system in order to then restore your DB, but it is NOT supported to run NNMi on 2.7.   The instalation of 9.2 on 2.7 is purely as a means to upgrade the OS because you can't upgrade 2.5 to 2.7, you have to do a clean install of 2.7.   The installation and upgrade documentation should state all this.

  All the best

Dave Y

MicroFocus Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of MicroFocus
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..

Re: NNM not working after installation

thnaks NGA do,

 

can i install NNMi 9.20 on RHEL 6 instead of RHEL 5 (then patch 5 on it) and then upgrade to 10.10.

for backup and configuration transfer , can we transfer from 9.20 to 10.10  or it can be done only between same version NNMi.

 

Thanks

 

 

 

 

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: NNM not working after installation

Same version as well as same patch level and hotfixes only for restoration.

Have a nice day 🙂

Andy Kemp
I've lasted longer in the technology industry than most certifications.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: NNM not working after installation

Hi,

Is there anything else we could help you with on this discussion thread?

Did you manage to complete the upgrade from NNMi 9.20 RHEL 5 to 10.10 RHEL 7 ?

The 10.00 Upgrade Reference Guide  provides a number of examples showing the methodology to use when the upgrade plan combines both a new version of NNMi and a new version of OS, that can be extended to upper versions as well, and be used as reference to achieve what you want to achieve.

See for instance in the "Upgrading from NNMi 9.1x or 9.2x to NNMi 10.00" version the "Changing NNMi to RHEL Version 6.4 or Later" sub-section.

Please let us know the end of the story in case the migration completed successfully.

If no more help is required here, would you mind marking the most appropriate post as Accepted Solution so that we could close this discussion thread? 

Many Thanks

Marie-Noelle

Micro Focus Customer Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone’s response please remember to give them KUDOS and show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.