Highlighted
New Member.
770 views

NNMi hotfix postgres installation failed.

Jump to solution

Hi,

I'm trying to install NNMi 10.01 Hotfix Postgresql for Windows (

Hotfix-NNMI-10.0X-WIN-POSTGRESQL-20160331.zip
) .

Installation fails each time with message: "NNMi trapReceiver still running, please stop it and rerun this command".
But actually no NNMi services are running at the moment. I checked it with ovstatus command.

What may cause the problem? And how to resolve it?

Thanks,

Igor

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: NNMi hotfix postgres installation failed.

Jump to solution

Igor,

  Which version of the tool are you running?  It may be best to open a support case with us so we can provide you the latest version of it or look into why its not detecting the correct status of the trap receiver.  Unfortunately I am unable to upload the script to this forum

  All the best

Dave Y

MicroFocus Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of MicroFocus
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

4 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: NNMi hotfix postgres installation failed.

Jump to solution

Igor,

  In NNMi 10.x there is now an external process called nnmtrapreceiver that is running and is independent of the ovspmd commands.  while the nnmtrapreceivermd process that does run under ovspmd will start it, it will not stop it.  What you need to do is run the command

nnmtrapreceiver.exe -stop

  All the best

Dave Y

MicroFocus Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of MicroFocus
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
Highlighted
New Member.

Re: NNMi hotfix postgres installation failed.

Jump to solution

Hi Dave,

Thank you for your help.

I ran the command  

nnmtrapreceiver.exe -stop

I checked that nnmtrapreceiver is stopped. But when trying to install the patch I got an error message again: "NNMi trapReceiver still running, please stop it and rerun this command".

Thanks,

Igor

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: NNMi hotfix postgres installation failed.

Jump to solution

Igor,

  Which version of the tool are you running?  It may be best to open a support case with us so we can provide you the latest version of it or look into why its not detecting the correct status of the trap receiver.  Unfortunately I am unable to upload the script to this forum

  All the best

Dave Y

MicroFocus Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of MicroFocus
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

Highlighted
New Member.

Re: NNMi hotfix postgres installation failed.

Jump to solution

Hi Dave,

Thank you for your answer.

Could you please send me the script via email?

Thank you in advance.

Thanks,

Igor

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.