Highlighted
Acclaimed Contributor.
Acclaimed Contributor.
650 views

NPS 10.20 fails to install with RHEL 7.x

Jump to solution

We are planning to install NPS 10.20 with RHEL 7.x

In the pre-requisite section of the install, it fails with error which says it could not find openmotif library packages.

As per our Unix admins, RHEL 7.x comes with default MOTIF package not openmotif and our admins are saying that they cannot install openmotif library package.

We went ahead of trying to install openmotif using rpm package and it fails with error,

error: Failed dependencies:
/usr/share/X11/XKeysymDB is needed by openmotif2.2.319.el6.i686

We tried yum install, but it says package is not available.

Had anyone faced this issue and how did you overcome this issue.

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: NPS 10.20 fails to install with RHEL 7.x

Jump to solution

Dear Andy

It is checking for exact version of openmotif package. We installed downgraded version of openmotif package and it was complaining. Once we installed exact version of openmotif package it went through.

This should be properly mentioned in pre-requisite section of what version of package you need to install.

View solution in original post

0 Likes
3 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: NPS 10.20 fails to install with RHEL 7.x

Jump to solution

Work around ?   Its listed in the OS requirements for Performance v10.20, its not something you can work around.

List of Prerequisite Libraries

libstdc++.i686
compat-libstdc++-296.i686
compat-libstdc++-33.i686
compat-libstdc++-33.x86_64
libpng.i686
libpng.x86_64
libXp.i686
libXp.x86_64
ncurses
openmotif.i686
openmotif.x86_64
tcsh
unixODBC.i686
unixODBC.x86_64
unixODBC-devel.i686
unixODBC-devel.x86_64
libXtst.i686
libXtst
libXi.i686
libXi
libaio
nspr.i686
nspr.x86_64
nss.i686
nss.x86_64

Have a nice day 🙂

Andy Kemp
I've lasted longer in the technology industry than most certifications.
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: NPS 10.20 fails to install with RHEL 7.x

Jump to solution

Dear Andy

It is checking for exact version of openmotif package. We installed downgraded version of openmotif package and it was complaining. Once we installed exact version of openmotif package it went through.

This should be properly mentioned in pre-requisite section of what version of package you need to install.

View solution in original post

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: NPS 10.20 fails to install with RHEL 7.x

Jump to solution

Did you use the QCCR1B150910 hotfix to make this work?  I have been grappling with this but no success yet.

When I took a look at AppCheckReqdLibs.sh, it seems like "openmotif" libraries are not actually required for RHEL greater than 6.  Other research indicated that the "motif" libraries contain OpenMotif content these days.  I didn't realize the Motif stuff had been open-sourced back in 2012.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.