Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..
304 views

Unable to patch NNM Hotfix 23 (Postgres)

Jump to solution

I've followed the steps to install the Hotfix as given in the guide however I do not get a prompt to install. Attempting to run the nmshotfix.ovpl command pops up a window but closes the window when it attempts to extract the .zip

We are trying to upgrade a fresh build on Windows 2012 R2 from NNM 10.0 to NNM 10.2. Is there another way to apply the patch?

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Unable to patch NNM Hotfix 23 (Postgres)

Jump to solution

Folks,

  First point, the post is about Patch 23 the Postgres patch delivered as a hotfix, not the BSM integration hotfix.

  So to Patch 23.  This seems to be a common mistake, naming the hotfix incorrectly.  The Patch text instructions clearly state:

        1. Back up your system before installing a patch.

        2. A complete backup of NNMi  is recommended prior to applying this patch.
        Use $NnmInstalldir/bin/nnmbackup.ovpl script  to take NNMi backup.

        3. Rename the NNM1000L_00023 file provided to
        Hotfix-NNMI-10.0X-LIN-POSTGRESQL-20160331.zip before proceeding with the
        installation.

The name of the zip file needs to be "Hotfix-....."   and not the normal "HF......" name.   If the zip file is named HF....  then you will see the initial error reported.   The reason is that normally when we provide a hotfix via support the name of the hotfix  is "HOTFIX...."  however the internal delivery tool wraps the zip file with the readme file and calls it "HF.......".    When you run the hotfix tool against this zip file it detects this double zipping and notes the name of the hotfix is HOTFIX......, it then unzips this and then expects to find a directory of the same name, and in there a control file of the same name again.  So if you name this patch HF........   the directory in the zip file is not HF...... but HOTFIX........

  Sorry for the gory details but I thought a bit of "why" might help to understand what is going on and the reason for the naming

  hope this helps

Dave Y

MicroFocus Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of MicroFocus
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

4 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Unable to patch NNM Hotfix 23 (Postgres)

Jump to solution

Hello Mike

Thanks for porting

I think yuo can follow this steps:

->  Extract the hotfix in a folder.
      The name should be HF-NNMI-10.20-BSMINTEGRATION-20170405.zip

 * ovstop
      $NnmInstalldir>/bin/nnmtrapreceiver -stop                (Unix) (NNMi 10.x and above)
      %NnmInstalldir%\bin\nnm\amd64\nnmtrapreceiver -stop      (Windows) (NNMi 10.x and above)
*Open a command prompt window in the above directory.
* run the command:
          %NnmInstalldir%\support\nmshotfix.ovpl -i "Path where the zip file is located\HF-NNMI-10.20-BSMINTEGRATION-20170405.zip    (Windows)
* Follow the instructions on screen until you get the message "Hotfix installed correctly"

When the display shows a message indicating tha enter any key to continue you can press enter key

* ovstart

Hope this helps,

Regards,

Vincent Montenegro Mena
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Unable to patch NNM Hotfix 23 (Postgres)

Jump to solution

Folks,

  First point, the post is about Patch 23 the Postgres patch delivered as a hotfix, not the BSM integration hotfix.

  So to Patch 23.  This seems to be a common mistake, naming the hotfix incorrectly.  The Patch text instructions clearly state:

        1. Back up your system before installing a patch.

        2. A complete backup of NNMi  is recommended prior to applying this patch.
        Use $NnmInstalldir/bin/nnmbackup.ovpl script  to take NNMi backup.

        3. Rename the NNM1000L_00023 file provided to
        Hotfix-NNMI-10.0X-LIN-POSTGRESQL-20160331.zip before proceeding with the
        installation.

The name of the zip file needs to be "Hotfix-....."   and not the normal "HF......" name.   If the zip file is named HF....  then you will see the initial error reported.   The reason is that normally when we provide a hotfix via support the name of the hotfix  is "HOTFIX...."  however the internal delivery tool wraps the zip file with the readme file and calls it "HF.......".    When you run the hotfix tool against this zip file it detects this double zipping and notes the name of the hotfix is HOTFIX......, it then unzips this and then expects to find a directory of the same name, and in there a control file of the same name again.  So if you name this patch HF........   the directory in the zip file is not HF...... but HOTFIX........

  Sorry for the gory details but I thought a bit of "why" might help to understand what is going on and the reason for the naming

  hope this helps

Dave Y

MicroFocus Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of MicroFocus
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Unable to patch NNM Hotfix 23 (Postgres)

Jump to solution

So it turns out that the readme file that comes with the hotfix actually tells you to use HF as the name instead of Hotfix as Mr. Young had stated. Changing the name to Hotfix resolves the issue.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Unable to patch NNM Hotfix 23 (Postgres)

Jump to solution

Mike,

  Thanks for pointing this out.  Indeed, the readme file that is available in SSO does refer to naming the zip file as HOTFIX-...   however if you open up the zip file and then read the readme that comes inside the zip file this does refer to naming it HF-.....

  The reason why this has come about is because when the hotfixes are built the readme is documented on the assumption that the hotfix will have been provided via our internal delivery tool and this uses the double zip approach and the outer zip file is named HF-......

  I guess we assumed folks would read the readme file in SSO and then simply install the hotfix zip file having downloaded it but before opening and extracting it.

  Sorry for the confusion, but hopefully the explanation provides a little more insight into this tool.

  All the best

Dave Y

MicroFocus Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of MicroFocus
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.