UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
7223 views

Anybody success or failure in using a Sonicwall DHCP relay pointing to an OES2 SP3 SLES 10.3 dhcpd ??

I have setup the Sonicwall IP (10.50.0.1 and 10.70.0.1) as DHCP relay
(IP-helper for DHCP) for the network 10.50.x.x to the OES dhcp server
at 10.70.0.8.

A packet trace shows all requests and informs are forwarded to the
server, the server answers all requests and sends his replies to
10.50.0.1 and they are received by the sonicwall. Unfortunately only
the DHCP ACKs (I have sent the DHCP offers manually for testing on the
10.50.x.x network ) are send back to the correct network, the DHCP
OFFERS from the server end dead at the Sonicwall. So without manual
intervention no IP addresses for the clients.

Anybody seen similar (I have already opened a SR with Sonicwall) or any
clues?

--
W. Prindl

W. Prindl
Labels (2)
0 Likes
4 Replies
Absent Member.
Absent Member.

W_,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
Absent Member.
Absent Member.

Just for the records if anybody gets into the same trouble:

The Sonicwall software does only support reply packets, with the
broadcast flag set to on (1). Unfortunately that is nowhere documented
and even their support was not aware of that for quite some time.

So the solution is quite simple, set the always-broadcast flag in the
settings section of the server to True and everything starts to work.

--
W. Prindl


W_ Prindl wrote:

>I have setup the Sonicwall IP (10.50.0.1 and 10.70.0.1) as DHCP relay
>(IP-helper for DHCP) for the network 10.50.x.x to the OES dhcp server
>at 10.70.0.8.
>
>A packet trace shows all requests and informs are forwarded to the
>server, the server answers all requests and sends his replies to
>10.50.0.1 and they are received by the sonicwall. Unfortunately only
>the DHCP ACKs (I have sent the DHCP offers manually for testing on the
>10.50.x.x network ) are send back to the correct network, the DHCP
>OFFERS from the server end dead at the Sonicwall. So without manual
>intervention no IP addresses for the clients.
>
>Anybody seen similar (I have already opened a SR with Sonicwall) or
>any clues?


W. Prindl
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

W_Prindl;2130336 wrote:
Just for the records if anybody gets into the same trouble:

The Sonicwall software does only support reply packets, with the
broadcast flag set to on (1). Unfortunately that is nowhere documented
and even their support was not aware of that for quite some time.

So the solution is quite simple, set the always-broadcast flag in the
settings section of the server to True and everything starts to work.


Thanks for that feedback.

Never had to use that setting (but then I've not had the situation/setup you do with a SonicWall 🙂 ).

I am curious though if that setting can affect normal workings and Googling I found this: Brandon Checketts » Blog Archive » DHCP ‘always-broadcast’ confusion

But it also made me note a change that was made in Vista and again in Windows 7 in regard to DHCP broadcasts : DHCP Broadcast flag handling in Windows 7 - Microsoft Windows DHCP Team Blog - Site Home - TechNet Blogs

That made me curious which OS is involved that initially did not get the dhcp address?

Cheers,
Willem
0 Likes
Absent Member.
Absent Member.

Yes, that's an interesting thing.

Win7 had no problems at all as that tests both settings and switches
per interface to the working setting after the first successful dhcp
lease is obtained.

WinXP had problems because it tests both settings (at least after SP3)
but in a predefined order and not configurable, so you have a timeout
of 60 seconds till the lease is obtained.

And SLED 11 does - in a default configuration - only send dhcp requests
with the broadcast flag set to 0 thus getting replies with the same
flag - so it had problems, too.

But none of those clients have a problem with the broadcast flag set to
on - even if they send requests without this flag.

Therefore the change on the server side is easier and with less issues
IMO. Otherwise I'm pretty sure, that I'd ran into problems, if I change
networks with a laptop and have the client set to always send the
broadcast flag on - as the many google entries show regarding WinVista,
which seems to have/had that setting initially (I do/did not use Vista
at all - so no experiences with that OS)

Fortunately the DHCP server only serves this network and his local
network, which is almost unused by clients. But on a plain SLES dhcp
server i could set this setting per subnet and not only per server,
which of course would be a much nicer and less intrusive approach.
--

W. Prindl


magic31 wrote:

>
>W_Prindl;2130336 Wrote:
>> Just for the records if anybody gets into the same trouble:
>>
>> The Sonicwall software does only support reply packets, with the
>> broadcast flag set to on (1). Unfortunately that is nowhere
>>documented and even their support was not aware of that for quite
>>some time.
>> So the solution is quite simple, set the always-broadcast flag in
>>the settings section of the server to True and everything starts
>>to work.

>
>Thanks for that feedback.
>
>Never had to use that setting (but then I've not had the
>situation/setup you do with a SonicWall 🙂 ).
>
>I am curious though if that setting can affect normal workings and
>Googling I found this: 'Brandon Checketts » Blog Archive » DHCP
>‘always-broadcast’ confusion'
>(http://www.brandonchecketts.com/archives/dhcp-always-broadcast-confusion)
>
>But it also made me note a change that was made in Vista and again in
>Windows 7 in regard to DHCP broadcasts : 'DHCP Broadcast flag handling
>in Windows 7 - Microsoft Windows DHCP Team Blog - Site Home - TechNet
>Blogs'
>(http://blogs.technet.com/b/teamdhcp/archive/2009/02/12/dhcp-broadcast-flag-handling-in-windows-7.aspx)
>
>That made me curious which OS is involved that initially did not get
>the dhcp address?
>
>Cheers,
>Willem


W. Prindl
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.