marklar23 Absent Member.
Absent Member.
2653 views

Black Screen after OES2018 Upgrade

I am testing the OES2018 upgrade and made a clone of my GroupWise server that also runs Messenger, since SLES 12 is required to upgrade it, and relocated them to my test environment which is an isolated VMWare Workstation that has no Internet access. The upgrade process seems to work fine, I get the Ruby error after the package progress bar portion completes before the OES update happens. I just continue through that step, I brought over another server from the replica so that OES had something to talk to for the upgrade and it completed.

Now after I complete the upgrade process and the system reboots to go into normal operation, after the splash screen goes away I get a black screen. Occasionally I will see the same command line/startup (like after pushing the button to watch services start instead of the splash screen) but a login screen never appears. I can SSH into the machine and it appears that services are running, I just can't access the server directly from a GUI if I needed to. Has anyone else run into this issue and have a resolution? Thanks!
Labels (2)
0 Likes
14 Replies
mattjones1 Absent Member.
Absent Member.

Re: Black Screen after OES2018 Upgrade

I had this when I upgraded from OES 2015 to 2018 on XEN. Not sure it's the same but CTRL+ALT+F7 would get me to the graphical window or CTRL+ALT+F1 to get to non-graphical prompt.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Black Screen after OES2018 Upgrade

while i've never played with OES18 on VMWare WS i'd try adding
vga=0x317
to the boot options. hitting "e" (without the quotes) will bring you to the edit screen.
i'd also change the "splash" statement to
splash=verbose
0 Likes
lca25 Trusted Contributor.
Trusted Contributor.

Re: Black Screen after OES2018 Upgrade

marklar23;2475577 wrote:
I am testing the OES2018 upgrade and made a clone of my GroupWise server that also runs Messenger, since SLES 12 is required to upgrade it, and relocated them to my test environment which is an isolated VMWare Workstation that has no Internet access. The upgrade process seems to work fine, I get the Ruby error after the package progress bar portion completes before the OES update happens. I just continue through that step, I brought over another server from the replica so that OES had something to talk to for the upgrade and it completed.

Now after I complete the upgrade process and the system reboots to go into normal operation, after the splash screen goes away I get a black screen. Occasionally I will see the same command line/startup (like after pushing the button to watch services start instead of the splash screen) but a login screen never appears. I can SSH into the machine and it appears that services are running, I just can't access the server directly from a GUI if I needed to. Has anyone else run into this issue and have a resolution? Thanks!


I got the same after upgrading vmware guest oes2015sp1 to oes2018. I set the default runlevel to multi-user.target to get rid of the black screen and to allow login from the console.

I then logged in as root and issued 'startx' command while redirecting output to file. I got the following:

[INDENT]xauth: file /root/.serverauth.3929 does not exist


X.Org X Server 1.18.3
Release Date: 2016-04-04
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux vuh-lb-ds4 4.4.114-92.64-default #1 SMP Thu Feb 1 19:18:19 UTC 2018 (c6ce5db) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.114-92.64-default root=UUID=d421cfbf-acaf-48df-8557-b96f2e6c6439 resume=/dev/sda1 splash=silent quiet showopts
Build Date: 16 November 2017 09:28:20AM

Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 8 12:24:28 2018
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Parse error on line 44 of section Files in file /etc/X11/xorg.conf
Ignoring obsolete keyword "InputDevices".
Parse error on line 45 of section Files in file /etc/X11/xorg.conf
Ignoring obsolete keyword "InputDevices".
VMware: No 3D enabled (0, Success).
/etc/X11/xim: Checking whether an input method should be started.
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_GB.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
gnome-session-is-accelerated: llvmpipe detected.
** Message: couldn't access control socket: /run/user/0/keyring/control: No such file or directory
** Message: couldn't access control socket: /run/user/0/keyring/control: No such file or directory
SSH_AUTH_SOCK=/run/user/0/keyring/ssh

(gnome-shell:4003): Gvc-WARNING **: Failed to connect context: OK
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
W: [pulseaudio] authkey.c: Failed to open cookie file '/root/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/root/.config/pulse/cookie': No such file or directory
E: [pulseaudio] main.c: Daemon startup failed.
gnome-session-binary[3954]: WARNING: App 'pulseaudio.desktop' exited with code 1
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 106]: anonymous function does not always return a value
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 108]: anonymous function does not always return a value
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 166]: octal literals and octal escape sequences are deprecated
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 166]: octal literals and octal escape sequences are deprecated
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 166]: octal literals and octal escape sequences are deprecated

** (gnome-settings-daemon:4053): WARNING **: Schemas 'org.gnome.desktop.a11y' has not been setup

(gnome-settings-daemon:4053): Gvc-WARNING **: Failed to connect context: OK
vmware-user: could not open /proc/fs/vmblock/dev

(nautilus:4085): Gtk-WARNING **: Theme parsing error: <broken file>:1:0: Failed to import: The resource at '/org/gnome/libgd/tagged-entry/default.css' does not exist

** (nautilus:4085): WARNING **: Can not get _NET_WORKAREA

** (nautilus:4085): WARNING **: Can not determine workarea, guessing at layout
gnome-session-binary[3954]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11

(gnome-settings-daemon:4053): common-plugin-WARNING **: Failed to construct RR screen: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Mutter.DisplayConfig was not provided by any .service files

(gnome-settings-daemon:4053): color-plugin-WARNING **: failed to get screens: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Mutter.DisplayConfig was not provided by any .service files

(gnome-settings-daemon:4053): wacom-plugin-WARNING **: Failed to create GnomeRRScreen: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Mutter.DisplayConfig was not provided by any .service files

(gnome-settings-daemon:4053): power-plugin-WARNING **: Could not create GnomeRRScreen: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Mutter.DisplayConfig was not provided by any .service files


(gnome-settings-daemon:4053): media-keys-plugin-WARNING **: Failed to grab accelerators: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.10 was not provided by any .service files (2)

(gnome-shell:4118): Gvc-WARNING **: Failed to connect context: OK
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 106]: anonymous function does not always return a value
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 108]: anonymous function does not always return a value
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 166]: octal literals and octal escape sequences are deprecated
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 166]: octal literals and octal escape sequences are deprecated
Gjs-Message: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 166]: octal literals and octal escape sequences are deprecated

(gnome-settings-daemon:4053): media-keys-plugin-WARNING **: Failed to grab accelerators: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus) (4)
gnome-session-binary[3954]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
gnome-session-binary[3954]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Unable to init server: Could not connect: Connection refused

** (gnome-session-failed:4142): WARNING **: Cannot open display:
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.
[/INDENT]

Could this be the display size causing an issue? PulseAudio?

Scratching my head, although the answer is probably right there in front of me.

Larry
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Black Screen after OES2018 Upgrade

Hi,

have you seen https://www.novell.com/support/kb/doc.php?id=7022687
(since it wasn't mentioned in this thread yet)?

Franz

0 Likes
lca25 Trusted Contributor.
Trusted Contributor.

Re: Black Screen after OES2018 Upgrade

Hi

Yes, had applied this TID prior to upgrading. This TID deals with inability to boot into the upgrade process.

Regards, Larry
0 Likes
lca25 Trusted Contributor.
Trusted Contributor.

Re: Black Screen after OES2018 Upgrade

Managed to acquire the output from a good SLES12sp2 startx xsession:

[INDENT]xauth: file /root/.serverauth.26530 does not exist
xauth: file /root/.Xauthority does not exist
xauth: file /root/.Xauthority does not exist


X.Org X Server 1.15.2
Release Date: 2014-06-27
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux vuh-la-cas5 3.12.74-60.64.40-default #1 SMP Wed May 10 05:07:16 UTC 2017 (4eb35ec) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.12.74-60.64.40-default root=UUID=fb98915f-e581-47c9-b85c-015913ffb175 resume=/dev/sda1 splash=silent quiet showopts crashkernel=100M,high crashkernel=72M,low
Build Date: 16 February 2016 04:59:15PM

Current version of pixman: 0.32.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 9 14:28:06 2018
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension DRI2
Loading extension GLX
VMware: No 3D enabled (0, Success).
/etc/X11/xim: Checking whether an input method should be started.
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_GB.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
gnome-session-is-accelerated: llvmpipe detected.
GNOME_KEYRING_CONTROL=/run/user/0/keyring-v7pgFj
GPG_AGENT_INFO=/run/user/0/keyring-v7pgFj/gpg:0:1
GNOME_KEYRING_PID=26578
GNOME_KEYRING_CONTROL=/run/user/0/keyring-v7pgFj
GPG_AGENT_INFO=/run/user/0/keyring-v7pgFj/gpg:0:1
GNOME_KEYRING_CONTROL=/run/user/0/keyring-v7pgFj
GPG_AGENT_INFO=/run/user/0/keyring-v7pgFj/gpg:0:1
GNOME_KEYRING_CONTROL=/run/user/0/keyring-v7pgFj
GPG_AGENT_INFO=/run/user/0/keyring-v7pgFj/gpg:0:1
SSH_AUTH_SOCK=/run/user/0/keyring-v7pgFj/ssh
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Compat map for group 2 redefined
> Using new definition
> Warning: Compat map for group 3 redefined
> Using new definition
> Warning: Compat map for group 4 redefined
> Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Compat map for group 2 redefined
> Using new definition
> Warning: Compat map for group 3 redefined
> Using new definition
> Warning: Compat map for group 4 redefined
> Using new definition
Errors from xkbcomp are not fatal to the X server
Gjs-Message: JS LOG: GNOME Shell started at Fri Mar 09 2018 14:28:09 GMT+0000 (GMT)
Initializing nautilus-open-terminal extension
vmware-user: could not open /proc/fs/vmblock/dev

(nautilus:26687): GLib-GObject-CRITICAL **: g_object_new_valist: object class 'NautilusLocationEntry' has no property named 'max-width-chars'

** (nautilus:26687): WARNING **: Can not get _NET_WORKAREA

** (nautilus:26687): WARNING **: Can not determine workarea, guessing at layout

(gnome-shell:26646): Gjs-WARNING **: JS ERROR: [boxed instance proxy GIName:GLib.Error jsobj@0x7f4d45018370 native@0x40a5880]

(gnome-shell:26646): Gjs-WARNING **: JS ERROR: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.settings.modify.system is not registered
NMApplet<._tryLateInit@/usr/share/gnome-shell/js/ui/status/network.js:1500
wrapper@/usr/share/gjs-1.0/lang.js:213
NMApplet<._remoteSettingsGot@/usr/share/gnome-shell/js/ui/status/network.js:1475
wrapper@/usr/share/gjs-1.0/lang.js:213

Window manager warning: Log level 16: STACK_OP_ADD: window 0x1600001 already in stack
Window manager warning: Log level 16: STACK_OP_ADD: window 0x1600001 already in stack
Window manager warning: Log level 32: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 105]: anonymous function does not always return a value
Window manager warning: Log level 32: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 107]: anonymous function does not always return a value
Window manager warning: Log level 32: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 165]: octal literals and octal escape sequences are deprecated
Window manager warning: Log level 32: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 165]: octal literals and octal escape sequences are deprecated
Window manager warning: Log level 32: JS WARNING: [/usr/share/gnome-shell/extensions/apps-menu@gnome-shell-extensions.gcampax.github.com/extension.js 165]: octal literals and octal escape sequences are deprecated
[/INDENT]
0 Likes
Knowledge Partner
Knowledge Partner

Re: Black Screen after OES2018 Upgrade

which hardware version are you running on? how much memory is allocated to the virtual video adapter?
0 Likes
lca25 Trusted Contributor.
Trusted Contributor.

Re: Black Screen after OES2018 Upgrade

My mistake...last info was from a sles12sp1 box.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Black Screen after OES2018 Upgrade

marklar23 wrote:

> Now after I complete the upgrade process and the system reboots to go
> into normal operation, after the splash screen goes away I get a black
> screen.


VMware support for guest operating system upgrade (2018695)
https://kb.vmware.com/s/article/2018695


> VMware does not support the installation of major update releases on
> an operating system as an upgrade in a virtual machine, such as
> Windows 7 to Windows 8 or RHEL 5.x to RHEL 6.0. VMware recommends the
> installation of a new major releases in a new virtual machine.



--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below this post.
Thank you.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
davemrm Super Contributor.
Super Contributor.

Re: Black Screen after OES2018 Upgrade

KBOYLE;2476973 wrote:
marklar23 wrote:

VMware support for guest operating system upgrade (2018695)
https://kb.vmware.com/s/article/2018695


> VMware does not support the installation of major update releases on
> an operating system as an upgrade in a virtual machine, such as
> Windows 7 to Windows 8 or RHEL 5.x to RHEL 6.0. VMware recommends the
> installation of a new major releases in a new virtual machine.


Does anyone really believe that kb article is anything other than a "cover our a$$" thing so that you can't bother vmware about it? Sure, major version upgrades are always potentially messy, but surely an otherwise supported upgrade path doesn't become magically unworkable just because you're running on VMWare. VMware doesn't want to support it, but that doesn't mean there's any reason it won't work.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Black Screen after OES2018 Upgrade

davemrm wrote:

> but that doesn't mean there's any reason it won't work.


That doesn't *necessarily* mean there's any reason it won't work. There
may be reasons or specific situations about which they do not want to
elaborate.

If it works, great! If not, well you were warned...

--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below this post.
Thank you.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.