jfeyen
New Member.
1609 views

CIFS not working for only one volume on new OES2015

Hi,

This weekend we installed a new OES2015 server.

CIFS works fine for 2 volumes.
For only one volume it is not working..

NCP works fine.
NSS volume is mounted.

If I create a new share for that volume in iManager:
Error: Storage Error

Missing or invalid directory path for the CIFS share.

less /var/log/messages:
Dec 7 10:18:23 oesxxx adminusd: CIFS: MNSS_CIFSAddShare
Dec 7 10:18:23 oesxxx adminusd: Data Successfully Written
Dec 7 10:18:23 oesxxx adminusd: Data is successfully passed with the pipe 5
Dec 7 10:18:23 oesxxx adminusd: NSS:CIFS:RecvDataFrom_Server
Dec 7 10:18:23 oesxxx adminusd: Command failed
Dec 7 10:18:23 oesxxx adminusd: Status Value = 22101


less /var/log/cifs/cifs.log
Dec 7 10:08:23 oes0103 CIFS[25374]: ERROR: CODIR: AddShadowVolumeInfoToVCD: Shadow path "/shadowhome" does not exists on an NSS volume
Dec 7 10:08:23 oesxxx CIFS[25374]: WARNING: CODIR: AddVolumeToDirCache: Failed to add shadow volume info to volume: HOME, error: -1
Dec 7 10:08:23 oesxxx CIFS[25374]: ERROR: RPC: GetVolumesList: Failed to add volume "HOME" into CIFS list, error: -1

How can this be fixed?

Joeri
Labels (1)
0 Likes
4 Replies
jfeyen
New Member.

Re: CIFS not working for only one volume on new OES2015

I tested and AFP works on this volume.

Could it be that CIFS is not compatible with the DST which is enabled on the volume?

tx,

Joeri
0 Likes
mdallair Absent Member.
Absent Member.

Re: CIFS not working for only one volume on new OES2015

Hi Joeri,

It's in the doc so it should support it.

https://www.novell.com/documentation/oes2015/stor_dst_lx/data/bq3dvrh.html

Martin
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: CIFS not working for only one volume on new OES2015

Hello,

have you tried TID 7013095 (and the TIDs there listed within)?
Especially make shure that the nfapCIFSShares attribute is ok.

Regards

Burkhard Wiegand
0 Likes
jfeyen
New Member.

Re: CIFS not working for only one volume on new OES2015

wiegandb;2413219 wrote:
Hello,

have you tried TID 7013095 (and the TIDs there listed within)?
Especially make shure that the nfapCIFSShares attribute is ok.

Regards

Burkhard Wiegand


Hi,

I checked those attributes , nothing was wrong there.
In the mean time I removed the shadow volume and restarted cifs. Issue resolved 🙂
Maybe I misconfigured DST but I don't need it anymore so I removed it.

Joeri
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.