butley Absent Member.
Absent Member.
4092 views

Can't access Remote Manager

I have 2 Netware 6.5 SP8 servers (the other 40 work fine) all configured the same way and updated with the latest patches that I can't get RM to work on. I http to it and get a funky looking screen with red X's all over the place. I tried to run RM via gui on both servers and get the same result. nile.nlm, portal.nlm and httpk are all loaded fine. Apache and Tomcat appear to be working fine as well. I ran PKIDIAG to check the certs and they are ok also. Running out of options....will probably try to reinstall RM next....
Labels (2)
0 Likes
11 Replies
jdlf_wf4 Absent Member.
Absent Member.

Re: Can't access Remote Manager

Hi,

Check the following on the SYS:LOGIN directory on both servers
- Trustee assignment for [Public] with Read and Filescan rights
- Check the contents of the SYS:LOGIN directory, copy the SYS:LOGIN contents from another working Remote Manager server to the non working, without overwriting any existing files.

Hope this helps.

Cheers,
Johan
0 Likes
butley Absent Member.
Absent Member.

Re: Can't access Remote Manager

jdlf_wf4;2000731 wrote:
Hi,

Check the following on the SYS:LOGIN directory on both servers
- Trustee assignment for [Public] with Read and Filescan rights
- Check the contents of the SYS:LOGIN directory, copy the SYS:LOGIN contents from another working Remote Manager server to the non working, without overwriting any existing files.

Hope this helps.

Cheers,
Johan
0 Likes
butley Absent Member.
Absent Member.

Re: Can't access Remote Manager

Johan, thanks your response helped with one of my servers. It had only 4 files in the main Login folder....copied over all the files from another server and it works now. The other server however still has issues. The Red x's are now gone but it takes me to the iMonitor screen not iManager? Any idea's about that?
0 Likes
jdlf_wf4 Absent Member.
Absent Member.

Re: Can't access Remote Manager

So if you login it goes to iMonitor instead of Remote Manager?
I've never seen that before, what you could do is create a backup of the LOGIN directory and copy it over from another working SP8 server.

By the way, it also doesn't work if you go to https://yourip:8009/portal ?

Cheers,
Johan
0 Likes
butley Absent Member.
Absent Member.

Re: Can't access Remote Manager

Correct when I login it takes me to iMonitor. I tried to https://myip:8009/portal and it comes up page not found. If I don't add the /portal to it it goes to iMonitor. I will try your suggestion of copying over the entire login folder...can't hurt....thanks again.
0 Likes
jdlf_wf4 Absent Member.
Absent Member.

Re: Can't access Remote Manager

What you could also do if you have the ISO's of NW65SP8 is to open the PROD ISO with winrar and in the ISO browse to the PRODUCTS\NRM folder.
There you'll find the original NWPORTAL.ZIP which contains everything you need for Remote Manager.

Also double check the file SYS\SYSTEM\ipconf\httpstk\AppConf.xml
This file contains the IP configuration for HTTPSTK, this file should be OK, as you can access the iMonitor, but check it anyway 🙂
0 Likes
butley Absent Member.
Absent Member.

Re: Can't access Remote Manager

Just discovered that Portal.nlm is not loaded and won't load...have to check why....
0 Likes
butley Absent Member.
Absent Member.

Re: Can't access Remote Manager

Found on the web that Portal.nlm has to be loaded before Ndsimon.nlm in the Autoexec. I went to look to see what the order was and there was no load line for Portal.nlm.....could have sworn it was already loaded. Anyhow I tried to unload Ndsimon and then load portal but it still would not load. The web link says the server needs to be rebooted. Will do that in the morning ...thanks again Johan for all of your help.
0 Likes
jdlf_wf4 Absent Member.
Absent Member.

Re: Can't access Remote Manager

No problem and keep us posted!

Cheers,
Johan
0 Likes
butchhm Absent Member.
Absent Member.

Re: Can't access Remote Manager

Hi, I have a similar problem on a Netware 6.5 SP8 system in that earlier today I was accessing NRM with no problems from within my vCenter console. Suddenly I can no longer login (nothing happens after I press the login button) and the Novell logo images do not display. I did install VMtools sometime during the day but am not absolutely sure this has anything to do with it. Anyhow I removed VMtools and rebooted to no avail.

I tried accessing remotely through IE and Firefox. After going through the usual certificate error it shows page not found at URL https://ip007.bondi.asc:8009/sys/login/status_normal.gif but when I remove the /sys/login/status_normal.gif from the URL and hit enter it does find the front menu selections and I can see/select all the usual selections but none of the images display. I looked at the properties of the images and they specify a path like the following: /sys/login/new_Novellogo.gif. However, I actually find the image on path /sys/login/NRMGroups/new_Novellogo.gif...

So...any ideas how I fix it? Any ideas how it all fell apart?!

Cheers, HMB
0 Likes
jdlf_wf4 Absent Member.
Absent Member.

Re: Can't access Remote Manager

Hi,

This is usually seen when the [public] trustee is not set or missing.

What could have caused that NRM stops working I'm not sure, I've only seen it a couple of times and it usually turned out that the LOGIN directory was missing certain files for NRM.

You mention that you find the new_Novelllogo.gif in the NRMGroups directory, however that is not that place where it should be, it should be directly under the login directory.
Otherwise get the NWPORTAL.ZIP from the NW65SP8 products CD as a refference.

Cheers,
Johan
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.