tiacovone
New Member.
839 views

Cannot open port

I hope I'm posting in the correct forum.

This server is SLES11.4 with OES2015. I am trying to add it in to our Barracuda Backup schedule. I am having trouble with the bbagent.
I have discovered that the port 5120 is closed. All communication is internal so I thought these ports should always be accessible. I have
checked via nmap -p 5120 192.168.2.0/24 and it reports (5120/tcp closed unknown) The firewall is not running also. We have an identical server
running with no issue. Can someone offer any suggestion as to help with this matter.

If post is in the wrong forum I apologize. Let me know.

Tom
Labels (2)
0 Likes
12 Replies
Knowledge Partner
Knowledge Partner

Re: Cannot open port

Is the agent started at all? If not, which kind of error does it throw on a start attempt?
What does "netstat -anp |grep 5120" show?
Can you open a listener with something like "netcat -lv -p 5120" ?
0 Likes
Knowledge Partner
Knowledge Partner

Re: Cannot open port

tiacovone wrote:

> I have discovered that the port 5120 is closed.


I assume your bbagent is supposed to listen on port 5120?

My guess is that it is not listening. Perhaps a configuration issue?


--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below this post.
Thank you.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
tiacovone
New Member.

Re: Cannot open port

Pasta:~ # netstat -anp |grep 5120
Pasta:~ # netcat -lv -p 5120
listening on [any] 5120 ...

netstat -anp |grep 5120 as shown above did not show anything and
netcat -lv -p 5120 was just listening until cancelled.

I don't believe the agent is running although it did say installed successfully.

Pasta:/etc/init.d # bbagent start
If 'bbagent' is not a typo you can run the following command to lookup the package that contains the binary:
command-not-found bbagent
-bash: bbagent: command not found

I get the above whether I try start, stop or restart
0 Likes
tiacovone
New Member.

Re: Cannot open port

I would tend to agree that it is a config issue but I'm lost,
sorry.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Cannot open port

If the shell prompt currently "resides" in /etc/init.d you'd have to attempt something like
./bbagent start
0 Likes
tiacovone
New Member.

Re: Cannot open port

Thank you, using (./bbagent) started the backup service and opened the port!
The agent was suppose to start automatically after installation. I am wondering after a reboot
if it will start automatically?
0 Likes
Knowledge Partner
Knowledge Partner

Re: Cannot open port

Try something like
chkconfig --list bbagent
If it shows "on" for runlevels 3 and 5 you should be fine. If it shows "off" all across the board issue
chkconfig bbagent on
and recheck.
0 Likes
tiacovone
New Member.

Re: Cannot open port

Here is what I got below, is it OK now?


Pasta:~ # chkconfig --list bbagent
bbagent 0:off 1:off 2:off 3:off 4:off 5:off 6:off
Pasta:~ # chkconfig bbagent on
insserv: Service network is missed in the runlevels 4 to use service openslp
insserv: Service syslog is missed in the runlevels 4 to use service bbagent
Pasta:~ # chkconfig --list bbagent
bbagent 0:off 1:off 2:on 3:on 4:on 5:on 6:off
0 Likes
Knowledge Partner
Knowledge Partner

Re: Cannot open port

tiacovone Wrote in message:

> Here is what I got below, is it OK now?
>
>
> Pasta:~ # chkconfig --list bbagent
> bbagent 0:off 1:off 2:off 3:off 4:off 5:off
> 6:off
> Pasta:~ # chkconfig bbagent on
> insserv: Service network is missed in the runlevels 4 to use service
> openslp
> insserv: Service syslog is missed in the runlevels 4 to use service
> bbagent
> Pasta:~ # chkconfig --list bbagent
> bbagent 0:off 1:off 2:on 3:on 4:on 5:on
> 6:off


First things first, is Barracuda able to connect to your server
and back it up? Based on the output above I think things should
now work with port 5120 available.

What the output of "chkconfig bbagent on" does show is that things
probably won't work if you're running your server in runlevel 4
which is unlikely as most servers run at 3 (text only) or 5 (with
GUI) so probably best if you disable bbagent from running in
runlevel 4. You can do this using "chkconfig --level 4 bbagent
off".

HTH.
--
Simon Flood
Micro Focus Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/
0 Likes
Knowledge Partner
Knowledge Partner

Re: Cannot open port

This should likely be ok for you. As runlevel 2 doesn't provide network support and level 4 is rarely used you might want to switch these off (what you normally want for such a service is 3 and 5), but i'd strongly doubt that it would harm to keep it as it is.
0 Likes
tiacovone
New Member.

Re: Cannot open port

mathiasbraun;2494675 wrote:
This should likely be ok for you. As runlevel 2 doesn't provide network support and level 4 is rarely used you might want to switch these off (what you normally want for such a service is 3 and 5), but i'd strongly doubt that it would harm to keep it as it is.


Thanks so much for your help, it is very appreciated.
Regards,
Tom Iacovone
0 Likes
Knowledge Partner
Knowledge Partner

Re: Cannot open port

Glad to help.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.