Highlighted
Absent Member.
Absent Member.
2225 views

Catalogs OES2-SP3-Updates and OES2-SP3-Pool Missing from svr

I've got a SLES 10 sp4 non 64 bit server that I recently registered to an SMT server I created. It will not get updates for OES2 no matter what I try. It is stuck at version 20604.10 and all my other servers are at 20606.01. I have tried what is listed here: Support | Updates catalog missing after registration of OES2 (subbed in commands to register it back to my smt server) and have had no luck on it working. When I go into online updates, it seems like it doesn't even scan my smt server. Also, when I check to see what catalogs are available, i only see checkboxes for SLES and Open Enterprise Server. My other servers show checkboxes for OES-SP3-Updates, Pool and Online.

How do i make those catalogs available to this server?
Labels (2)
0 Likes
7 Replies
Highlighted
Absent Member.
Absent Member.

Try re-registering your server with the SMT. You might also want to check to make sure your server is actually registered.

--El

postaszewski;2197404 wrote:
I've got a SLES 10 sp4 non 64 bit server that I recently registered to an SMT server I created. It will not get updates for OES2 no matter what I try. It is stuck at version 20604.10 and all my other servers are at 20606.01. I have tried what is listed here: Support | Updates catalog missing after registration of OES2 (subbed in commands to register it back to my smt server) and have had no luck on it working. When I go into online updates, it seems like it doesn't even scan my smt server. Also, when I check to see what catalogs are available, i only see checkboxes for SLES and Open Enterprise Server. My other servers show checkboxes for OES-SP3-Updates, Pool and Online.

How do i make those catalogs available to this server?

El LaGrew elbert.lagrew#katun.com elagrew on twitter
0 Likes
Highlighted
Absent Member.
Absent Member.

elagrew;2197619 wrote:
Try re-registering your server with the SMT. You might also want to check to make sure your server is actually registered.

--El


I've tried to re-register, no luck. I also have checked to see if its registered with my SMT server, and it is.
0 Likes
Highlighted
Absent Member.
Absent Member.

DATA:/tmp # rug ca

Sub'd? | Name | Service
-------+-------------------------------------+------------------------------------
Yes | SUSE Linux Enterprise Server 10 SP3 | SUSE Linux Enterprise Server 10 SP3
Yes | Novell Open Enterprise Server 2 SP3 | Novell Open Enterprise Server 2 SP3

DATA:/tmp # rug sl

# | Status | Type | Name | URI
--+--------+------+-------------------------------------+-----------------------
1 | Active | ZYPP | SUSE Linux Enterprise Server 10 SP3 | cd:///?devices=/dev...
2 | Active | ZYPP | Novell Open Enterprise Server 2 SP3 | iso:///?iso=oes2sp3...
3 | Active | NU | http://smt.skokie68.org | http://smt.skokie68...

DATA:/tmp # rug sub OES2-SP3-Updates
ERROR: 'OES2-SP3-Updates' is not a valid catalog.
DATA:/tmp #

I can't even use the rug sub command to add the catalogs... See the error above.
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

postaszewski;2197808 wrote:
DATA:/tmp # rug ca

Sub'd? | Name | Service
-------+-------------------------------------+------------------------------------
Yes | SUSE Linux Enterprise Server 10 SP3 | SUSE Linux Enterprise Server 10 SP3
Yes | Novell Open Enterprise Server 2 SP3 | Novell Open Enterprise Server 2 SP3

DATA:/tmp # rug sl

# | Status | Type | Name | URI
--+--------+------+-------------------------------------+-----------------------
1 | Active | ZYPP | SUSE Linux Enterprise Server 10 SP3 | cd:///?devices=/dev...
2 | Active | ZYPP | Novell Open Enterprise Server 2 SP3 | iso:///?iso=oes2sp3...
3 | Active | NU | http://smt.skokie68.org | http://smt.skokie68...

DATA:/tmp # rug sub OES2-SP3-Updates
ERROR: 'OES2-SP3-Updates' is not a valid catalog.
DATA:/tmp #

I can't even use the rug sub command to add the catalogs... See the error above.


Same problem here, but im on SLES 10 SP4 and OES 2 SP3, are there any solutions for this?

ERROR: 'OES2-SP3-Updates' is not a valid catalog.
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

No success, and now i even don´t have the OES channel in rug sl
if i try to add it, it says: already installed

i tried everything i could google 😕
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

It worked... i did this: Support | Updates catalog missing after registration of OES2 without success, then changed the oes registration key, did Support | Updates catalog missing after registration of OES2 again and had no success, changed the registration key for oes a last time and it worked... it added everything i needed via the ncc...

the old key worked for the last upgrades...

so, maybe it will rescue someones life in the future 😄
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.