Anonymous_User Absent Member.
Absent Member.
2479 views

Client is ignores 'Preferred Network Protocol' setting

G'day!

Client32 v4.91SP4 + almost all latest updates, workstations
win2000/XP/2003. Network is Nw4.11, 5.1 and 6.5 servers, so we have
set IP + IPX on workstations and on 5.1/6.5 servers, too.

Problem: some workstations fully ignore setting 'Preferred Network
Protocol = IP' and connect to NW6.5 servers with IPX only. I may to
force IP connection from this workstation by choosing FQDN or
IP-address for NW6.5 servers in command, like this:

net use x: \\server.domain.com\data

But use of short name for servers always leads to connection on IPX
for this problem worksations.

Why setting 'Preferred Network Protocol = IP' is ignored? It occurs
not at all workstation but only on a few including my main admin
computer (client and settings exactly same for 'good' and 'bad'
workstations).


TIA,
Sergei Dubrov
Labels (1)
0 Likes
10 Replies
Marcel_Cox Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

You probably have a name resolution problem. The client is unable to resolve your server name through IP and therefore uses an IPX connection.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

G'day!

On Thu, 13 Mar 2008 10:46:01 GMT, Marcel Cox
<Marcel_Cox@no-mx.forums.novell.com> wrote:

>
>You probably have a name resolution problem. The client is unable to
>resolve your server name through IP and therefore uses an IPX
>connection.


If I simply 'ping shortservername' - it's works. If I temporaly
disable IPX on problem workstation and made connection to NW6.5 server
by short name something like 'net use x: \\shortservername\data' -
it's normally connect with IP. And at last - two similar workstations
with equal Client32 version/setting behave differently - one very
'like' IPX but another - IP while connect to the SAME NW6.5 server.

I tried to capture network packets for problem ws when connected to
server for study - look like station has completely solved inside of
itself what protocol to use and very first packet from station to
server is IPX - non any IP attempts :-(.

WBR,
Sergei Dubrov
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting


G'day!

On Fri, 14 Mar 2008 03:27:18 GMT, Sergei V. Dubrov <Dubrov@inp.nsk.su>
wrote:

>G'day!
>
>On Thu, 13 Mar 2008 10:46:01 GMT, Marcel Cox
><Marcel_Cox@no-mx.forums.novell.com> wrote:
>
>>
>>You probably have a name resolution problem. The client is unable to
>>resolve your server name through IP and therefore uses an IPX
>>connection.

>
>If I simply 'ping shortservername' - it's works. If I temporaly
>disable IPX on problem workstation and made connection to NW6.5 server
>by short name something like 'net use x: \\shortservername\data' -
>it's normally connect with IP. And at last - two similar workstations
>with equal Client32 version/setting behave differently - one very
>'like' IPX but another - IP while connect to the SAME NW6.5 server.
>
>I tried to capture network packets for problem ws when connected to
>server for study - look like station has completely solved inside of
>itself what protocol to use and very first packet from station to
>server is IPX - non any IP attempts :-(.


I tested some workstations with old 4.83sp2 client and look like with
this version of client setting 'Preferred Network Protocol = IP' works
finely - all connections to NW6.5 were made over IP not by IPX. After
updating client to 4.91sp4 workstation begin to connect to the same
server by casual way - or IP or IPX - unpredictable behavior 😞


WBR,
Sergei Dubrov
0 Likes
Marcel_Cox Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

Maybe you see the result of a timing issue. With the 4.9x clients, you get
the new features of bad name and bad address caching. These will make the
client "remember" for a certain time (5 minutes by default) that a server
is not accessible. Sometimes, depending on your overall network
configuration, it is possible that your client tries to connect to the
server before the network is fully initialized. In that case, the
connection will fail and the server is flagged for 5 minutes as non
available for the protocol used (e.g. IP in that case). So the client will
try to use IPX instead.
Try to go into the client's advanced properties and set the bad address
cache to 0 and see if that makes a difference.

--
Marcel Cox
http://support.novell.com/forums
------------------------------------------------------------------------
Marcel_Cox's Profile: http://forums.novell.com/member.php?userid=8
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

Sergei V. Dubrov <Dubrov@inp.nsk.su> wrote:

> I tested some workstations with old 4.83sp2 client and look like with
> this version of client setting 'Preferred Network Protocol = IP' works
> finely - all connections to NW6.5 were made over IP not by IPX. After
> updating client to 4.91sp4 workstation begin to connect to the same
> server by casual way - or IP or IPX - unpredictable behavior 😞


In addition to Marcel's good ideas, another possibility that comes to
my mind is the fact that the later clients added SLPv2 support. It
could be that the later client's attempt to use both SLPv2 and SLPv1
is delaying or in some way causing the name resolution to fail.

So you might also try setting the "SLP Protocol Version" to "SLPv1
only" and see if that makes any difference to the reliability of
getting the connection over IP.

Alan Adams
alancrumbadams@drcrumb.com
(for email, remove the crumbs)
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

G'day!

On Fri, 14 Mar 2008 21:38:09 GMT, Alan Adams
<alancrumbadams@drcrumb.com> wrote:

>Sergei V. Dubrov <Dubrov@inp.nsk.su> wrote:
>
>> I tested some workstations with old 4.83sp2 client and look like with
>> this version of client setting 'Preferred Network Protocol = IP' works
>> finely - all connections to NW6.5 were made over IP not by IPX. After
>> updating client to 4.91sp4 workstation begin to connect to the same
>> server by casual way - or IP or IPX - unpredictable behavior 😞

>
>In addition to Marcel's good ideas, another possibility that comes to
>my mind is the fact that the later clients added SLPv2 support. It
>could be that the later client's attempt to use both SLPv2 and SLPv1
>is delaying or in some way causing the name resolution to fail.


My setting for SLP Version is SLPv2 for all our new installation not
default Auto. But I think this not a reason - as I wrote earlier I
tested connection with network sniffer software and on problem station
I did not see any ip packet (slp) only ipx.

>
>So you might also try setting the "SLP Protocol Version" to "SLPv1
>only" and see if that makes any difference to the reliability of
>getting the connection over IP.


I shall try, thanks!

>
>Alan Adams
>alancrumbadams@drcrumb.com
>(for email, remove the crumbs)


WBR,
Sergei Dubrov
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

G'day!

On Fri, 14 Mar 2008 21:09:58 GMT, "Marcel Cox"
<Marcel_Cox@no-mx.forums.novell.com> wrote:

>Maybe you see the result of a timing issue. With the 4.9x clients, you get
>the new features of bad name and bad address caching. These will make the
>client "remember" for a certain time (5 minutes by default) that a server
>is not accessible. Sometimes, depending on your overall network
>configuration, it is possible that your client tries to connect to the
>server before the network is fully initialized. In that case, the
>connection will fail and the server is flagged for 5 minutes as non
>available for the protocol used (e.g. IP in that case). So the client will
>try to use IPX instead.
>Try to go into the client's advanced properties and set the bad address
>cache to 0 and see if that makes a difference.


O, it's look very similar on the true reason - I shall try to play
with bad address caching (on Monday). As I see here are few bad
caching setting: bad address cache timeout, bad server name caching
enable, bad server name caching timeout - I'll try to change all.

Thanks!

WBR,
Sergei Dubrov
0 Likes
Knowledge Partner
Knowledge Partner

Re: Client is ignores 'Preferred Network Protocol' setting

Hi,

"Sergei V. Dubrov" wrote:
>
> O, it's look very similar on the true reason - I shall try to play
> with bad address caching (on Monday). As I see here are few bad
> caching setting: bad address cache timeout, bad server name caching
> enable, bad server name caching timeout - I'll try to change all.


Note that *if* this turns out to be the problem, then the real core
culprit is your physical network infrastructure, not the client. The
issue are switches that signal a succesful link to the conected nic, but
then aren't able to transfer any data (yet) on the signalled link. Gear
doing this is violating IEEE standards, but as its mostly Cisco with
that issue....

Anyways, check for the port settings on the switches, especially
"portfast" or similar need to be enabled on WS-connecting switches.

CU,
--
Massimo Rosen
Novell Product Support Forum Sysop
No emails please!
http://www.cfc-it.de
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

G'day!

On Sat, 15 Mar 2008 10:22:21 GMT, Sergei V. Dubrov <Dubrov@inp.nsk.su>
wrote:

>G'day!
>
>On Fri, 14 Mar 2008 21:09:58 GMT, "Marcel Cox"
><Marcel_Cox@no-mx.forums.novell.com> wrote:
>
>>Maybe you see the result of a timing issue. With the 4.9x clients, you get
>>the new features of bad name and bad address caching. These will make the
>>client "remember" for a certain time (5 minutes by default) that a server
>>is not accessible. Sometimes, depending on your overall network
>>configuration, it is possible that your client tries to connect to the
>>server before the network is fully initialized. In that case, the
>>connection will fail and the server is flagged for 5 minutes as non
>>available for the protocol used (e.g. IP in that case). So the client will
>>try to use IPX instead.
>>Try to go into the client's advanced properties and set the bad address
>>cache to 0 and see if that makes a difference.

>
>O, it's look very similar on the true reason - I shall try to play
>with bad address caching (on Monday). As I see here are few bad
>caching setting: bad address cache timeout, bad server name caching
>enable, bad server name caching timeout - I'll try to change all.


Today's testing with the switched off settings 'bad address cache
timeout = 0' and 'bad server name cache enabled = off' has not
improved a situation - same trouble here: workstations it is
unpredictable choose IP or IPX. Seems I really has serious name
resolution troubles most likely with DNS.

I shall investigate further - WireShark our friend :-). Another
question: what order for protocols of name resolution? How they are
specified on tab 'Protocol Preferences' and DNS has advantage before
SLP?


WBR,
Sergei Dubrov
0 Likes
Marcel_Cox Absent Member.
Absent Member.

Re: Client is ignores 'Preferred Network Protocol' setting

As far as I know, DNS has indeed priority over SLP. However DNS only works if the server is defined in your DNS and it is in your default domain or in your domain seach list.
Anyway, taking a packet capture with wireshark and looking at it is probably the best option to debug this problem.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.