Anonymous_User Absent Member.
Absent Member.
784 views

Cluster backup and failed over resource still listed in mounts and mtab

Hi,

I'm running a OES Linux sp2 iSCSI cluster (latest patches). When a
clustered NSS volume fails over from node 1 to node 2 then the mount
information of the resource is still listed in /proc/mounts and
/etc/mtab on node 1. I ran into this when using my clustered backup
solusion (SEP Sesam) and tried to backup a certain cluster resource. I
gat an error starting the job about that a volume that's in mtab is
not availabe on the node that the resource runs that I am to backup.
The strange thing is that another resource on that same node can be
backuped withoutany problems.

To be more clear what happened:
Node 1 runs the resources: APS, USR, MAIL
Node 2 runs the resources: IMG, SPOOL

The resources have been running on both nodes for the last weeks, so
when I did look at mtab or /proc/mounts for both nodes all resources
are listed as:
SPOOL on /media/nss/SPOOL type nssvol (rw,name=SPOOL)
IMG on /media/nss/IMG type nssvol (rw,name=IMG)
USR on /media/nss/USR type nssvol (rw,name=USR)
MAIL on /media/nss/MAIL type nssvol (rw,name=MAIL)
APS on /media/nss/APS type nssvol (rw,name=APS)

Now I could backup MAIL withoud any problems, but backing up APS or
USR complained about that SPOOL listed in mtab on node 1 was not
mounted on node 1. When I move SPOOL back to node 1 the problem was
solved.

I yesterday rebooted node 1 and now node 1 only lists APS, USR and
MAIL in mtab and /proc/mounts. Node 2 ran, while rebooting node 1, of
course APS USR and MAIL for a while and after moving them back to node
1 mtab and /etc/proc on node 2 still list them as being mounted.

As I think it should be /proc/mounts should only list what's mounted
on a server. The mtab could be 'out of sync' as stated in the SLES
manuals. Is this working as designed or might this be a problem in the
way OES dismount clustered volume (and does not inform the kernel
(process) correctly?

Any suggestions are (of course<G>) welcome!

Regards,

Sebastiaan Veld
Wannit BV
www.wannit.nl




Labels (2)
0 Likes
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: Cluster backup and failed over resource still listed in mounts and mtab

Sebastiaan,

It appears that in the past few days you have not received a response to your posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Do a search of our knowledgebase at http://support.novell.com/search/kb_index.jsp
- Check all of the other support tools and options available at http://support.novell.com in both the "free product support" and "paid product support" drop down boxes.
- You could also try posting your message again. Make sure it is posted in the correct newsgroup. (http://support.novell.com/forums)

If this is a reply to a duplicate posting, please ignore and accept our apologies and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://support.novell.com/forums/

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.