sselaya
New Member.
1609 views

Cluster resource does not register smdr with slp on failover

Running OES2 sp2 Linux using cluster services. When a clustered resource fails over to another physical node it does not register smdr with slp. Running a netstat -a I do see that the clustered resources is listening on the correct port though. If I run rcnovell-smdrd stop and then rcnovell-smdrd start it registers and I can then browse and backup the clustered resource again.
Labels (2)
0 Likes
4 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Cluster resource does not register smdr with slp on failover

sselaya,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://support.novell.com/forums/

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Cluster resource does not register smdr with slp on failover

Check if your tsa mode it "dual"... i think there was a problem with that and clusters...

You need to look at /etc/opt/novell/sms/tsafs.conf file for "tsamode" and also /etc/opt/novell/sms/smdrd.conf file for "autoload" option...

If its dual, make it "linux" and restart smdrd...

There is also smdr option to refresh the SLP advertisements after some time... this option is in /etc/opt/novell/sms/smdrd.conf file... maybe you can set it to a low value like 20 mins and check if subsequent advertisements succeed...

Oza

>>> On 6/6/2010 at 05:16 AM, in message

<sselaya.4c3xqn@no-mx.forums.novell.com>,
sselaya<sselaya@no-mx.forums.novell.com> wrote:

> Running OES2 sp2 Linux using cluster services. When a clustered
> resource fails over to another physical node it does not register smdr
> with slp. Running a netstat -a I do see that the clustered resources is
> listening on the correct port though. If I run rcnovell-smdrd stop and
> then rcnovell-smdrd start it registers and I can then browse and backup
> the clustered resource again.


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Cluster resource does not register smdr with slp on failover

Oza wrote:

> Check if your tsa mode it "dual"... i think there was a problem with that
> and clusters...
>
> You need to look at /etc/opt/novell/sms/tsafs.conf file for "tsamode" and
> also /etc/opt/novell/sms/smdrd.conf file for "autoload" option...
>
> If its dual, make it "linux" and restart smdrd...
>
> There is also smdr option to refresh the SLP advertisements after some
> time... this option is in /etc/opt/novell/sms/smdrd.conf file... maybe you
> can set it to a low value like 20 mins and check if subsequent
> advertisements succeed...
>
> Oza
>
>>>> On 6/6/2010 at 05:16 AM, in message

> <sselaya.4c3xqn@no-mx.forums.novell.com>,
> sselaya<sselaya@no-mx.forums.novell.com> wrote:
>
>> Running OES2 sp2 Linux using cluster services. When a clustered
>> resource fails over to another physical node it does not register smdr
>> with slp. Running a netstat -a I do see that the clustered resources is
>> listening on the correct port though. If I run rcnovell-smdrd stop and
>> then rcnovell-smdrd start it registers and I can then browse and backup
>> the clustered resource again.


I have actually reduced mine to 10 minutes being in a cluster. Otherwise if
there is a failover during a backup it takes forever to recover.

Rick

0 Likes
Highlighted
sselaya
New Member.

Re: Cluster resource does not register smdr with slp on fail

Tried all of the different methods (Linux, NetWare, etc..). Didnt seem to matter. Will now try changing refresh time change from 65535 to 10 minutes.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.