UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
1961 views

DHCP failover

I have two oes11 servers setup doing dns & dhcp. Services are set up
w/ identical zones, subnets, pools, etc. DNS is fine, and dhcp starts
& works properly on each server.

When I setup the failover option, the server that's set to be primary
keeps dhcp running while the secondary one goes to unused.

During this time, no machines will receive a dhcp address.

In watching /var/log/messages, I see this in the secondary failover
server:

Failover CONNECT from ccg-dns2: unknown failover relationship name.

This shows up on the primary failover server:

failover peer ccg-dns2: I move from recover to startup
failover peer ccg-dns2: I move from startup to recover

Primary server is ccg-dns1 with a failover peer of ccg-dns2, secondary
is ccg-dns2 with a failover peer of ccg-dns1.

If I take the failover peer out of the services, dhcp returns to
working properly.

Any ideas? Suggestions?

--

Stevo
Labels (2)
0 Likes
10 Replies
Absent Member.
Absent Member.

Make sure the failover object is the same. I got the same error on my test environment. So, I think it should be like this:

Service1
- failoverxyz

Service2
-failoverxyz


-Hans


>>> On 5/2/2012 at 3:10 PM, in message <dxgor.271$EH6.164@kovat.provo.novell.com>, Stevo<steveSPAM@LESSccgov.net> wrote:


I have two oes11 servers setup doing dns & dhcp. Services are set up
w/ identical zones, subnets, pools, etc. DNS is fine, and dhcp starts
& works properly on each server.

When I setup the failover option, the server that's set to be primary
keeps dhcp running while the secondary one goes to unused.

During this time, no machines will receive a dhcp address.

In watching /var/log/messages, I see this in the secondary failover
server:

Failover CONNECT from ccg-dns2: unknown failover relationship name.

This shows up on the primary failover server:

failover peer ccg-dns2: I move from recover to startup
failover peer ccg-dns2: I move from startup to recover

Primary server is ccg-dns1 with a failover peer of ccg-dns2, secondary
is ccg-dns2 with a failover peer of ccg-dns1.

If I take the failover peer out of the services, dhcp returns to
working properly.

Any ideas? Suggestions?

--

Stevo
0 Likes
Absent Member.
Absent Member.

Hans sounds like they 'said':

> Make sure the failover object is the same. I got the same error on
> my test environment. So, I think it should be like this:
>
> Service1
> - failoverxyz
>
> Service2
> -failoverxyz


So my response to Hans's comment is...

So the failover peer needs to be named the same for both services even
though the documentation says otherwise?

--
Stevo
0 Likes
Absent Member.
Absent Member.

That's what worked for me. I also had them named differently at first and got the same error you got. Then I named them the same and it works great.

-Hans



>>> On 5/8/2012 at 9:55 AM, in message <Utaqr.744$EH6.648@kovat.provo.novell.com>, Stevo<steveSPAM@LESSccgov.net> wrote:


Hans sounds like they 'said':


> Make sure the failover object is the same. I got the same error on
> my test environment. So, I think it should be like this:
>
> Service1
> - failoverxyz
>
> Service2
> -failoverxyz


So my response to Hans's comment is...

So the failover peer needs to be named the same for both services even
though the documentation says otherwise?

--
Stevo
0 Likes
Absent Member.
Absent Member.

Hans sounds like they 'said':

> That's what worked for me. I also had them named differently at
> first and got the same error you got. Then I named them the same and
> it works great.


So my response to Hans's comment is...

Thanks for the tip on that. Wonder if someone should mention it to
Novell. Everything I saw in the documentation says the failover 'peer'
should be named differently in each service.........

--
Stevo
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Stevo;2194544 wrote:
Hans sounds like they 'said':

> That's what worked for me. I also had them named differently at
> first and got the same error you got. Then I named them the same and
> it works great.


So my response to Hans's comment is...

Thanks for the tip on that. Wonder if someone should mention it to
Novell. Everything I saw in the documentation says the failover 'peer'
should be named differently in each service.........

--
Stevo


Please, hit the "Feedback" link on the documentation page (down at the bottom right) and provide the details, then the documentation team will get notified.

Thomas
0 Likes
Absent Member.
Absent Member.

thsundel sounds like they 'said':

> Please, hit the "Feedback" link on the documentation page (down at the
> bottom right) and provide the details, then the documentation team
> will get notified.


So my response to thsundel's comment is...

Sent feedback on tid 7004294.

I couldn't find a link to submit feedback here:

http://www.novell.com/documentation/oes2/pdfdoc/ntwk_dnsdhcp_lx/ntwk_dns
dhcp_lx.pdf

--
Stevo
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Stevo;2196972 wrote:
thsundel sounds like they 'said':

> Please, hit the "Feedback" link on the documentation page (down at the
> bottom right) and provide the details, then the documentation team
> will get notified.


So my response to thsundel's comment is...

Sent feedback on tid 7004294.

I couldn't find a link to submit feedback here:

http://www.novell.com/documentation/oes2/pdfdoc/ntwk_dnsdhcp_lx/ntwk_dns
dhcp_lx.pdf

--
Stevo


Good, if you sent feedback on the TID it should get looked at...

Well I can imagine that since it's a PDF 🙂 but if you look up the html version of that same section then you will find a feedback link at the bottom right.

Thomas
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

hpfeil;2193827 wrote:
Make sure the failover object is the same. I got the same error on my test environment. So, I think it should be like this:

Service1
- failoverxyz

Service2
-failoverxyz


-Hans


Good tip Hans, thanks,

As I'm actually also looking into setting this up for some larger existing setups.... wondering if it would not be quickest to add the failover object to the existing service and configure the existing pools to use that failover object.
Then export the existing DHCP service and reimport it into a new service and point it to be serviced by a second DHCP server that was setup.

Also, the port that should be used for the failover primary port/listener. The TID mentions there is no standardized port... Though different sources mention port 647 has been defined for this purpose.
Might be a good thing to put that in the TID as well as documentation to use as suggested port. To much options are not always a good thing 🙂

So I'm curious which port you guys used and for what reason...?

Cheers,
Willem
0 Likes
Absent Member.
Absent Member.

magic31 sounds like they 'said':

> So I'm curious which port you guys used and for what reason...?


So my response to magic31's comment is...

I used something like port 8888, just because I couldn't think of
anything using that port.

--
Stevo
0 Likes
Absent Member.
Absent Member.

I used 647

-Hans



>>> On 5/22/2012 at 5:56 AM, in message <magic31.5cyq3b@no-mx.forums.novell.com>, magic31<magic31@no-mx.forums.novell.com> wrote:



hpfeil;2193827 Wrote:

> Make sure the failover object is the same. I got the same error on my
> test environment. So, I think it should be like this:
>
> Service1
> - failoverxyz
>
> Service2
> -failoverxyz
>
>
> -Hans


Good tip Hans, thanks,

As I'm actually also looking into setting this up for some larger
existing setups.... wondering if it would not be quickest to add the
failover object to the existing service and configure the existing pools
to use that failover object.
Then export the existing DHCP service and reimport it into a new
service and point it to be serviced by a second DHCP server that was
setup.

Also, the port that should be used for the failover primary
port/listener. The TID mentions there is no standardized port... Though
different sources mention port 647 has been defined for this purpose.
Might be a good thing to put that in the TID as well as documentation
to use as suggested port. To much options are not always a good thing
🙂

So I'm curious which port you guys used and for what reason...?

Cheers,
Willem


--
Novell Knowledge Partner (voluntary sysop)

It ain't anything like Harry Potter.. but you gotta love the magic IT
can bring to this world
------------------------------------------------------------------------
magic31's Profile: http://forums.novell.com/member.php?userid=2303
View this thread: http://forums.novell.com/showthread.php?t=455399
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.