restori1 Absent Member.
Absent Member.
839 views

Dependencies errors

I'm moving my server from from OES 11 SP1 (SLES 11 SP2) to OES 11 SP2 via SMT, but when I run zypper upgrade -t patch I've a dependencies errors:

# zypper update -t patch
Loading repository data...
Reading installed packages...
Resolving package dependencies...
2 Problems:
Problem: libzypp-9.40.2-14.7.x86_64 requires libz.so.1(ZLIB_1.2.3.3)(64bit), but this requirement cannot be provided
Problem: yast2-qt-pkg-2.21.4-2.5.56.x86_64 requires libzypp.so.908()(64bit), but this requirement cannot be provided

Problem: libzypp-9.40.2-14.7.x86_64 requires libz.so.1(ZLIB_1.2.3.3)(64bit), but this requirement cannot be provided
uninstallable providers: zlib-1.2.7-0.10.128.x86_64[SMT-http_smtsles_apa_it:SLES11-SP3-Pool]
zlib-1.2.7-0.12.3.x86_64[SMT-http_smtsles_apa_it:SLES11-SP3-Updates]
Solution 1: Following actions will be done:
deinstallation of libzypp-9.16.4-0.5.2.x86_64
deinstallation of smt-client-0.3.0-0.5.1.x86_64
deinstallation of yast2-pkg-bindings-2.17.61-0.7.2.x86_64
deinstallation of yast2-ncurses-pkg-2.17.20-0.5.1.x86_64
deinstallation of PackageKit-0.3.14-2.30.11.x86_64
.......
.......
deinstallation of novell-plugin-base-2.7.6-0.12.25.1.noarch
deinstallation of novell-plugin-nss-3.6.624-0.3.1.x86_64
Solution 2: deinstallation of zlib-devel-1.2.3-15.2.x86_64
Solution 3: do not install patch:slessp3-softwaremgmt-201505-2-10699.noarch
Solution 4: break libzypp-9.40.2-14.7.x86_64 by ignoring some of its dependencies

Can I ignore dependencies (solution 4)?
Does I need zlib-devel ?
How to move?

Thanks for help,
Fabrizio

fabrizio at rfc.it www.rfc.it
Labels (2)
0 Likes
6 Replies
Knowledge Partner
Knowledge Partner

Re: Dependencies errors

restori;2461567 wrote:
I'm moving my server from from OES 11 SP1 (SLES 11 SP2) to OES 11 SP2 via SMT


Hi Fabrizio,

In your previous thread, OES 11 SP1 upgrade to ...., you stated you were running OES 11 SP1 and SLES 11 SP1. We asked you to provide the output from this command:
cat /etc/*release

Please provide the requested information so we can verify what software is currently installed.

You were given a link to the OES 11 SP3 documentation. I can no longer locate the OES 11 SP2 documentation online but I do see that you can upgrade from OES 11 SP1 to OES 11 SP2 using the "Channel or patch upgrade" method as you are trying to do.

I see you are upgrading via SMT. I have not used this method myself so I am not the best person to help with SMT issues. Since you are unable to resolve so many dependencies, I suspect you may not have access to all the necessary repositories.

Have you followed all the steps in the OES 11 SP2: Installation Guide section 5.7.3 Upgrading OES 11 SP1 to OES 11 SP2 Using SMT?

Some things you should verify:
Have you re-registered your system to ensure you have access to all the necessary repositories?
Have you patched your system before attempting the upgrade?

There are other volunteers monitoring these forums who have worked with SMT. Perhaps one of them might have some additional suggestions.

Would you consider a different upgrade method to eliminate SMT as the issue? for example: section 5.7.2 Channel Upgrade from OES 11 SP1 to OES 11 SP2 Using Zypper.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
restori1 Absent Member.
Absent Member.

Re: Dependencies errors

KBOYLE;2461602 wrote:
Hi Fabrizio,

In your previous thread, OES 11 SP1 upgrade to ...., you stated you were running OES 11 SP1 and SLES 11 SP1. We asked you to provide the output from this command:
cat /etc/*release

Please provide the requested information so we can verify what software is currently installed.

You were given a link to the OES 11 SP3 documentation. I can no longer locate the OES 11 SP2 documentation online but I do see that you can upgrade from OES 11 SP1 to OES 11 SP2 using the "Channel or patch upgrade" method as you are trying to do.

I see you are upgrading via SMT. I have not used this method myself so I am not the best person to help with SMT issues. Since you are unable to resolve so many dependencies, I suspect you may not have access to all the necessary repositories.

Have you followed all the steps in the OES 11 SP2: Installation Guide section 5.7.3 Upgrading OES 11 SP1 to OES 11 SP2 Using SMT?

Some things you should verify:
Have you re-registered your system to ensure you have access to all the necessary repositories?
Have you patched your system before attempting the upgrade?

There are other volunteers monitoring these forums who have worked with SMT. Perhaps one of them might have some additional suggestions.

Would you consider a different upgrade method to eliminate SMT as the issue? for example: section 5.7.2 Channel Upgrade from OES 11 SP1 to OES 11 SP2 Using Zypper.


The release:
~> cat /etc/*relea*
LSB_VERSION="core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64"
cat: /etc/lsb-release.d: Is a directory
Novell Open Enterprise Server 11 (x86_64)
VERSION = 11.1
PATCHLEVEL = 1
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2


I'm moving to OES 11 SP1 to SP2 because is the minimal release useful for migration to OES 15 SP1.
Yes, SP2 documentations are not more available, but I don't know why :-(.
I'm upgrading via SMT because it seem that repository are not available for other routes. At least, so I understand.
All repository are available with SMT, may be I've not enabled some one? I'll check.

>> Have you patched your system before attempting the upgrade.
Yes, this was done.

Thanks for your help,
Fabrizio

fabrizio at rfc.it www.rfc.it
0 Likes
restori1 Absent Member.
Absent Member.

Re: Dependencies errors

One more think.
--- Solution 2: deinstallation of zlib-devel-1.2.3-15.2.x86_64
zlib-devel isn't in any repositories enabled on SMT, but I don't know witch I need.
How to check.

Fabrizio

fabrizio at rfc.it www.rfc.it
0 Likes
Knowledge Partner
Knowledge Partner

Re: Dependencies errors

restori;2461607 wrote:

I'm moving to OES 11 SP1 to SP2 because is the minimal release useful for migration to OES 15 SP1.
Yes, SP2 documentations are not more available, but I don't know why :-(.
I'm upgrading via SMT because it seem that repository are not available for other routes. At least, so I understand.


Hi Fabrizio,

You do have another option: You can upgrade from OES 11 SP1 to OES 2015 and then upgrade to OES 2015 SP1.


You can download from here a .zip file containing PDF files for all the Open Enterprise Server 2015 documentation.

I am trying to locate the OES 11 SP2 documentation for you. I am also checking to see if the repositories are still available.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Dependencies errors

restori Wrote in message:

> One more think.
> --- Solution 2: deinstallation of zlib-devel-1.2.3-15.2.x86_64
> zlib-devel isn't in any repositories enabled on SMT, but I don't know
> witch I need.
> How to check.


-devel packages are available as part of the Software Development
Kit (SDK) so you need to have the appropriate* repository
enabled.

HTH.

*which will depend on the versions in play hence asking for the
output from "cat /etc/*release"
--
Simon Flood
Micro Focus Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/
0 Likes
restori1 Absent Member.
Absent Member.

Re: Dependencies errors

Solved with option 2:
Solution 2: deinstallation of zlib-devel-1.2.3-15.2.x86_64

I wasn't sure, but zlib-devel seems not necessary.
Thanks to all.

fabrizio at rfc.it www.rfc.it
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.