Highlighted
Absent Member.
Absent Member.
967 views

Enabing an second unconfigured NIC causes NDS errors (LDAP etc)

Hello,

I try to configure a second nic card in a OES SP2 server with a well
running NDS.

The first Nic (172.19.1.8/255.255.0.0) is linked to an intranet network
and the second (172.22.1.8/255.255.0.0) has to be connected to a DMZ
Ichain system...

1) When I reboot the server, I get during the boot sequence the
following error after a "certain" -quite long- delay: "Novell eDirectory
LDAP server TCP port is not listening"...

Could it be linked with this already discussed problem of "LDAP hard
coded to use all interfaces" (thread 28/04/2005 in install forum)?

Does somebody has find a workaround for this problem? has an enhacement
request be done?

2) After the boot, when I browse NDS services (iManager etc) using the
"name server", I can't get them.

Using instead the first IP address 172.19.1.8 , it works...

The "Ping name server" answers with the new address 172.22.1.8.

Is it the order the nic are binded? Is there a way to change this order?
is it based on the MAC and so the filename in sysconfig/network
alphanumeric order?

Thanks for help

Kind regards

Philippe

Labels (2)
0 Likes
1 Reply
Highlighted
Absent Member.
Absent Member.

Re: Enabing an second unconfigured NIC causes NDS errors (LDAP etc)

Hello,

Here is what I did to solve the problem; I don't know if it is the right
way to do it, but it seems to work.

1) for problem 1: I inverted the 2 adresses on the NICs...

It seems to me that now the 172.22.1.8 starts on the nic with a "higher"
mac, and thus with a parameter file (ifcg-eth-id-mac) after the
172.19.1.8 one on a alphanumeric point of view. This would present to
LDAP as first IP address the 172.19 one and LDAP would not try to use
the 172.22 one... (my interpretation of the mystery)

2) for problem 2: I just put in the etc/hosts file the line linking the
address 172.19.1.8 with the nameserver before the one linking 172.22.1.8
with the nameserver...

If anyone has any comment, don't hesitate, you are welcome. It is just
my workaround, but it could be perhaps of some use for someone else (who
knows?).

Kind regards

Philippe

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.