Anonymous_User Absent Member.
Absent Member.

Error compiling simias (simias-event-client.c:413: parse error before `*')


I downloaded the tarbal version of simias-1.2.5347.1. I ran "./configure"
(no errors) and then "make". I got an error when I ran make (see below).

gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)
Linux RedHat 7.2
Kernel: 2.4.32grs-bipiv-ipv4-32
libc: glibc-2.2.4-31 ( compiled with gcc 2.96)

any pointers would be appreciated.

# make
Making all in src
make[1]: Entering directory `/home/src/simias-1.2.5347.1/src'
Making all in SimiasClient
make[2]: Entering directory `/home/src/simias-1.2.5347.1/src/SimiasClient'
Making all in libsimias-event
make[3]: Entering directory
if /bin/sh ../../../libtool --tag=CC --mode=compile gcc -DPACKAGE_NAME=\"\"
`xml2-config --cflags` -MT libsimias_event_la-simias-event-client.lo -MD
-MP -MF ".deps/libsimias_event_la-simias-event-client.Tpo" -c -o
libsimias_event_la-simias-event-client.lo `test -f 'simias-event-client.c'
|| echo './'`simias-event-client.c; \
then mv -f ".deps/libsimias_event_la-simias-event-client.Tpo"
".deps/libsimias_event_la-simias-event-client.Plo"; else rm -f
".deps/libsimias_event_la-simias-event-client.Tpo"; exit 1; fi
-I. -I. -I/usr/local/include/libxml2 -MT
libsimias_event_la-simias-event-client.lo -MD -MP -MF
..deps/libsimias_event_la-simias-event-client.Tpo -c simias-event-client.c
-fPIC -DPIC -o .libs/libsimias_event_la-simias-event-client.o
simias-event-client.c: In function `sec_register':
simias-event-client.c:413: parse error before `*'
simias-event-client.c:415: `ec' undeclared (first use in this function)
simias-event-client.c:415: (Each undeclared identifier is reported only once
simias-event-client.c:415: for each function it appears in.)
make[3]: *** [libsimias_event_la-simias-event-client.lo] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/src/simias-1.2.5347.1/src/SimiasClient'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/src/simias-1.2.5347.1/src'
make: *** [all-recursive] Error 1

Labels (1)
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: Error compiling simias (simias-event-client.c:413: parse error before `*')


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Do a search of our knowledgebase at
- Check all of the other support tools and options available at
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.