UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Vice Admiral
Vice Admiral
2341 views

Failed to configure Novell iFolder 3 Server OES 11 SP1

Hi,

I am installing a new OES 11 SP1 in our e-directory domain.
Everything on the server installs fine except iFolder.

Yast2 is giving : "Failed to configure Novell iFolder 3 Server"

/var/log/YaST2/y2log:
2013-01-16 18:14:02 <1> oes2601(6868) [wfm] Y2CCWFM.cc(createInLevel):148 Parsing finished
2013-01-16 18:14:02 <1> oes2601(6868) [Interpreter] clients/novell-ifolder3_proposal.ycp:239 Calling YaST client novell-ifolder3_proposal
2013-01-16 18:14:02 <1> oes2601(6868) [YCP] clients/novell-ifolder3_proposal.ycp:46 ----------------------------------------
2013-01-16 18:14:02 <1> oes2601(6868) [YCP] clients/novell-ifolder3_proposal.ycp:47 NovellIfolder3 proposal started
2013-01-16 18:14:02 <1> oes2601(6868) [Pkg] NovellPatterns.ycp:397 Pkg Builtin called: ResolvableDependencies
2013-01-16 18:14:02 <1> oes2601(6868) [YCP] NovellPatterns.ycp:410 NovellPatterns::IsPatternInstalled(novell-ifolder) returned: true
2013-01-16 18:14:02 <1> oes2601(6868) [YCP] NovellUtils.ycp:45 NovellUtils::ReadOptions
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] Progress.ycp:380 Progress::New(Saving iFolder3 Configuration, 1, ["Write iFolder settings"])
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] Progress.ycp:469 No progress icons defined
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:800 NovellIfolder:Primary server: $["CONFIG_LDAP_PORT":389, "CONFIG_LDAP_SECURE_PORT":636, "CONFIG_LDAP_SERVER_IP":"10.1.254.106"]
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:801 NovellIfolder:Fallback server_list: [$["CONFIG_LDAP_PORT":389, "CONFIG_LDAP_SECURE_PORT":636, "CONFIG_LDAP_SERVER_IP":"10.1.254.76"]]
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:826 NovellIfolder3.Read:useCommonProxy: yes
2013-01-16 18:14:03 <1> oes2601(6868) [Pkg] NovellPatterns.ycp:397 Pkg Builtin called: ResolvableDependencies
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellPatterns.ycp:410 NovellPatterns::IsPatternInstalled(novell-ncs) returned: false
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:832 NovellIfolder3.Read:useCommonProxy after NCS check: yes
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellUtils.ycp:1566 NovellUtils.RetrieveProxyCredentials:executing: /opt/novell/proxymgmt/bin/cp_retrieve_proxy_cred password
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellUtils.ycp:1569 NovellUtils.RetrieveProxyCredentials:returned:0
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:672 ifolder3.CopyCertFiles:executing mkdir -p /ifolder/simias/data/simias
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:677 ifolder3.CopyCertFiles:executing cp /etc/opt/novell/certs/SSCert.der /ifolder/simias/data/simias/SSCert.der
2013-01-16 18:14:03 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:893 ifolder3:Executing /opt/novell/oes-install/util/extend_schema -d -p 636 'cn=admin,o=vgg' t*****t 10.1.254.106 /opt/novell/ifolder3/etc/iFolderLdapPlugin.ldif
2013-01-16 18:14:04 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:1110 ifolder3.write:executing: /opt/novell/ifolder3/bin/simias-server-setup --p='/ifolder/simias/data' --listen-port=443 --server-name=oes2601 --public-url='10.1.254.106' --p
rivate-url='10.1.254.106' --ldap-plugin=false --use-ssl='BOTH' --slave-server=false --system-name='iFolder VGSAS' --system-description='iFolder Enterprise System' --use-ldap=true --ldap-server=10.1.254.106 --ldap-ssl=true --ldap-admin-dn
='cn=admin,o=vgg' --system-admin-dn='cn=admin,o=vgg' --ldap-proxy-dn='cn=OESCommonProxy_oes2601,ou=oes2601,ou=SRV,ou=VGSAS,o=VGG' --ldap-search-context='ou=oes2601,ou=SRV,ou=VGSAS,o=VGG#ou=vgsas,o=vgg' --naming-attribute='cn' --apache=tr
ue --use-recovery-agent=true --ra-cert-path='/ifolder/simias/data/simias' --ldap-cert-acceptance=true
2013-01-16 18:14:06 <1> oes2601(6868) [YCP] NovellIfolder3.ycp:1112 ifolder3.write::config output:Map Value:
$["exit":255, "stderr":"", "stdout":"\nSIMIAS SERVER SETUP\n\nSetting up store Configuration files...\nDone\nPrivate https://10.1.254.106:443/simias10\n\n\n\n\n\nWorking...\n\nConfiguring /ifolder/simias/data/simias/Simias.config...\nSet
upSimias - Done\nConfiguring /etc/apache2/conf.d/simias.conf...\nDone\nInstalling certificate from ldaps://10.1.254.106/...\n\nLdap certificate : \n\nMono Certificate Manager - version 2.6.7.0\nManage X.509 certificates and CRL from stor
es.\nCopyright 2002, 2003 Motus Technologies. Copyright 2004-2008 Novell. BSD licensed.\n\n\n X.509 Certificate v3\n Issued from: O=VGG_TREE, OU=Organizational CA\n Issued to: O=VGG_TREE, OU=Organizational CA\n Valid from: 3/22/
2006 9:43:00 AM\n Valid until: 3/22/2016 11:43:00 AM\n\nDone\nConnecting to ldaps://10.1.254.106/...\nDetected errors in the Server Certificate:\n-2146869232\n at Novell.Directory.Ldap.LdapResponse.chkResultCode () [0x00000] in <filen
ame unknown>:0 \n at Novell.Directory.Ldap.LdapConnection.chkResultCode (Novell.Directory.Ldap.LdapMessageQueue queue, Novell.Directory.Ldap.LdapConstraints cons, Novell.Directory.Ldap.LdapResponse response) [0x00000] in <filename unkno
wn>:0 \n at Novell.Directory.Ldap.LdapConnection.Bind (Int32 version, System.String dn, System.SByte[] passwd, Novell.Directory.Ldap.LdapConstraints cons) [0x00000] in <filename unknown>:0 \n at Novell.Directory.Ldap.LdapConnection.Bin
d (Int32 version, System.String dn, System.String passwd, Novell.Directory.Ldap.LdapConstraints cons) [0x00000] in <filename unknown>:0 \n at Novell.Directory.Ldap.LdapConnection.Bind (System.String dn, System.String passwd, Authenticat
ionTypes authenticationTypes) [0x00000] in <filename unknown>:0 \n at Novell.Directory.Ldap.LdapConnection.Bind (System.String dn, System.String passwd) [0x00000] in <filename unknown>:0 \n at Novell.iFolder.Utility.LdapUtility.Connect
() [0x00000] in <filename unknown>:0 \n at Novell.iFolder.SimiasServerSetup.SetupLdap () [0x00000] in <filename unknown>:0 \nFailed\n\nLdapException: (91) Connect Error\nSystem.IO.IOException: The authentication or decryption has faile
d. ---> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server.\n at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.validateCertificates (Mono.Security.X509.X509CertificateCollection certific
ates) [0x00000] in <filename unknown>:0 \n at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.ProcessAsTls1 () [0x00000] in <filename unknown>:0 \n at Mono.Security.Protocol.Tls.Handshake.HandshakeMessage.Process () [0
x00000] in <filename unknown>:0 \n at (wrapper remoting-invoke-with-check) Mono.Security.Protocol.Tls.Handshake.HandshakeMessage:Process ()\n at Mono.Security.Protocol.Tls.ClientRecordProtocol.ProcessHandshakeMessage (Mono.Security.Pro
tocol.Tls.TlsStream handMsg) [0x00000] in <filename unknown>:0 \n at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRecordCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 \n --- End of inner exception sta

-CA is checked by e-directory team, and is allright. No problems found.
-Removing iFolder via Yast2 and installing it again does not work .. same error.
-Running simias-setup again to reconfigure ifolder does not work .. tried with LDAP secure (does not work) .. tried with LDAP unsecure (does not work)
-Reinstalling whole server -> same issue again

Same issue in this thread: http://forums.novell.com/novell-product-discussions/file-networking-services/ifolder/363106-failed-configure-novell-ifolder-3-server.html

Can somebody help me with this issue?

Thanks

Joeri
Labels (1)
0 Likes
3 Replies
Absent Member.
Absent Member.

jfeyen,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
Vice Admiral
Vice Admiral

Hi,

After a long way of trying i fixed this myself.
TLS needs to be off on LDAP. Used non secure LDAP on the ifolder script and
LDAP Proxy DN used cn=OESCommonProxy_oes1401 with default filled in pw.

I hope this helps other people too.

Joeri
0 Likes
Absent Member.
Absent Member.

jfeyen;2243193 wrote:
Hi,

After a long way of trying i fixed this myself.
TLS needs to be off on LDAP. Used non secure LDAP on the ifolder script and
LDAP Proxy DN used cn=OESCommonProxy_oes1401 with default filled in pw.

I hope this helps other people too.

Joeri


It is working this way, but it is not secure. Is this a kind of bug which will be fixed later on or Filr will take place of ifolde
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.