ahleia Absent Member.
Absent Member.
1454 views

File locked/Read-Only issue in OES2LINUX

We have observed that when the novell connection is idle for some time, then it is creating a second connection upon wakeup. Whatever the opened files in the idle connection are getting read-only.
How to activate the idle connection and prevent creating a second connection? we hope by activating the idle connection, read-only problem can be solved.
Labels (2)
0 Likes
6 Replies
Knowledge Partner
Knowledge Partner

Re: File locked/Read-Only issue in OES2LINUX

ahleia;2305806 wrote:
We have observed that when the novell connection is idle for some time, then it is creating a second connection upon wakeup. Whatever the opened files in the idle connection are getting read-only.
How to activate the idle connection and prevent creating a second connection? we hope by activating the idle connection, read-only problem can be solved.


Hi,

Which OS is the client running (version and patchlevel) and which Novell client version?

Two generic things that come to mind:

1) Make sure you have oplocks disabled on the server and also have disabled Novell client caching on the workstation.
2) If this is a fixed workstation, disable energy saving on the network card to see if that helps

Cheers,
Willem
0 Likes
ahleia Absent Member.
Absent Member.

Re: File locked/Read-Only issue in OES2LINUX

Dear Mr.Willem,

Thanks for ur reply.

Client OS: Windows 7 Proff sp1,Novell Client : Novell Client 2 SP1 for Windows 7 (IR5), but this problem is there with all the versions of client.
We have already tried disabling novell client caching and energy saving. Still the problem is not solved.
I've just changed the value of OPLOCK_SUPPORT_LEVEL to '0' on server. I'll get back to u on this soon.

Rgds,
Ahleia

magic31;2305862 wrote:
Hi,

Which OS is the client running (version and patchlevel) and which Novell client version?

Two generic things that come to mind:

1) Make sure you have oplocks disabled on the server and also have disabled Novell client caching on the workstation.
2) If this is a fixed workstation, disable energy saving on the network card to see if that helps

Cheers,
Willem
0 Likes
ahleia Absent Member.
Absent Member.

Re: File locked/Read-Only issue in OES2LINUX

Please find attached the screenshot of the error message for your reference.

ahleia;2305916 wrote:
Dear Mr.Willem,

Thanks for ur reply.

Client OS: Windows 7 Proff sp1,Novell Client : Novell Client 2 SP1 for Windows 7 (IR5), but this problem is there with all the versions of client.
We have already tried disabling novell client caching and energy saving. Still the problem is not solved.
I've just changed the value of OPLOCK_SUPPORT_LEVEL to '0' on server. I'll get back to u on this soon.

Rgds,
Ahleia
0 Likes
Knowledge Partner
Knowledge Partner

Re: File locked/Read-Only issue in OES2LINUX

ahleia;2305930 wrote:
Please find attached the screenshot of the error message for your reference.


Is this error specifically with dwg files? Or are you also seeing it with other types of files/extensions? I'd also be curious to know if something else might be locking the file (virus scanner for example)...

You mention in your post subject that the OES server is version 2. It would be good to know which OES2 patch level you are running and the last time the server has been patched. There are some (older) issues with the NCP engine that could be related to the issue you are seeing.

Before jumping the gun and looking for other possible suspects on what's causing the issue.... did you restart the server after changing the oplock setting to 0 on the server?

Cheers,
Willem
0 Likes
MCCFL_MLA Absent Member.
Absent Member.

Re: File locked/Read-Only issue in OES2LINUX

Given we are OES11SP1 this may not be any help.....But we experienced some similar issues early on...and I do not recall exactly what fixed it....

You indicate you disabled energy savings?

Did you change the Network Card Power Management: (Disable) Allow the computer to turn off this device to save power?
Also, Did you try setting the Active Power Plan: HIGH PERFORMANCE?

Along with Disabling File Caching we had to Enable (ON) File Commit to fix other file lock issues....

If it continues, I would also suggest updating to at least Novell Client 2 SP3 (IR3) preferably IR5 as IR3 has some issues but is stable.... and attempting again after the OPSLOCK is disabled and the server is restarted as stated by Willem

Patrick
0 Likes
ataubman Absent Member.
Absent Member.

Re: File locked/Read-Only issue in OES2LINUX

ahleia;2305916 wrote:

Client OS: Windows 7 Proff sp1,Novell Client : Novell Client 2 SP1 for Windows 7 (IR5), but this problem is there with all the versions of client.

The current version is Client 2 SP3 IR5 - did you mean that? If not, you are years behind in client patch levels and need to update. And your OEs2 SP3 server needs to be patched up to current levels too, if not.

Andrew C Taubman (Sorry, support is not provided via e-mail) Opinions expressed above are not necessarily those of Micro Focus.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.