Anonymous_User Absent Member.
Absent Member.
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HP Controller Fails HDD and causes NSS Pool De-Activation and ofcourse volume dismounts

Perhaps any one else who has experienced this can respond


PROBLEM:
The CPQRAID driver is failing the array controller

DETAILS:

1. A change in controller status occurs (have seen this message -
CPQRAID: The Controller in slot 0 has been failed by the driver and
requires corrective action).
2. The Insight Manager console receives a trap for a controller status
change event. When the event is viewed from the Insight Manager console,
the array controller is shown in powered off state.
3. At this point, there are a two different scenarios that may occur
based on the hardware configuration.
3a. For hard disk storage attached to the affected controller, all NSS
pools proceed to deactivate and all volumes dismount. Additionally, the
C: drive also becomes inaccessible.
3b. For tape drive hardware attached to the affected controller, the
tape drive becomes inaccessible and the backup software find it can no
longer communicate with the tape drive.
4. Depending on scenario 3a or 3b above, the stability of the server
will vary.
4a. With all the volumes dismounted, the server typically becomes
unstable and unresponsive. Network communications fail also. No core
dump may be gathered locally or remotely at this point due to the
inability to communicate with local storage or across the network. And
there is no log information written since the volumes have dismounted.
Server has to typically be power cycled to recover but there have been
instances where it was possible to gracefully reset the server.


Cause

HP has determined the cause of this event which we have named the All
Drive Partitions Unavailable problem. Through analysis and
troubleshooting, HP has isolated the condition to the following events.

1.An scan command from the driver to the firmware gets stuck
2.The array controller driver tries to abort the command and times out
trying.
3.The driver fails the controller as a result of the time-out
4.The array is taken off-line when the drive fails the controller
5.The NSS pools deactivate and volumes dismount as a result of the array
being taken off-line.

Fix

Currently, there is no fix for the All Drive Partitions Unavailable problem.

HP engineers are working with their developers to make a change to
either the array controller driver or the array controller firmware to
address and resolve the problem

This is an alleged remedy apparently:

ProLiant Support Pack for Novell NetWare (Drivers)
http://h18023.www1.hp.com/support/files/server/us/download/26939.html

Firmware Maintenance CD
http://h18023.www1.hp.com/support/files/server/us/download/27783.html
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Anonymous_User Absent Member.
Absent Member.

Re: HP Controller Fails HDD and causes NSS Pool De-Activation andof course volume dismounts

Richard Seepaul wrote:
> Perhaps any one else who has experienced this can respond
>
>
> PROBLEM:
> The CPQRAID driver is failing the array controller
>
> DETAILS:
>
> 1. A change in controller status occurs (have seen this message -
> CPQRAID: The Controller in slot 0 has been failed by the driver and
> requires corrective action).
> 2. The Insight Manager console receives a trap for a controller status
> change event. When the event is viewed from the Insight Manager console,
> the array controller is shown in powered off state.
> 3. At this point, there are a two different scenarios that may occur
> based on the hardware configuration.
> 3a. For hard disk storage attached to the affected controller, all NSS
> pools proceed to deactivate and all volumes dismount. Additionally, the
> C: drive also becomes inaccessible.
> 3b. For tape drive hardware attached to the affected controller, the
> tape drive becomes inaccessible and the backup software find it can no
> longer communicate with the tape drive.
> 4. Depending on scenario 3a or 3b above, the stability of the server
> will vary.
> 4a. With all the volumes dismounted, the server typically becomes
> unstable and unresponsive. Network communications fail also. No core
> dump may be gathered locally or remotely at this point due to the
> inability to communicate with local storage or across the network. And
> there is no log information written since the volumes have dismounted.
> Server has to typically be power cycled to recover but there have been
> instances where it was possible to gracefully reset the server.
>
>
> Cause
>
> HP has determined the cause of this event which we have named the All
> Drive Partitions Unavailable problem. Through analysis and
> troubleshooting, HP has isolated the condition to the following events.
>
> 1.An scan command from the driver to the firmware gets stuck
> 2.The array controller driver tries to abort the command and times out
> trying.
> 3.The driver fails the controller as a result of the time-out
> 4.The array is taken off-line when the drive fails the controller
> 5.The NSS pools deactivate and volumes dismount as a result of the array
> being taken off-line.
>
> Fix
>
> Currently, there is no fix for the All Drive Partitions Unavailable
> problem.
>
> HP engineers are working with their developers to make a change to
> either the array controller driver or the array controller firmware to
> address and resolve the problem
>
> This is an alleged remedy apparently:
>
> ProLiant Support Pack for Novell NetWare (Drivers)
> http://h18023.www1.hp.com/support/files/server/us/download/26939.html
>
> Firmware Maintenance CD
> http://h18023.www1.hp.com/support/files/server/us/download/27783.html


For those who may want to know:
HP Proliant DL 360 G4p 4 GB RAM
HP MSA 30
Proliant Support Pack for Netware ver 7.60
Netware 6.5 SP6 plus all public post SP6 patches. ( except for 3 most
recent iPrint 6g, TCP, and CIFS update).
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