elangogopal Absent Member.
Absent Member.
8731 views

Imanager login webpage failed to load!

Hello,

Could you please help me regarding the imanager webpage not opening!

Issue Description
-----------------
Imanager login webpage failed to load on the Novell Netware 6.5 ,Imanager 2.6

Setup environment
-----------------
Imanager 2.6.x
Tomcat 4.1
Novell eDirectory 8.7
Apache 2.0
MySQL 4.0

Observed and Taken actions
--------------------------
We had performed the following activity to find out what causes the imanager webpage issue as per Novell link Cool Solutions: Troubleshooting iManager 2.0.2 on NetWare 6.5 and didn't help!

Noticed on the following imanager related applications:
Apache
LDAP over SSL
Tomcat
SSL (Server Certificates)

1. Apache testing - https://0.0.0.0:2200 -> imanager web interface is opening on the default port 2200 and the 8009 port is listening checked by tcpcon utility and also verified the port 8009 using the telnet serverip 8009 on the client side.

2. LDAP Secure port testing https://0.0.0.0:636 -> open the webpage with the output as à 0$__x* ____Š_1.3.6.1.4.1.1466.20036 LDAP works and also checked port 636 by tcpcon command.

3. Tomcat testing - Logger screen shows "listen 0.0.0.0:9010" and also verified the command by "java -show" which shows the tomcat running process.

4. Ssl certifiation had been expired, checked by pkidiag command ,found the 1 error and fixed it by the press 0 and 4. I have performed followng steps to try to resolve the ssl certification renewal since ssl cerifitication had been expired.

(i)i had tried to Deleted the sys:/system/CertServ/ directory of certification location directory.
(ii) New ssl certification has been created during the server rebooting up after deleted the certification directory.
(iii) Ran the pkidiag utility for diagnostic and fix the new certification issue.
(iv) Executed the tckeygen.nlm to export the new certification to Tomcat application.
(v) Rebooted the server to effect the certification renewal in the Tomcat application.
(vi) Bydefault the ssl certification has been created on the network interface "eth1" instead of "eth0" where imanager setup has been configured
(vii) Also tried to disable the netware card eth1 and the ssl certifiation created successfully on the eth0 and no pkidiag error found in the logs file.

5. Even i tried to shutted down all the imanager related services and re-started it again in the proper order.

tc4stop.ncf
tcadmdn.ncf
admsrvdn.ncf
ap2webdn.ncf

java -kill

ap2webup.ncf
admsrvup.ncf
tcadmup.ncf
tomcat4.ncf

6.Removed the existing key and properly re-imported the Certificate into the keystore path /adminserv/conf/.keystore. for tomcat using the tckeygen and tcedirint command. The new certification has been created successfully and reexported to tomcat and noticed the imanager ports are listening 8009,636,8008,2200 and no recent logs found for the Apache,Tomcat,ssl on the OSbackend.imanager is not opening on port 8009 yet.still imanager issue persists!

Any thoughts, suggestions or recommendations would be greatly appreciated to resolve the imanager login web page.

Note : can i install the standalone imanager and use it on the client side in the place of imanager webpage since the imanager webpage is not opening? Please suggest me also on this.

Regards,
Elango Gopal
Labels (2)
0 Likes
31 Replies
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

Elangogopal,
> Imanager login webpage failed to load on the Novell Netware 6.5
> ,Imanager 2.6


What error message do you see?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
elangogopal Absent Member.
Absent Member.

Re: Imanager login webpage failed to load!

Thanks for your prompt response.

The Imanager web page is loading to open too long time and giving the error as "Internet Explorer cannot display the webpage" in the IE and "Server not found" in the Firefox.however the port 8009 listens and all services related to imanager is working fine as already mentioned here.

Also please let me know , what about the "standalone imanager 2.6/7 workstation"? can i try this one standalone imanager 2.7 workstation on the windows client side since the imanager issue persists on the server and instead of troubleshooting on this imanager issue? would it be worked on the client side since imanager server has issue? Thanks again.

Regards,
Elango Gopal
0 Likes
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

Elangogopal,
> The Imanager web page is loading to open too long time and giving the
> error as "Internet Explorer cannot display the webpage" in the IE and
> "Server not found" in the Firefox.however the port 8009 listens and all
> services related to imanager is working fine as already mentioned here.


Ok. That sounds like nothing is listening on port 80/443. 8009 is NORM and
that is a separate process. IS Apache loaded? TRy M APA* on the server
console

> Also please let me know , what about the "standalone imanager 2.6/7
> workstation"? can i try this one standalone imanager 2.7 workstation on
> the windows client side since the imanager issue persists on the server
> and instead of troubleshooting on this imanager issue? would it be
> worked on the client side since imanager server has issue? Thanks
> again.


Yes. You can install standalone imanager. Not all imanager plugins will
run on that though.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

To clarify:

If you go to http://serverip/nps/imanager.html

You should get the imanager login page. If not, apache is not
listening. When you start Apache (ap2webup), you should see:

Apache/2.0.63 (NETWARE) mod_jk/1.2.23 PHP/5.0.5
Listening on port(s): 443 443 631 80 80 80
Loaded dynamic module util_ldap.c
Loaded dynamic module mod_auth_ldap.c
Loaded dynamic module mod_jk.c
Loaded dynamic module mod_rewrite.c
Loaded dynamic module util_ldap2.c
Loaded dynamic module mod_auth_ldapdn.c

Ors something similar.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
elangogopal Absent Member.
Absent Member.

Re: Imanager login webpage failed to load!

Thanks for update.

I am able to access the imanager login webpage and logged in using port number 2200 as https://0.0.0.0:2200 it is opening without any issues, and also checked the opening port of 8009 by tcpcon and telnet that all working fine.

Can you please explain what about "M APA*" ? as you mentioned the here "Try M APA" and please let me know which logs file your want to check, i will be glad to attach the log file here in the next post.

Thanks in advance.
0 Likes
elangogopal Absent Member.
Absent Member.

Re: Imanager login webpage failed to load!

i apologize. i am not onsite right now where Netware imanager server is located. I already tried many times access this link http://serverip/nps/imanager.html which was not opening! So is the meaning my apache service has down on the server even though i was able to open this imanager webpage on the default port on http://serverip:2200 and was able to logged in using username and password?

Is it enough to identify the issue either if i send you the apache logs /apache2/logs/ only ? or send you all those logs such as tomcat,imanager,pkidiag,apache? Please suggest me.

i really appreciate your taking the time to help me.

Thanks
Elango Gopal
0 Likes
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

On 08.08.2012 16:46, elangogopal wrote:
>
> Thanks for update.
>
> I am able to access the imanager login webpage and logged in using port
> number 2200 as https://0.0.0.0:2200 it is opening without any issues,
> and also checked the opening port of 8009 by tcpcon and telnet that all
> working fine.


2200 is a different Apache instance (the admin server), not he one that
runs iManager.

> Can you please explain what about "M APA*" ?


Enter it on the console. It will either return nothing, or all loaded
modules named APAXXXXXX, one of which will be apache2. But we already
know Apache is running, but there need to be *two* seperate Apache
instances. The important one in your case doesn't seem to be.

ap2webup is the command that starts the proper imanager. If you execute
it, there *should* be an error somewhere, at the very very least there
will be one in the apache error.log

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

Massimo Rosen,
> at the very very least there
> will be one in the apache error.log


Which normally is \\server\sys\apache2\logs\error_log

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
gopalelango Absent Member.
Absent Member.

Re: Imanager login webpage failed to load!

I want to thank you both, Anders and Massimo for your support.

I understand clearly here, 2200,8009 are not related to apache instance and seperate process from the apache. let me look into the Apache error logs \\server\sys\apache2\logs\error_log. Also i would like to check the port 80,443 listening status on the server logger console as well as using the tcpcon utility after ran the ap2webup as you have suggested.

Please stand by for further update.

Thanks,
Elango Gopal
0 Likes
gopalelango Absent Member.
Absent Member.

Re: Imanager login webpage failed to load!

Hello Anders and mrosen,

> Which normally is \\server\sys\apache2\logs\error_log

I noticed that port 443,80 are not listening on the server,checked by the tcpcon and nmap utility.Please refer the apache error_log given below.

cat /apache2/logs/error_log

[Thu Aug 02 13:19:54 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 13:27:10 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 13:34:37 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 13:37:29 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 13:57:05 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 13:58:56 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 14:33:32 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 14:40:40 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 19:17:43 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 19:24:52 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 19:31:18 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 19:32:21 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 19:42:10 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 19:49:11 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 19:55:31 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 20:02:36 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 20:25:49 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 20:26:28 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations
[Thu Aug 02 20:31:59 2012] [notice] caught SIGTERM, shutting down
[Thu Aug 02 20:39:01 2012] [notice] Apache/2.0.59 (NETWARE) mod_jk/1.2.15 PHP/5.0.5
configured -- resuming normal operations

cat /apache2/logs/error_log.1343920154 ( Most of the all log files are showing as below )
[Thu Aug 02 20:39:14 2012] [notice] LDAP: Built with Novell LDAP SDK
[Thu Aug 02 20:39:14 2012] [notice] LDAP: SSL support available
[Thu Aug 02 20:39:15 2012] [notice] LDAP: Built with Novell LDAP SDK
[Thu Aug 02 20:39:15 2012] [notice] LDAP: SSL support available
(OS 10037)Operation already in progress: make_sock: unable to listen for connections on
address 0.0.0.0:631
[Thu Aug 02 20:39:15 2012] [alert] no listening sockets available, shutting down
[Thu Aug 02 20:39:15 2012] [alert] no listening sockets available, shutting down

Maybe I'm missing something,Anyone with any idea what is the problem and how I can fix this Apache down issue?.Thank you in advanced for the help

Please do let me know if you need any more information.

Thanks,
Elango Gopal
0 Likes
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

Hi.

On 10.08.2012 10:46, gopalelango wrote:
> (OS 10037)Operation already in progress: make_sock: unable to listen
> for connections on
> address 0.0.0.0:631


That's a weird one. You have iPrint installed. iPrint starts with Apache
too, and needs port 631. On your server however, port 631 is already in
use, so iPrint can't start, so Apache2 can't start.

I'm not aware of any "normal" software on Netware that would occupy port
631. You have to find out who/what is stealing that.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

Massimo Rosen,
> I'm not aware of any "normal" software on Netware that would occupy port
> 631. You have to find out who/what is stealing that.


Or comment out iprint from httpd.conf temporarily to verify apache2 starts
then.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
gopalelango Absent Member.
Absent Member.

Re: Imanager login webpage failed to load!

Massimo Rosen and Anders Gustafsson,
Thanks for update.

> That's a weird one. You have iPrint installed. iPrint starts with Apache
> too, and needs port 631. On your server however, port 631 is already in
> use, so iPrint can't start, so Apache2 can't start.

I got your point,noticed that 631 port is opened on the server side checked by the nmap utility on the client side,nmap logs provided here for your reference.Would do something else to fix issue.i am searching here for the resolution.

> Or comment out iprint from httpd.conf temporarily to verify apache2 starts
> then.

Surely i am going to perform your suggestion.i noticed the apache logs today,same error getting repeatedly in the log files.Also checked the port 631 is opened on the server.

cat /adminsrv/logs/errors (Latest admin server error logs)

sys:/adminsrv/webapps/WebAdmin/status.jsp
[Thu Aug 09 17:15:33 2012] [error] [client ip ] File does not exist:
sys:/adminsrv/webapps/WebAdmin/master.jsp
[Thu Aug 09 17:58:57 2012] [error] [client ip ] File does not exist:
sys:/adminsrv/webapps/WebAdmin/Other, referer: https://serverip:2200/welcome/IPMGMT.html

cat /apache2/logs/error_log ( Latest Apache error logs )

[Fri Aug 10 13:27:23 2012] [notice] LDAP: Built with Novell LDAP SDK
[Fri Aug 10 13:27:23 2012] [notice] LDAP: SSL support available
[Fri Aug 10 13:27:24 2012] [notice] LDAP: Built with Novell LDAP SDK
[Fri Aug 10 13:27:24 2012] [notice] LDAP: SSL support available
(OS 10037)Operation already in progress: make_sock: unable to listen for connections on address 0.0.0.0:631
[Fri Aug 10 13:27:24 2012] [alert] no listening sockets available, shutting down
[Fri Aug 10 13:27:24 2012] [alert] no listening sockets available, shutting down

nmap utility port scanned on the Netware server on the client side.Observed the 631 port was opened while the 80 and 443 was not opened.

| ssl-cert: Subject: commonName=dns_name/organizationName=servername
| Issuer: organizationName=ou_name
| Public Key type: rsa
| Public Key bits: 2048
| Not valid before: 2012-08-02 14:41:27
| Not valid after: 2014-08-02 14:41:27
| MD5: 2767 b30c 3a00 9468 3210 0abf 5838 7431
|_SHA-1: b80f d2e9 052b c859 9a97 715c ed43 3c09 0824 409b
23/tcp open telnet Cisco or Edge-core switch telnetd
81/tcp open http Novell NetWare HTTP Stack (HTTPSTK.NLM)
|_http-title: Did not follow redirect to https://serverip:8009/ and no page was returned.
|_http-favicon: Unknown favicon MD5: A5E63B134D225F4602BDEFC80C1B004C
139/tcp open netbios-ssn NetWare 6 SMB Services
389/tcp open ldap (Anonymous bind OK)
427/tcp open svrloc?
524/tcp open ncp Novell NetWare NCP
548/tcp open afp Novell NetWare AFP 5.70.06 (name: servername; protocol 3.1)
631/tcp open http Novell NetWare HTTP Stack (HTTPSTK.NLM)
|_http-favicon: Unknown favicon MD5: A5E63B134D225F4602BDEFC80C1B004C
|_http-title: Did not follow redirect to https://serverip:8009/ and no page was returned.
636/tcp open ssl/ldap (Anonymous bind OK)
1043/tcp open rconj Novell rconj (Unknown token: servername)
1070/tcp open gmrupdateserv?
1074/tcp open warmspotMgmt?
2200/tcp open ssl/http Apache httpd 2.0.59 ((NETWARE) mod_jk/1.2.15 PHP/5.0.5)
| ssl-cert: Subject: commonName=dns_name/organizationName=ou_name
| Issuer: organizationName=ou_name
| Public Key type: rsa
| Public Key bits: 2048
| Not valid before: 2012-08-02 14:41:27
| Not valid after: 2014-08-02 14:41:27
| MD5: 2767 b30c 3a00 9468 3210 0abf 5838 7431
|_SHA-1: b80f d2e9 052b c859 9a97 715c ed43 3c09 0824 409b
3351/tcp open psql-btrieve serer- getese
5989/tcp open ssl/http Openwbem CIMOM httpd 3.1.0
|_http-methods: No Allow or Public header in OPTIONS response (status code 401)
| ssl-cert: Subject: commonName=dns.dns/organizationName=Organization Name/stateOrProvinceName=Test State or
Province/countryName=seredg
| Issuer: commonName=dns.dns/organizationName=Organization Name/stateOrProvinceName=Test State or
Province/countryName=seredg
6101/tcp open backupexec?
6901/tcp open jetstream?
8008/tcp open http Novell NetWare HTTP Stack (HTTPSTK.NLM)
|_http-favicon: Unknown favicon MD5: A5E63B134D225F4602BDEFC80C1B004C
|_http-title: Did not follow redirect to https://serverip:8009/ and no page was returned.
8009/tcp open http Novell NetWare HTTP Stack (HTTPSTK.NLM)
|_http-title: Did not follow redirect to https://serverip:8009/ and no page was returned.
|_http-favicon: Unknown favicon MD5: A5E63B134D225F4602BDEFC80C1B004C
8080/tcp open http Novell NetWare HTTP Stack (HTTPSTK.NLM)
|_http-title: Did not follow redirect to https://serverip:8009/ and no page was returned.
|_http-favicon: Unknown favicon MD5: A5E63B134D225F4602BDEFC80C1B004C
8089/tcp open http Novell NetWare HTTP Stack (HTTPSTK.NLM)
|_http-title: Did not follow redirect to https://serverip:8009/ and no page was returned.
9009/tcp open pichat?
9010/tcp open sdr?
10000/tcp open ndmp Symantec/Veritas Backup Exec ndmp
10002/tcp open documentum?
21571/tcp open unknown
OS details: Novell NetWare 6.5 Open Enterprise Server SP6

Thanks for all to take a look in this.
Elango Gopal
0 Likes
Knowledge Partner
Knowledge Partner

Re: Imanager login webpage failed to load!

Gopalelango,
> 631/tcp open http Novell NetWare HTTP Stack
> (HTTPSTK.NLM)


Ooops. Try unloading httpstk (unload httpstk) that will stop the
NetWare remote manager. See if Apache starts then?

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.