iliadmin1 Absent Member.
Absent Member.
956 views

Issue with Unitrends Backup on OES2018 Edirectory Server

Having an issue on my full backups by my Unitrends appliance for an eDirectory server running on OES 2018.
I have been troubleshooting with Unitrends to discover where the errors are occurring and determined it is with the directory path /var/opt/novell/nclmnt/ on the server. The full backup completes, but shows a warning ( ERROR: 4 extended attribute/value pairs failed). Further digging into the logs using debug level shows these messages:

Failed to get the size of extended attributes: No such file or directory
a /var/opt/novell/nclmnt/.Trees, 0 blocks
Failed to get the size of extended attributes: No such file or directory
a /var/opt/novell/nclmnt/.Servers, 0 blocks
Failed to get the size of extended attributes: No such file or directory
a /var/opt/novell/nclmnt/root, 0 blocks
Failed to get the size of extended attributes: No such file or directory

As you can see once the backup gets to the path it does not return block information but instead it gets "No Such File or Directory".
The file path/directories listed are in fact there and I have verified that.

Is there something I have to change for the directory folder attributes to allow my Unitrends backup to do what it needs to do here?
Has anyone experienced this with any other backup solution?

If it matters, this eDirectory server is also a VM hosted on ESXi 6.7.

Anyone see this before?

The current attributes on this path are (from NRM):
Folder Information nclmnt N/A Tue 11 Dec 2018 06:22:11 PM EST d rwx rwx rwx
Folder Information .Servers N/A Tue 11 Dec 2018 06:22:11 PM EST d rwx rwx rwx
Folder Information .Trees N/A Tue 11 Dec 2018 06:22:11 PM EST d rwx rwx rwx
Folder Information root N/A Tue 11 Dec 2018 06:22:41 PM EST d rwx ... ...

Kind regards,

Val

GW 2018 & Mobility Service-Version: 18.1.0 Build: 410 on SLES 12SP3, GW Client 18.02 (Build 131493) on Windows 7 64bit; server OES 11 on SLES 11 SP3; eDirectory 9.1 on SLES12SP3 and eDirectory 8.8sp8 on SLES11 SP3
Labels (2)
0 Likes
5 Replies
AutomaticReply Absent Member.
Absent Member.

Re: Issue with Unitrends Backup on OES2018 Edirectory Server

iliadmin,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
iliadmin1 Absent Member.
Absent Member.

Re: Issue with Unitrends Backup on OES2018 Edirectory Server

I know it 's the holidays...but has anybody run across this before? Anyone know the function /purpose of the /var/opt/novell/nclmnt directory/tree? If I specifically exclude that tree/path, my backup does fail, so it has some significance.....?

Kind regards,

Val

GW 2018 & Mobility Service-Version: 18.1.0 Build: 410 on SLES 12SP3, GW Client 18.02 (Build 131493) on Windows 7 64bit; server OES 11 on SLES 11 SP3; eDirectory 9.1 on SLES12SP3 and eDirectory 8.8sp8 on SLES11 SP3
0 Likes
Knowledge Partner
Knowledge Partner

Re: Issue with Unitrends Backup on OES2018 Edirectory Server

It's merely a mountpoint for the novell client package. It's e.g. used if you ftp into a server and navigate to another one (with ftp methods). In this case the server you've ftp'd in will establish a client connection to the other server behind the scenes. While i don't see a reason to back this up due to its volatile nature i've never excluded it anywhere and never got an error. But i use SEP Sesam for all of my clients and these folks do an excellent job especially in OES / ...x environments.
My primary question would be: why on earth would a backup fail if you tell it NOT TO backup something?
0 Likes
iliadmin1 Absent Member.
Absent Member.

Re: Issue with Unitrends Backup on OES2018 Edirectory Server

So this is a server that only runs eDirectory, nothing else. So if this is a mount point for the Novell client package, then you're right that it does not make any sense why I cannot exclude it from a backup without causing the backup to fail. It is totally weird. Yet, that is exactly what is happening. If I don't exclude it, I get a warning about it. And only on a full backup, not an incremental, because the directory/path is not actively used so it does not change.

GW 2018 & Mobility Service-Version: 18.1.0 Build: 410 on SLES 12SP3, GW Client 18.02 (Build 131493) on Windows 7 64bit; server OES 11 on SLES 11 SP3; eDirectory 9.1 on SLES12SP3 and eDirectory 8.8sp8 on SLES11 SP3
0 Likes
iliadmin1 Absent Member.
Absent Member.

Re: Issue with Unitrends Backup on OES2018 Edirectory Server

Update if anyone is interested: I had opened an SR with Micro Focus, but the response I got was "exclude the directories from the backup". Which I said I was trying to do but it wasn't allowing me to, likely due to the failure to get attribute errors. More Googling today led me to a page on the SP1 patch for OES 11 that included a bugfix for an issue with this directory, referenced in TID 7014386. Specifically "Bug 847008 - Change in the OES 11 getfattr implementation results in backup errors while trying to access the /var/opt/novell/nclmnt/ folder." Which sounds an awful lot like what is happening in my Unitrends backup! I have an OES11 SP3 server that is being backed up by the same Unitrends appliance and that directory path is not an issue on it, and I didn't have to set any exclusion for it to be ignored, and it also has eDirectory installed. So... I opened a new SR (my other one was closed unresolved). HOPEFULLY it is the same bug and the same fix can be created and applied and I'll have successful backups of this eDirectory server.

Val

GW 2018 & Mobility Service-Version: 18.1.0 Build: 410 on SLES 12SP3, GW Client 18.02 (Build 131493) on Windows 7 64bit; server OES 11 on SLES 11 SP3; eDirectory 9.1 on SLES12SP3 and eDirectory 8.8sp8 on SLES11 SP3
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.