Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.

Kanaka Home Folder Issues

While attempting to hold a pilot of Kanaka on our 6 iMacs I found that, in testing, everything worked as expected and I was very pleased. However, it seemed that the first 5 users failed to log in. Within such a short period of time I backtracked and just allowed open access on a generic user account until I could figure out what was going in.

At first users received the following error when they attempted to log in.

"You are unable to log in to the user account "username" at this time.

Logging in to the account failed because an error occurred."

I'll admit, the user accounts that seemed to have no issue logging in included usernames that started with A or B for student accounts and any staff account from A to Z didn't seem to have any issues.

Manually connecting using Connect to Server... and using CIFS showed that users after A and B experienced authentication issues so we pushed the protocol back down on server where student accounts resided and restarted and found that manual connections were possible.

Now, all users were finally able to log in. Then we hit another roadblock. Student accounts with usernames beginning with A experienced no issues logging in and the Desktop folder mapped beautifully as expected (we're not using Mobile Accounts since I don't want the data to remain on the Macs). However, users with names beginning with another letter experienced this next error after they logged in.

"The home folder for user "username" isn't located in the usual place or can't be accessed.

The home or Users folder may have been moved or deleted. If the home folder is located on the network, the server may be temporarily unavailable. If you continue to have problems, see you system administrator."

This error infuriated me since there didn't seem to be any clear logging to show why this was happening to all but users that started with A.

The 6 iMacs are running Mavericks 10.9.5 (most up to date) and Kanaka is at version
The server is running SLES 11 SP3 x64 OES 11 SP2

I hesitated to update to Yosemite when it came out as we didn't know what would break. As it turned out Kanaka broke until an update came out and our Printing (using Novell) failed until that was updated and users who connected to our older shared drive server also experienced issues until we placed a config file in /private/etc (this impacted staff shared drive access and student home drive access).

I decided to do some testing on the iMac at my desk as it had been updated to Yosemite when it first came out and we've since worked out most of the bugs and I knew Kanaka worked once more on that machine. I tried logging in with a few student accounts I had to play with (one starting with A, B and R). I found that all logins succeeded AND I didn't receive the above error about home folder locations.

I'm currently updating one of the 6 iMacs with Yosemite and I'll update the Kanaka client to 2.8.1 and we'll see how that works and if Printing and file access is still intact (can't forget the config file for the older server).
Labels (1)
1 Reply
Absent Member.
Absent Member.

!! UPDATE !!

One iMac has been updated and the new client was installed (kanaka version 2.8.1) and our config files was dropped in /private/etc. Kanaka was configured and I changed the log in page to show the username and password field. One of the test student accounts that started with R was able to log in (first hurdle) and their single Desktop icon appeared (the second hurdle). Unfortunately this account had no money for printing so I had to switch to a different user. All seems well.

That Kanaka update client side for the plugin must have fixed a number of issues. I almost feel brave enough to start another pilot.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.