Anonymous_User Absent Member.
Absent Member.
14533 views

LUM problem - new thread

I am starting new thread as the other one is way too long & way too messy.

Here is the situation:

Brand new install of OES2, activated, ALL updates to date

LDAP server on a remote NW 6.5 SP6 machine

I can browse LDAP server from OES2 server with LDAP Browser (login or
Anonymous) with NO problems!

namconfig add -a cn=adminuser,ou=users,o=spgs,c=uk -p password -r
ou=users,o=spgs,c=uk -w ou=OESLinux,o=spgs,c=uk -S 10.0.0.3:389 -l 636 -y
cn=LUMldapuser,o=spgs,c=uk -d password

namconfig.getSchemaName: schema name = cn=schema
NAM Schema is extended successfully.
NAM Unique id schema is already extended.
uidNumber and gidNumber attribute indices already exist in the LDAP server
Creating the Unix Config object...done.
Creating the Unix Workstation object... already exists
Adding the workstation context...done.
Stopping the service 'namcd'...done.
Stopping the service 'nscd'...done.
Starting the service 'namcd'... Done.
Starting the service 'nscd'... Done.
Configure done successfully.

plone:~ # id adminuser
id: admin: No such user

Which means LUM is not working.

Trying to reconfigure LUM from Yast2 (all services selected for LUM) gives
error:

Unable to connect to LDAP server 10.0.0.3 or the specified user
cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
configure Linux User Management
Please correct the problem and re-run namconfig after the install

It is the same IP and user that namconfig is happy with!

I am lost (as much as my OES2 is itself I believe)

Seb




Labels (2)
0 Likes
53 Replies
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

namuserlist adminuser

No such object exist

getent passwd definitely does NOT report eDir users

Seb

"Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> wrote in message
news:sNSxj.6139$Ec7.24@kovat.provo.novell.com...
>I am starting new thread as the other one is way too long & way too messy.
>
> Here is the situation:
>
> Brand new install of OES2, activated, ALL updates to date
>
> LDAP server on a remote NW 6.5 SP6 machine
>
> I can browse LDAP server from OES2 server with LDAP Browser (login or
> Anonymous) with NO problems!
>
> namconfig add -a cn=adminuser,ou=users,o=spgs,c=uk -p password -r
> ou=users,o=spgs,c=uk -w ou=OESLinux,o=spgs,c=uk -S 10.0.0.3:389 -l 636 -y
> cn=LUMldapuser,o=spgs,c=uk -d password
>
> namconfig.getSchemaName: schema name = cn=schema
> NAM Schema is extended successfully.
> NAM Unique id schema is already extended.
> uidNumber and gidNumber attribute indices already exist in the LDAP server
> Creating the Unix Config object...done.
> Creating the Unix Workstation object... already exists
> Adding the workstation context...done.
> Stopping the service 'namcd'...done.
> Stopping the service 'nscd'...done.
> Starting the service 'namcd'... Done.
> Starting the service 'nscd'... Done.
> Configure done successfully.
>
> plone:~ # id adminuser
> id: admin: No such user
>
> Which means LUM is not working.
>
> Trying to reconfigure LUM from Yast2 (all services selected for LUM) gives
> error:
>
> Unable to connect to LDAP server 10.0.0.3 or the specified user
> cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
> configure Linux User Management
> Please correct the problem and re-run namconfig after the install
>
> It is the same IP and user that namconfig is happy with!
>
> I am lost (as much as my OES2 is itself I believe)
>
> Seb
>
>
>
>



0 Likes
MarkCRobinson Absent Member.
Absent Member.

Re: LUM problem - new thread

On Fri, 29 Feb 2008 13:54:32 +0000, Sebastian Cerazy wrote:

> namuserlist adminuser
>
> No such object exist
>
> getent passwd definitely does NOT report eDir users


Ok, in iManager do you see a workstation object for your server?

Can you then manually LUM enable the adminuser and assign it to the server.
Then run rcnamcd restart on the workstation and see if the user appears
(this may take a few minutes).


--
Mark Robinson
Novell Volunteer SysOp
www.nds8.co.uk
One by one the penguins steal my sanity...


Novell Volunteer SysOp www.nds8.co.uk One by one the penguins steal my sanity...
0 Likes
MarkCRobinson Absent Member.
Absent Member.

Re: LUM problem - new thread

On Fri, 29 Feb 2008 12:21:44 +0000, Sebastian Cerazy wrote:

>
> Trying to reconfigure LUM from Yast2 (all services selected for LUM) gives
> error:
>
> Unable to connect to LDAP server 10.0.0.3 or the specified user
> cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
> configure Linux User Management
> Please correct the problem and re-run namconfig after the install



I think we need to get someone in here who understands LDAP...

I will ask and see who bites!
--
Mark Robinson
Novell Volunteer SysOp
www.nds8.co.uk
One by one the penguins steal my sanity...


Novell Volunteer SysOp www.nds8.co.uk One by one the penguins steal my sanity...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

EVERYTHING on the eDir side is already done
The user(s) are enabled & assigned to the Unix workstation object

Seb

"markr" <markr@no-mx.forums.novell.com> wrote in message
news:pan.2008.02.29.15.31.53.519903@no-mx.forums.novell.com...
> On Fri, 29 Feb 2008 13:54:32 +0000, Sebastian Cerazy wrote:
>
>> namuserlist adminuser
>>
>> No such object exist
>>
>> getent passwd definitely does NOT report eDir users

>
> Ok, in iManager do you see a workstation object for your server?
>
> Can you then manually LUM enable the adminuser and assign it to the
> server.
> Then run rcnamcd restart on the workstation and see if the user appears
> (this may take a few minutes).
>
>
> --
> Mark Robinson
> Novell Volunteer SysOp
> www.nds8.co.uk
> One by one the penguins steal my sanity...
>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

I wonder what kind of setup ldap.conf needs (I assume all is OK, as the LDAP
browser works OK)

Seb

"markr" <markr@no-mx.forums.novell.com> wrote in message
news:pan.2008.02.29.15.33.02.25814@no-mx.forums.novell.com...
> On Fri, 29 Feb 2008 12:21:44 +0000, Sebastian Cerazy wrote:
>
>>
>> Trying to reconfigure LUM from Yast2 (all services selected for LUM)
>> gives
>> error:
>>
>> Unable to connect to LDAP server 10.0.0.3 or the specified user
>> cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
>> configure Linux User Management
>> Please correct the problem and re-run namconfig after the install

>
>
> I think we need to get someone in here who understands LDAP...
>
> I will ask and see who bites!
> --
> Mark Robinson
> Novell Volunteer SysOp
> www.nds8.co.uk
> One by one the penguins steal my sanity...
>



0 Likes
spgsitsupport Absent Member.
Absent Member.

Re: LUM problem - new thread

Anybody please?

Unable to install LUM with YAST - Insufficient rights / LDAP not working error (-5875)

This document (3646068) and many OTHERS followed & no chance so far to get it working

Thanks

Seb
0 Likes
spgsitsupport Absent Member.
Absent Member.

Re: LUM problem - new thread

How does this:

Cool Solutions: How to configure LUM on a new SUSE workstation

relate to current OES2?

Seb
0 Likes
spgsitsupport Absent Member.
Absent Member.

Re: LUM problem - new thread

This also makes no difference:

Cool Solutions: LUM-enabling eDirectory Users
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

Well, ldap.conf is for the client side, you DONT need to edit it cuz u
running eDir.
So please check your /etc/nam.conf so that your base-name points where the
UNIX config object resides. Preferred-server with IP to replica server.

If you change anything in nam.conf reissue namconfig -k to recreate the
certs in /var/lib/novell-lum.
Then restart namcd and try "namuserlist wwwrun" and "namgrouplist www", get
any output?


"Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> skrev i meddelandet
news:6XVxj.6218$Ec7.1762@kovat.provo.novell.com...
> I wonder what kind of setup ldap.conf needs (I assume all is OK, as the
> LDAP browser works OK)
>
> Seb
>
> "markr" <markr@no-mx.forums.novell.com> wrote in message
> news:pan.2008.02.29.15.33.02.25814@no-mx.forums.novell.com...
>> On Fri, 29 Feb 2008 12:21:44 +0000, Sebastian Cerazy wrote:
>>
>>>
>>> Trying to reconfigure LUM from Yast2 (all services selected for LUM)
>>> gives
>>> error:
>>>
>>> Unable to connect to LDAP server 10.0.0.3 or the specified user
>>> cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
>>> configure Linux User Management
>>> Please correct the problem and re-run namconfig after the install

>>
>>
>> I think we need to get someone in here who understands LDAP...
>>
>> I will ask and see who bites!
>> --
>> Mark Robinson
>> Novell Volunteer SysOp
>> www.nds8.co.uk
>> One by one the penguins steal my sanity...
>>

>
>

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

Done all that & namuserlist wwwrun gives:

No such object exist

Seb

"Anders Bengtsson" <thenotsoveryhumblebabe@fairlight.com> wrote in message
news:aW5Aj.8227$Ec7.2881@kovat.provo.novell.com...
> Well, ldap.conf is for the client side, you DONT need to edit it cuz u
> running eDir.
> So please check your /etc/nam.conf so that your base-name points where the
> UNIX config object resides. Preferred-server with IP to replica server.
>
> If you change anything in nam.conf reissue namconfig -k to recreate the
> certs in /var/lib/novell-lum.
> Then restart namcd and try "namuserlist wwwrun" and "namgrouplist www",
> get any output?
>
>
> "Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> skrev i meddelandet
> news:6XVxj.6218$Ec7.1762@kovat.provo.novell.com...
>> I wonder what kind of setup ldap.conf needs (I assume all is OK, as the
>> LDAP browser works OK)
>>
>> Seb
>>
>> "markr" <markr@no-mx.forums.novell.com> wrote in message
>> news:pan.2008.02.29.15.33.02.25814@no-mx.forums.novell.com...
>>> On Fri, 29 Feb 2008 12:21:44 +0000, Sebastian Cerazy wrote:
>>>
>>>>
>>>> Trying to reconfigure LUM from Yast2 (all services selected for LUM)
>>>> gives
>>>> error:
>>>>
>>>> Unable to connect to LDAP server 10.0.0.3 or the specified user
>>>> cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
>>>> configure Linux User Management
>>>> Please correct the problem and re-run namconfig after the install
>>>
>>>
>>> I think we need to get someone in here who understands LDAP...
>>>
>>> I will ask and see who bites!
>>> --
>>> Mark Robinson
>>> Novell Volunteer SysOp
>>> www.nds8.co.uk
>>> One by one the penguins steal my sanity...
>>>

>>
>>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

Above is correct as wwwrun does NOT exist
I have another users (auto created in same OU as the Unix workstation
ploneadmin)

namuserlist ploneadmin works OK giving the correct autput

But it seems to be limited to ONLY this OU (and nothing elswhere)

Seb

"Anders Bengtsson" <thenotsoveryhumblebabe@fairlight.com> wrote in message
news:aW5Aj.8227$Ec7.2881@kovat.provo.novell.com...
> Well, ldap.conf is for the client side, you DONT need to edit it cuz u
> running eDir.
> So please check your /etc/nam.conf so that your base-name points where the
> UNIX config object resides. Preferred-server with IP to replica server.
>
> If you change anything in nam.conf reissue namconfig -k to recreate the
> certs in /var/lib/novell-lum.
> Then restart namcd and try "namuserlist wwwrun" and "namgrouplist www",
> get any output?
>
>
> "Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> skrev i meddelandet
> news:6XVxj.6218$Ec7.1762@kovat.provo.novell.com...
>> I wonder what kind of setup ldap.conf needs (I assume all is OK, as the
>> LDAP browser works OK)
>>
>> Seb
>>
>> "markr" <markr@no-mx.forums.novell.com> wrote in message
>> news:pan.2008.02.29.15.33.02.25814@no-mx.forums.novell.com...
>>> On Fri, 29 Feb 2008 12:21:44 +0000, Sebastian Cerazy wrote:
>>>
>>>>
>>>> Trying to reconfigure LUM from Yast2 (all services selected for LUM)
>>>> gives
>>>> error:
>>>>
>>>> Unable to connect to LDAP server 10.0.0.3 or the specified user
>>>> cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
>>>> configure Linux User Management
>>>> Please correct the problem and re-run namconfig after the install
>>>
>>>
>>> I think we need to get someone in here who understands LDAP...
>>>
>>> I will ask and see who bites!
>>> --
>>> Mark Robinson
>>> Novell Volunteer SysOp
>>> www.nds8.co.uk
>>> One by one the penguins steal my sanity...
>>>

>>
>>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

Re-configure the UNIX objects again maybe will do it.. and the UNIX
Workstation object,
re-enabled the group AND the user account as a LUM enabled user once again.


"Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> skrev i meddelandet
news:75bAj.8273$Ec7.3692@kovat.provo.novell.com...
> Above is correct as wwwrun does NOT exist
> I have another users (auto created in same OU as the Unix workstation
> ploneadmin)
>
> namuserlist ploneadmin works OK giving the correct autput
>
> But it seems to be limited to ONLY this OU (and nothing elswhere)
>
> Seb
>
> "Anders Bengtsson" <thenotsoveryhumblebabe@fairlight.com> wrote in message
> news:aW5Aj.8227$Ec7.2881@kovat.provo.novell.com...
>> Well, ldap.conf is for the client side, you DONT need to edit it cuz u
>> running eDir.
>> So please check your /etc/nam.conf so that your base-name points where
>> the
>> UNIX config object resides. Preferred-server with IP to replica server.
>>
>> If you change anything in nam.conf reissue namconfig -k to recreate the
>> certs in /var/lib/novell-lum.
>> Then restart namcd and try "namuserlist wwwrun" and "namgrouplist www",
>> get any output?
>>
>>
>> "Sebastian Cerazy" <sebastian.cerazy@(nospam)spgs.org> skrev i
>> meddelandet news:6XVxj.6218$Ec7.1762@kovat.provo.novell.com...
>>> I wonder what kind of setup ldap.conf needs (I assume all is OK, as the
>>> LDAP browser works OK)
>>>
>>> Seb
>>>
>>> "markr" <markr@no-mx.forums.novell.com> wrote in message
>>> news:pan.2008.02.29.15.33.02.25814@no-mx.forums.novell.com...
>>>> On Fri, 29 Feb 2008 12:21:44 +0000, Sebastian Cerazy wrote:
>>>>
>>>>>
>>>>> Trying to reconfigure LUM from Yast2 (all services selected for LUM)
>>>>> gives
>>>>> error:
>>>>>
>>>>> Unable to connect to LDAP server 10.0.0.3 or the specified user
>>>>> cn=adminuser,ou=users,o=spgs,c=uk does not have enough privileges to
>>>>> configure Linux User Management
>>>>> Please correct the problem and re-run namconfig after the install
>>>>
>>>>
>>>> I think we need to get someone in here who understands LDAP...
>>>>
>>>> I will ask and see who bites!
>>>> --
>>>> Mark Robinson
>>>> Novell Volunteer SysOp
>>>> www.nds8.co.uk
>>>> One by one the penguins steal my sanity...
>>>>
>>>
>>>

>
>

0 Likes
spgsitsupport Absent Member.
Absent Member.

Re: LUM problem - new thread

Done that countless number of times with 0 results

Seb
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: LUM problem - new thread

Then you got serious problems and need to get in touch with Novell Support.

"spgsitsupport" <spgsitsupport@no-mx.forums.novell.com> skrev i meddelandet
news:spgsitsupport.362ow1@no-mx.forums.novell.com...
>
> Done that countless number of times with 0 results
>
> Seb
>
>
> --
> spgsitsupport
> ------------------------------------------------------------------------
> spgsitsupport's Profile: http://forums.novell.com/member.php?userid=2356
> View this thread: http://forums.novell.com/showthread.php?t=314106
>

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.