Highlighted
mauzi Absent Member.
Absent Member.
941 views

Locking issues - login script related?

Dear Forum,

Server side: OES 11 SP2 and 2015 SP1
Client side: Windows 7 x64 (latest updates, latest Novell/OES Client, latest iPrint client, etc.)

I'm running an external batch file from the login script. (Tests if directory exists, creates directories in the users home directory if not exist, populates template files, etc. Nothing special - only basic DOS/Windows shell commands.) Let's call this as "template.bat".

Sometimes and somehow the batch file gets stucked in on the client. I see the file "template.bat" is open via Remote Manager. Then, no one can login into the network anymore - the "template.bat" is locked, and all clients get stucked on the login script.

If I close the stucked connection on the file "template.bat" manually, all the other clients go on, and their login script completes.

I cannot reproduce it manually. I have started "template.bat" many times, and it worked properly. However, it stucks in about 1-3 times per week in a network with ~1000 users.

If I disable oplocks on the server, the problem goes away - as well is client-side caching goes away too. This is not acceptable for performance reasons.

Basically, I have two questions:

- Why and how can a simple cmd batch file stuck in?
- Why does it have an exclusive lock on the batch file itself? There's no write operation there, only read/execution.

Any ideas?
Thank You!
Labels (1)
0 Likes
2 Replies
AutomaticReply Absent Member.
Absent Member.

Re: Locking issues - login script related?

mauzi,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
mmccaffe1 Absent Member.
Absent Member.

Re: Locking issues - login script related?

Have you tried flagging the file Read only?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.