Highlighted
crivera1 Absent Member.
Absent Member.
1482 views

Mixed Cluster WARNING Waited 10 seconds executing vgs

I have a cluster of 2 nodes Novell NetWare 6.5 SP8 and Novell Cluster Services 1.8.0, with 5 resources (NSS Pools) shared in a SAN SYMMETRIX EMC.
This cluster is 4 years old working without problems and it will be migrated to SLES11SP2/OES11SP1
As part of the process of migration, there have been added to the cluster two nodes SLES11SP2/OES11SP1.
Both nodes joined to the cluster without problems.
Five (5) resources of the cluster was migrate to the nodes SLES11SP2/OES11SP1 without problems.
I can do actions as offline, online, migrate of the resources between all the nodes of the cluster (NetWare and OES).
I do a trustee synchronization with "ncpcon nss resync=VOLUME"
All works fine.
In this point I have not realized a "cluster convert commit" because we needed the two nodes Novell NetWare for one month more (aprox) while we modify a system that is still working in a Novell Netware 6.5

I need to create five new resources but when I use NSSMU in any of the nodes SLES11SP2/OES11SP1 to see or to modify the partitions, the system delay 15 minutes, approximately, to display the information.

The same situation in the Yast-> System-> Partitioner

The same happens when I do the command "vgchange -a y". The server delay 15 minutes to display the following message:
Error locking on node NETWARE1: Command timed out
Error locking on node NETWARE2: Command timed out
Why does it try to look in the Netware servers?

Checking the var/log/messages they exist a lot of messages:
nlvm: WARNING: Waited 10 seconds executing: lvs --noheadings --nosuffix --units b --separator , -O
nlvm: WARNING: Waited 10 seconds executing: vgs --noheadings -o vg_attr volgrpsystem
Is that normal?

Any information will be received well.
Thank you
Labels (1)
0 Likes
3 Replies
Knowledge Partner
Knowledge Partner

Re: Mixed Cluster WARNING Waited 10 seconds executing vgs

On 28.10.2013 21:16, crivera wrote:
>
> I have a cluster of 2 nodes Novell NetWare 6.5 SP8 and Novell Cluster
> Services 1.8.0, with 5 resources (NSS Pools) shared in a SAN SYMMETRIX
> EMC.
> This cluster is 4 years old working without problems and it will be
> migrated to SLES11SP2/OES11SP1
> As part of the process of migration, there have been added to the
> cluster two nodes SLES11SP2/OES11SP1.
> Both nodes joined to the cluster without problems.
> Five (5) resources of the cluster was migrate to the nodes
> SLES11SP2/OES11SP1 without problems.
> I can do actions as offline, online, migrate of the resources between
> all the nodes of the cluster (NetWare and OES).
> I do a trustee synchronization with "ncpcon nss resync=VOLUME"
> All works fine.
> In this point I have not realized a "cluster convert commit" because we
> needed the two nodes Novell NetWare for one month more (aprox) while we
> modify a system that is still working in a Novell Netware 6.5
>
> I need to create five new resources but when I use NSSMU in any of the
> nodes SLES11SP2/OES11SP1 to see or to modify the partitions, the system
> delay 15 minutes, approximately, to display the information.
>
> The same situation in the Yast-> System-> Partitioner


Correct. The cluster docs actually tell you. While you have a mixed
cluster, you *MUST* do all changes to the cluster storage on the Netware
nodes, while you relly *should* avoid any such changes. In all cases, be
prepared for the possibility that you end up having to reboot the whole
cluster to get all nodes to accept it.


CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
changju Absent Member.
Absent Member.

Re: Mixed Cluster WARNING Waited 10 seconds executing vgs

Please refrain from adding new resources to the mixed cluster.

crivera;2291104 wrote:
Why does it try to look in the Netware servers?


It tries to get approval from all nodes to make the volume available. Apparently, Netware nodes don't know how to respond here.

crivera;2291104 wrote:
Is that normal?


Such messages (and the delay) will go away once all nodes are running OES11 code.

Regards,

Changju
0 Likes
crivera1 Absent Member.
Absent Member.

Re: Mixed Cluster WARNING Waited 10 seconds executing vgs

Solved!
Thanks for you supports, guys.
We created the new five volumes in NSS format from the NetWare servers. At this moment all works fine.
We´ll do the ""cluster convert commit" in 3 weeks, to closed the cluster migration.
Regards
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.