Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
2588 views

NICI error when upgrade Novell Client 2

Hello,

When we upgrade a Novell Client on Windows 7 x64 Worktation (French) we almost get an NICI related error during installation.
If we manually install NICI just after there is no error.
Any idea?

Thanks.
Labels (1)
0 Likes
9 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

micgra;2232148 wrote:
Hello,

When we upgrade a Novell Client on Windows 7 x64 Worktation (French) we almost get an NICI related error during installation.
If we manually install NICI just after there is no error.
Any idea?

Thanks.


Which Novell Client version version and what error message do you get?

The following bug was fixed in Novell Client 2 SP2 for Windows (IR4):

10. Upgrading through non-Administrators user with update Agent may encounter 1603 error installing NICI.


And here is a link to the latest version: NOVELL: Downloads - Novell Client 2 SP2 for Windows (IR5)

Thomas
0 Likes
Absent Member.
Absent Member.

Actually we have this error with all versions, even when upgrapding from ir4a to ir5.

So it looks the problem is not solved yet.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

micgra;2232165 wrote:
Actually we have this error with all versions, even when upgrapding from ir4a to ir5.

So it looks the problem is not solved yet.


Okay, but what is the error you get?

Thomas
0 Likes
Absent Member.
Absent Member.

Error code : 1612

Mm. the source is on a network share.
It is possible that the Novell Client use a kind of System account to install NICI and so it does not have access to the source files?
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

micgra;2232171 wrote:
Error code : 1612

Mm. the source is on a network share.
It is possible that the Novell Client use a kind of System account to install NICI and so it does not have access to the source files?


That might be the issue....

Does it say anything more useful in the NICI log under C:\ProgramData\Novell\Client\Log?

Thomas
0 Likes
Absent Member.
Absent Member.

Here..

=== Verbose logging started: 23.11.2012  14:44:52  Build type: SHIP UNICODE 5.00.7601.00  Calling process: C:\windows\SysWOW64\msiexec.exe ===
MSI (c) (4C:68) [14:44:52:700]: Resetting cached policy values
MSI (c) (4C:68) [14:44:52:700]: Machine policy value 'Debug' is 0
MSI (c) (4C:68) [14:44:52:700]: ******* RunEngine:
******* Product: C:\ProgramData\Novell\Client\Install\NICI\NICI_wx64.msi
******* Action:
******* CommandLine: **********
MSI (c) (4C:68) [14:44:52:700]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (4C:68) [14:44:52:700]: Grabbed execution mutex.
MSI (c) (4C:68) [14:44:52:731]: Cloaking enabled.
MSI (c) (4C:68) [14:44:52:731]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (4C:68) [14:44:52:731]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (7C:24) [14:44:52:731]: Running installation inside multi-package transaction C:\ProgramData\Novell\Client\Install\NICI\NICI_wx64.msi
MSI (s) (7C:24) [14:44:52:731]: Grabbed execution mutex.
MSI (s) (7C:F4) [14:44:52:731]: Resetting cached policy values
MSI (s) (7C:F4) [14:44:52:731]: Machine policy value 'Debug' is 0
MSI (s) (7C:F4) [14:44:52:731]: ******* RunEngine:
******* Product: C:\ProgramData\Novell\Client\Install\NICI\NICI_wx64.msi
******* Action:
******* CommandLine: **********
MSI (s) (7C:F4) [14:44:52:871]: Machine policy value 'DisableUserInstalls' is 0
MSI (s) (7C:F4) [14:44:52:871]: User policy value 'SearchOrder' is 'nmu'
MSI (s) (7C:F4) [14:44:52:871]: User policy value 'DisableMedia' is 0
MSI (s) (7C:F4) [14:44:52:871]: Machine policy value 'AllowLockdownMedia' is 0
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Media enabled only if package is safe.
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Looking for sourcelist for product {559D2B32-5066-4762-A2F2-52831AC6F67B}
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Adding {559D2B32-5066-4762-A2F2-52831AC6F67B}; to potential sourcelist list (pcode;disk;relpath).
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Now checking product {559D2B32-5066-4762-A2F2-52831AC6F67B}
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Media is enabled for product.
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Attempting to use LastUsedSource from source list.
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Trying source \\source.local\prg\Apps\NovellClient\Windows7\NICI\.
MSI (s) (7C:F4) [14:45:10:171]: Note: 1: 1314 2: \\source.local\prg\Apps\NovellClient\Windows7\NICI\
MSI (s) (7C:F4) [14:45:10:171]: ConnectToSource: CreatePath/CreateFilePath failed with: -2147483648 1314 -2147483648
MSI (s) (7C:F4) [14:45:10:171]: ConnectToSource (con't): CreatePath/CreateFilePath failed with: -2147483648 -2147483648
MSI (s) (7C:F4) [14:45:10:171]: SOURCEMGMT: net source '\\source.local\prg\Apps\NovellClient\Windows7\NICI\' is invalid.
MSI (s) (7C:F4) [14:45:10:171]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:10:171]: SOURCEMGMT: Processing net source list.
MSI (s) (7C:F4) [14:45:10:171]: SOURCEMGMT: Trying source \\source.local\prg\Apps\public\NovellClient\Windows7\NICI\.
MSI (s) (7C:F4) [14:45:12:745]: Note: 1: 1314 2: \\source.local\prg\Apps\public\NovellClient\Windows7\NICI\
MSI (s) (7C:F4) [14:45:12:745]: ConnectToSource: CreatePath/CreateFilePath failed with: -2147483648 1314 -2147483648
MSI (s) (7C:F4) [14:45:12:745]: ConnectToSource (con't): CreatePath/CreateFilePath failed with: -2147483648 -2147483648
MSI (s) (7C:F4) [14:45:12:745]: SOURCEMGMT: net source '\\source.local\prg\Apps\public\NovellClient\Windows7\NICI\' is invalid.
MSI (s) (7C:F4) [14:45:12:745]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:745]: SOURCEMGMT: Processing media source list.
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 2203 2: 3: -2147287037
MSI (s) (7C:F4) [14:45:12:777]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:777]: SOURCEMGMT: Processing URL source list.
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1402 2: UNKNOWN\URL 3: 2
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1706 2: 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:777]: SOURCEMGMT: Failed to resolve source
MSI (s) (7C:F4) [14:45:12:777]: MainEngineThread is returning 1612
MSI (s) (7C:24) [14:45:12:792]: User policy value 'DisableRollback' is 0
MSI (s) (7C:24) [14:45:12:792]: Machine policy value 'DisableRollback' is 0
MSI (s) (7C:24) [14:45:12:792]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (7C:24) [14:45:12:792]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (s) (7C:24) [14:45:12:792]: Restoring environment variables
MSI (c) (4C:68) [14:45:12:792]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (4C:68) [14:45:12:792]: MainEngineThread is returning 1612
=== Verbose logging stopped: 23.11.2012 14:45:12 ===

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

micgra;2232207 wrote:
Here..

=== Verbose logging started: 23.11.2012  14:44:52  Build type: SHIP UNICODE 5.00.7601.00  Calling process: C:\windows\SysWOW64\msiexec.exe ===
MSI (c) (4C:68) [14:44:52:700]: Resetting cached policy values
MSI (c) (4C:68) [14:44:52:700]: Machine policy value 'Debug' is 0
MSI (c) (4C:68) [14:44:52:700]: ******* RunEngine:
******* Product: C:\ProgramData\Novell\Client\Install\NICI\NICI_wx64.msi
******* Action:
******* CommandLine: **********
MSI (c) (4C:68) [14:44:52:700]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (4C:68) [14:44:52:700]: Grabbed execution mutex.
MSI (c) (4C:68) [14:44:52:731]: Cloaking enabled.
MSI (c) (4C:68) [14:44:52:731]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (4C:68) [14:44:52:731]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (7C:24) [14:44:52:731]: Running installation inside multi-package transaction C:\ProgramData\Novell\Client\Install\NICI\NICI_wx64.msi
MSI (s) (7C:24) [14:44:52:731]: Grabbed execution mutex.
MSI (s) (7C:F4) [14:44:52:731]: Resetting cached policy values
MSI (s) (7C:F4) [14:44:52:731]: Machine policy value 'Debug' is 0
MSI (s) (7C:F4) [14:44:52:731]: ******* RunEngine:
******* Product: C:\ProgramData\Novell\Client\Install\NICI\NICI_wx64.msi
******* Action:
******* CommandLine: **********
MSI (s) (7C:F4) [14:44:52:871]: Machine policy value 'DisableUserInstalls' is 0
MSI (s) (7C:F4) [14:44:52:871]: User policy value 'SearchOrder' is 'nmu'
MSI (s) (7C:F4) [14:44:52:871]: User policy value 'DisableMedia' is 0
MSI (s) (7C:F4) [14:44:52:871]: Machine policy value 'AllowLockdownMedia' is 0
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Media enabled only if package is safe.
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Looking for sourcelist for product {559D2B32-5066-4762-A2F2-52831AC6F67B}
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Adding {559D2B32-5066-4762-A2F2-52831AC6F67B}; to potential sourcelist list (pcode;disk;relpath).
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Now checking product {559D2B32-5066-4762-A2F2-52831AC6F67B}
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Media is enabled for product.
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Attempting to use LastUsedSource from source list.
MSI (s) (7C:F4) [14:44:52:871]: SOURCEMGMT: Trying source \\source.local\prg\Apps\NovellClient\Windows7\NICI\.
MSI (s) (7C:F4) [14:45:10:171]: Note: 1: 1314 2: \\source.local\prg\Apps\NovellClient\Windows7\NICI\
MSI (s) (7C:F4) [14:45:10:171]: ConnectToSource: CreatePath/CreateFilePath failed with: -2147483648 1314 -2147483648
MSI (s) (7C:F4) [14:45:10:171]: ConnectToSource (con't): CreatePath/CreateFilePath failed with: -2147483648 -2147483648
MSI (s) (7C:F4) [14:45:10:171]: SOURCEMGMT: net source '\\source.local\prg\Apps\NovellClient\Windows7\NICI\' is invalid.
MSI (s) (7C:F4) [14:45:10:171]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:10:171]: SOURCEMGMT: Processing net source list.
MSI (s) (7C:F4) [14:45:10:171]: SOURCEMGMT: Trying source \\source.local\prg\Apps\public\NovellClient\Windows7\NICI\.
MSI (s) (7C:F4) [14:45:12:745]: Note: 1: 1314 2: \\source.local\prg\Apps\public\NovellClient\Windows7\NICI\
MSI (s) (7C:F4) [14:45:12:745]: ConnectToSource: CreatePath/CreateFilePath failed with: -2147483648 1314 -2147483648
MSI (s) (7C:F4) [14:45:12:745]: ConnectToSource (con't): CreatePath/CreateFilePath failed with: -2147483648 -2147483648
MSI (s) (7C:F4) [14:45:12:745]: SOURCEMGMT: net source '\\source.local\prg\Apps\public\NovellClient\Windows7\NICI\' is invalid.
MSI (s) (7C:F4) [14:45:12:745]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:745]: SOURCEMGMT: Processing media source list.
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 2203 2: 3: -2147287037
MSI (s) (7C:F4) [14:45:12:777]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:777]: SOURCEMGMT: Processing URL source list.
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1402 2: UNKNOWN\URL 3: 2
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1706 2: -2147483647 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:777]: Note: 1: 1706 2: 3: NICI_wx64.msi
MSI (s) (7C:F4) [14:45:12:777]: SOURCEMGMT: Failed to resolve source
MSI (s) (7C:F4) [14:45:12:777]: MainEngineThread is returning 1612
MSI (s) (7C:24) [14:45:12:792]: User policy value 'DisableRollback' is 0
MSI (s) (7C:24) [14:45:12:792]: Machine policy value 'DisableRollback' is 0
MSI (s) (7C:24) [14:45:12:792]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (7C:24) [14:45:12:792]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (7C:24) [14:45:12:792]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (s) (7C:24) [14:45:12:792]: Restoring environment variables
MSI (c) (4C:68) [14:45:12:792]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (4C:68) [14:45:12:792]: MainEngineThread is returning 1612
=== Verbose logging stopped: 23.11.2012 14:45:12 ===



So do you use the automatic Novell Client updater feature?

If so then I believe you need to give that service access to the network as described here: Support | Configure a Windows (Vista/7/2008/R2) service for authentication to eDirectory

Thomas
0 Likes
Absent Member.
Absent Member.

thsundel;2232341 wrote:
So do you use the automatic Novell Client updater feature?

If so then I believe you need to give that service access to the network as described here: Support | Configure a Windows (Vista/7/2008/R2) service for authentication to eDirectory

Thomas


The source files are on a Windows server and the worksation is a member of the domain.
When I update the Novell Client by using "Update Novell Client" from the "N" icon, the Novell Client automatically download all files and copy them to C:\ProgramData\Novell\Client\Install
After that, the update process start.
I enabled audit failure on the Windows file server and discovered that the NICI instalation process use a dynamic user for installation. This dynamic user do not have the right to access the network share. This account name looks like "347be14c8ca99d11NCUS" and the failure reason is "Unknown user name or bad password".
My first idea was to look on the registry all entries about NICI source files and remplace them with C:\ProgramData\Novell\Client\Install\NICI\, but it does not work as the install process always look on the network share... I change the default user profile as well.

1) Is there a bug? Why NICI installation is not looking on C:\ProgramData\Novell\Client\Install\NICI\ as NMAS and Novell Client??
2) What to change on the registry to force NICI installation to look into C:\ProgramData\Novell\Client\Install\NICI\ (how to change source installation)?

Thanks in advance.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

micgra;2232878 wrote:
The source files are on a Windows server and the worksation is a member of the domain.
When I update the Novell Client by using "Update Novell Client" from the "N" icon, the Novell Client automatically download all files and copy them to C:\ProgramData\Novell\Client\Install
After that, the update process start.
I enabled audit failure on the Windows file server and discovered that the NICI instalation process use a dynamic user for installation. This dynamic user do not have the right to access the network share. This account name looks like "347be14c8ca99d11NCUS" and the failure reason is "Unknown user name or bad password".
My first idea was to look on the registry all entries about NICI source files and remplace them with C:\ProgramData\Novell\Client\Install\NICI\, but it does not work as the install process always look on the network share... I change the default user profile as well.

1) Is there a bug? Why NICI installation is not looking on C:\ProgramData\Novell\Client\Install\NICI\ as NMAS and Novell Client??
2) What to change on the registry to force NICI installation to look into C:\ProgramData\Novell\Client\Install\NICI\ (how to change source installation)?

Thanks in advance.


Let me ask Novell.

Thomas
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.