Anonymous_User Absent Member.
Absent Member.
743 views

NLDAP problem

Hi,

Our NW65SP3 server's SSL CertificateIP expires a few days ago. I ran
PKIDIAG and then rebooted the server. Everything came back without
problem. However, when I try to test LDAP with LDAPBrowser, I can connect
via port 389 but not 636. On the server, it shows port 636 is listening
and NLDAP is loaded without any error. I also tried to run PKIDIAG again
but it's showing no error.
Any suggestion to fix this problem?

Thanks

Jack
Labels (2)
0 Likes
4 Replies
Anonymous_User Absent Member.
Absent Member.

Re: NLDAP problem

,
> Any suggestion to fix this problem?
>

Did you renew your certificate in your LDAP browser?

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NLDAP problem

> Did you renew your certificate in your LDAP browser?

Thanks Anders. I renewed the certificate and it's working now.

However, I think there is some problem with my OpenSSH and NLDAP. When I
try putty to my server with OpenSSH, I was not able to log in and I kept
getting "Can't contact LDAP server" in the sshd log. I tried recreate the
sys:\public\RootCert.der and unload NLDAP or SSHD numerious times 😞

Any suggestions?

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NLDAP problem

I finally got it working (with the help of other treads in this forum :-
) ). I discovered that my SYS:\SYSTEM\RootCert.der is different from
SYS:\PUBLIC\RootCert.der. I kept creating a new RootCert.der in the
SYS:\PUBLIC directory but it seems SSHD searches SYS:\SYSTEM\RootCert.der
first. When I copied SYS:\PUBLIC\RootCert.der to SYS:\SYSTEM, putty works
beautifully.....
0 Likes
Highlighted
Anonymous_User Absent Member.
Absent Member.

Re: NLDAP problem

OK. Glad you got it sorted.

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.