colehill Absent Member.
Absent Member.
1046 views

NW6.5SP2 Abends after mounting DATA volume

Last night my Netware server was displaying disk full messages on the data volume. I deleted some old files and attempted to run a purge - but it wasn't having it. I did a normal shutdown and restart and now it won't complete loading. It mounts SYS and then DATA, executes various other tasks and then - after a few minutes - I see NSS error messages referring to some bad blocks on the DATA volume and then it alternately either abends or deactivates the RAID and shuts down.

It may be that one of my RAID volumes is corrupt: the Adaptec firmware says that the array is Optimal but there is a light on the bottom drive.

I've tried SERVER -NA but the result is still similar. I've tried SERVER -NS and it gets to a screen where it just keeps telling me that a delayed operation has taken more than a minute - over and over again. I don't ever get to a console prompt where I can try a pool rebuild.

Any ideas?

KD
Labels (1)
0 Likes
5 Replies
jgray Absent Member.
Absent Member.

Re: NW6.5SP2 Abends after mounting DATA volume

This is what I would do.
1) Boot the server to dos.
2) If the server has no problem with the sys Pool, I would start the server with a -na (server -na).
3) Use the following command on the DATA pool (nss /poolrebuild=data /purge).
4) After the rebuild is done, run autoexec.ncf and see if everythings goes ok. If so, down and restart as normal.

jgray
0 Likes
colehill Absent Member.
Absent Member.

Re: NW6.5SP2 Abends after mounting DATA volume

Thanks. I had tried it with -NA and -NS and got nowhere. Then I found a technote about using the LOADSTAGE and LIST STAGE commands. I started it up with -NA -NS -NL and then loaded a few stages. I had to run the startup.ncf and then I was able to run the Poolrebuild commands. There were no obvious problems but it now boots normally.

I shall now get all my daughter's photographs archived off to free a bit of space and cross my fingers it doesn't happen again until I can afford a new server.
The suspected problem with the array seems to have resolved itself - though maybe that was part of the problem.

KD
0 Likes
jgray Absent Member.
Absent Member.

Re: NW6.5SP2 Abends after mounting DATA volume

This is what I would do. It's great that things are working well for you now. Below are the steps to rebuilding the sys volume.

1) Boot the server to dos.

2) Create a file called nssstart.cfg in the c:\nwserver directory. The command that needs to go in the file is /pooldeactivate=all

3) Now start the server like this. server -ns

4) The server will boot to a : prompt. Type (startup) at the :.

5) It will come back to the : prompt. Type (loadstage 1) at the :.

6) Now the prompt will have the server name in it. At the prompt ttype in the word (pools). Everything should be in yellow text.

7) Now type the following to rebuild the sys pool (nss /poolrebuild=sys /purge).

😎 When it is done, get the server back to dos and either delete or rename the nssstart,cfg file.

9) Reboot the box.

jgray
0 Likes
colehill Absent Member.
Absent Member.

Re: NW6.5SP2 Abends after mounting DATA volume

I don't think there was a problem with the SYS volume, but it's handy to have that note about the NSSTART file. What is the effect of the /PURGE option? I didn't use that when I rebuilt my DATA pool.

KD
0 Likes
jgray Absent Member.
Absent Member.

Re: NW6.5SP2 Abends after mounting DATA volume

The /purge option purges the pool of any deleted files that are on it. There was an issue back in NW 6.5 SP5 when you would purge files, it would has they were purged, but they really were not. So I have got into the habit of use the /purge because if that issue is there, the /purge will fix it.

jgray
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.