Anonymous_User Absent Member.
Absent Member.
1237 views

Need help can't login

Hi,

We have set ifolder up ver 2.0 pro in our test lab on a nw 6 sp 2 edir
8.7
Server has a Master copy or r/w copy of whole tree. we are trying to
use
port 389
admin = cn=admin.o=bbg
Install works fine.
Ifolder loads
Client (admin) tries to connect and we get a -105 error
LDAP allows Clear Text Passwords
No proxy Username set

The ifolder_error.log complains that files don't exist, I have found
these
zipped up so I unziped them.
However I don't seem to have a emframe directory
i.e it asks for a file sys:apache/ifolder/documentroot/emframe

below is a break down of my httpd_additions_nw.conf

Any how would really be appreciated

#
# iFolder Server LoadModule
#
LoadModule ifolderserver_module "iFolder/Server/iFolder.nlm"

#
# iFolder User LoadModule
#
LoadModule ifolderuser_module "iFolder/Server/iFolderu.nlm"

#
# Edit the xxx.xxx.xxx.xxx to your IP address
# =================================
<VirtualHost 10.248.46.3:8111>

ServerName 10.248.46.3

DocumentRoot "SYS:\apache\iFolder\DocumentRoot"
iFolderApplicationRoot "SYS:\apache\iFolder\Server"

<Directory "SYS:\apache\iFolder\DocumentRoot">
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

<location /iFolderServer>
SetHandler ifolderserver-form-handler
</location>

<location /iFolder>
SetHandler ifolderuser-form-handler
</location>



#
# iFolder Server LDAP Settings
#
# Edit the LdapHost
# if the SSL LDAP port of 636 is used, you must
# enter the path to the LdapRootCert.
# ==============================================
LdapHost 10.248.46.3
LdapPort 389
LdapLoginDnContext "o=bbg"
# -or -
# LdapLoginDnContext ",ou=xxxx,o=xxxx"
# LdapRootCert "%LdapRootCert%"

#
# iFolder Volume \ directory for user files
#
# Edit the iFolderServerRoot
# Edit the iFolderUserRoot (same as iFolderServerRoot, used by
iFolderUser module)
# =================================
iFolderServerRoot data:\iFolder
iFolderUserRoot data:\iFolder

#
# iFolder Volume \ directory for application files
#
# Edit the iFolderApplicationRoot
# =================================
## iFolderApplicationRoot G:\Apache\iFolder\Server

#
# iFolder Admin Settings for Server Management Console
#
# Edit the iFolderAdminName
# ==================================
iFolderAdminName admin

#
# iFolder Server Secure Port
#
# Edit the ServerSecurePort
# ==================================
ServerSecurePort 4433
iFolderUserServerSecurePort 4433
#
# iFolder Server Non-Secure Port
#
# Edit the ServerNonSecurePort
# ==================================
ServerNonSecurePort 8111
iFolderUserServerSecurePort 4433

#
# iFolder Server DNS or IP
#
# Edit the iFolderServerDNSorIP
# ==================================
iFolderServerDNSorIP 10.248.46.3
iFolderUserServerDNSorIP 10.248.46.3

</VirtualHost>

# Virtual Host for SSL Port 4433

#
# Edit the xxx.xxx.xxx.xxx to your IP address
# =================================
<VirtualHost 10.248.46.3:4433>

BrowserMatch "MSIE" nokeepalive downgrade-1.0 force-response-1.0

ServerName 10.248.46.3

DocumentRoot "SYS:\apache\iFolder\DocumentRoot"
iFolderApplicationRoot "SYS:\apache\iFolder\Server"

<Directory "SYS:\apache\iFolder\DocumentRoot">
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

<location /iFolderServer>
SetHandler ifolderserver-form-handler
</location>

<location /iFolder>
SetHandler ifolderuser-form-handler
</location>


#
# iFolder Server LDAP Settings
#
# Edit the LdapHost
# if the SSL LDAP port of 636 is used, you must
# enter the path to the LdapRootCert.
# ==============================================
LdapHost 10.248.46.3
LdapPort 389
LdapLoginDnContext "o=bbg"
# -or -
# LdapLoginDnContext ",ou=xxxx,o=xxxx"
# LdapRootCert "%LdapRootCert%"

#
# iFolder Volume \ directory for user files
#
# Edit the iFolderServerRoot, iFolderUserRoot
# =================================
iFolderServerRoot data:\iFolder
iFolderUserRoot data:\iFolder

#
# iFolder Volume \ directory for application files
#
# Edit the iFolderApplicationRoot
# =================================
## iFolderApplicationRoot G:\Apache\iFolder\Server

#
# iFolder Admin Settings for Server Management Console
#
# Edit the iFolderAdmin lines
# ==================================
iFolderAdminName admin

#
# iFolder Server Secure Port
#
# Edit the ServerSecurePort
# ==================================
ServerSecurePort 4433
iFolderUserServerSecurePort 4433

#
# iFolder Server Non-Secure Port
#
# Edit the ServerNonSecurePort
# ==================================
ServerNonSecurePort 8111
iFolderUserServerNonSecurePort 8111

#
# iFolder Server DNS or IP
#
# Edit the iFolderServerDNSorIP
# ==================================
iFolderServerDNSorIP 10.248.46.3
iFolderUserServerDNSorIP 10.248.46.3

</VirtualHost>







Labels (1)
0 Likes
4 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Need help can't login

Try the following:

In the LDAP context lines (2 of them) add a * in front of the O=
(*O=).
Create and add a proxy user to the LDAP server/group with a BLANK
password and bc rights to the CN at the root of the tree (Inheritable
too)
TID10062428 and TID10062287
Login to the web admin server and go to the LDAP section. Check the
search subordinate contexts box and save.

iFolder should work more cleanly now.

--
Timothy Leerhoff
Principal Consultant
Independent Experts
Novell Support Forums Sysop



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Need help can't login

Timothy,

Thanks for the help. It is still not working 😞

However it is looking better. I had to reinstall however I have also
made
the relevant changes as suggested. I can now log in to the admin to
the
ifolder/admin page.

However I am still getting (unable to connect to server error -105)
when
connecting from the ifolder client.

I am trying to login in as admin (context is cn=admin.o=bbg)
and TEST (context is cn=test.o=bbg)

I have tried logging in with context and with out.

I just don't know what else can be the problem

Any ideas

> Try the following:
>
> In the LDAP context lines (2 of them) add a * in front of the O=

(*O=).
> Create and add a proxy user to the LDAP server/group with a BLANK

password and bc rights to the CN at the root of the tree (Inheritable
too)
> TID10062428 and TID10062287
> Login to the web admin server and go to the LDAP section. Check the


search subordinate contexts box and save.
>
> iFolder should work more cleanly now.
>
> --
> Timothy Leerhoff
> Principal Consultant
> Independent Experts
> Novell Support Forums Sysop





0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Need help can't login

Unable to Connect to Server
Question: Rob W. wrote: I have just done a completely clean
installation of iFolder. Once complete, I can connect to the website &
download the client. While setting up the client, I get the error
"Unable connect to server (-105)". I have read that I first need to
enable the users in the Management Page. So, I open the management
page, but cannot log into it. What to do?

Answer: Check these gotchas:

1. Check the .conf file to ensure that the context is correct and that
both areas for the context use commas, not periods, for separating
contexts.
2. Check the capitalizations.

What may work for you is to create an admin-eqiv at the o= level of
your tree and use that account for the .conf file. Also, ensure that
the account doesn't have 0 Grace Logins left or intruder lockout.

Also, make sure you are on eDirectory 8.6.

Quote from the cool solutions site. Note the need for commas NOT
periods. LDAP format needs commas.

http://www.novell.com/coolsolutions/ifmag/qna/configuration.html

--
Timothy Leerhoff
Principal Consultant
Independent Experts
Novell Support Forums Sysop



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Need help can't login

Timothy,

Thanks for all the pointers. It is now working. The final step I had

missed was to enable the account from the ifolder management page.

I am hoping the guy who is going to do the testing will push this one
as we
have a serious need to backup about 1000 laptops.

I think we need to get a TID that has all the instructions from start
to
finsh on a basic install. It is dead easy if you know how etc.

Thanks again

Pete

"Timothy Leerhoff" <tleerhoffNO@SPAMqwest.net> wrote in message
news:I%mla.51$682.37@prv-forum2.provo.novell.com...
> Unable to Connect to Server
> Question: Rob W. wrote: I have just done a completely clean

installation
of iFolder. Once complete, I can connect to the website & download the

client. While setting up the client, I get the error "Unable connect
to
server (-105)". I have read that I first need to enable the users in
the
Management Page. So, I open the management page, but cannot log into
it.
What to do?
>
> Answer: Check these gotchas:
>
> 1. Check the .conf file to ensure that the context is correct and

that
both areas for the context use commas, not periods, for separating
contexts.
> 2. Check the capitalizations.
>
> What may work for you is to create an admin-eqiv at the o= level of

your
tree and use that account for the .conf file. Also, ensure that the
account
doesn't have 0 Grace Logins left or intruder lockout.
>
> Also, make sure you are on eDirectory 8.6.
>
> Quote from the cool solutions site. Note the need for commas NOT

periods.
LDAP format needs commas.
>
> http://www.novell.com/coolsolutions/ifmag/qna/configuration.html
>
> --
> Timothy Leerhoff
> Principal Consultant
> Independent Experts
> Novell Support Forums Sysop






0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.