blittrell2 Absent Member.
Absent Member.
2871 views

New SLP news, Anyone using it?

Hi All,

I saw that with the SLES 10 SP3 OpenSLP is now persistent. Is that actually implemented now? If I put in the paramaters will it start working? There is a message that it will be default in OES2SP3 but I would like to start implementing now seeing as we are in the process of migrating off of NetWare and SLP has been a big holdout for NetWare.

Has anyone been using the new persistent feature, if so how does it work? Any gotchas I need to look out for? Lastly, does anyone know where the file is that it uses to save services so I can make sure it is actually writing to the file?

Thanks

Brett Littrell Network Manager Milpitas Unified School District
Labels (2)
0 Likes
16 Replies
gmarsh Absent Member.
Absent Member.

Re: New SLP news, Anyone using it?

Refer to SLP updates for Open Enterprise Server 2 / SLES10 | Novell User Communities

In my case, the DABackup file was created, but no SLP records were written to it. I need to test further. Please post your findings here.
0 Likes
skapanen2 Absent Member.
Absent Member.

Re: New SLP news, Anyone using it?

gmarsh wrote:
> Refer to 'SLP updates for Open Enterprise Server 2 / SLES10 | Novell
> User Communities'
> (http://www.novell.com/communities/node/11672/slp-updates-open-enterprise-server-2-sles10)
>
> In my case, the DABackup file was created, but no SLP records were
> written to it. I need to test further. Please post your findings here.


I applied the SLP patches to OES2 SP2..
added the new options to slp.conf, restarted services and now
/etc/slp.reg.d/slpd/DABackup seems to up updating and includes the SLP info.

haven't tried rebooting server and checking SLP services though..

-sk

HAMK University - OES, NW, GW, NCS, eDir, Zen, IDM, NSL - www.hamk.fi
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: New SLP news, Anyone using it?

Sami Kapanen wrote:

> gmarsh wrote:
> > Refer to 'SLP updates for Open Enterprise Server 2 / SLES10 | Novell
> > User Communities'
> > (http://www.novell.com/communities/node/11672/slp-updates-open-enter
> > prise-server-2-sles10)
> >
> > In my case, the DABackup file was created, but no SLP records were
> > written to it. I need to test further. Please post your findings
> > here.

>
> I applied the SLP patches to OES2 SP2..
> added the new options to slp.conf, restarted services and now
> /etc/slp.reg.d/slpd/DABackup seems to up updating and includes the
> SLP info.
>
> haven't tried rebooting server and checking SLP services though..


interesting, I took a sles 10 sp3 server and applied all the patches
available (including the slp one) and configured slp to use the backup
file. I can see in slpd.log that it is updating the file (the timestamp
in it changes too) but no services are written in it. I definitely have
services registered against the DA.



--
Cheers,
Edward
0 Likes
gmarsh Absent Member.
Absent Member.

Re: New SLP news, Anyone using it?

Ah, so I'm not the only one. If anyone has the answer, please post!
0 Likes
blittrell2 Absent Member.
Absent Member.

Re: New SLP news, Anyone using it?

Hey All,

I did start implementing the SLP on Linux, I did get the DABackup file as well but for me it did seem to be populating. Just curious, besides the editing of the text files did you go into yast and slp servers and make sure it was set to act as a DA? I know it seems like a simple thing, but I often overlook the most basic part. Any who, I have the SLP info sharing between servers and it appears to be doing well, I have redirected clients to look at the new DA and there seems to be no problems at the moment. Upon a reboot it did seem that SLP did come back pretty fast, so I am guessing it is working as advertised.

Brett Littrell Network Manager Milpitas Unified School District
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: New SLP news, Anyone using it?

blittrell wrote:

>
> Hey All,
>
> I did start implementing the SLP on Linux, I did get the DABackup
> file as well but for me it did seem to be populating. Just curious,
> besides the editing of the text files did you go into yast and slp
> servers and make sure it was set to act as a DA?


Just did and still no joy



--
Cheers,
Edward
0 Likes
gmarsh Absent Member.
Absent Member.

Re: New SLP news, Anyone using it?

So for some people, it works. For others, like me, the backup file is created and timestamp gets updated, but no records are written. So wonder what are the differences between the two. Platform maybe? e.g. 32/64bit? Would you kindly post your platform details (uname -a) and whether it works or not for you. In my case, it doesn't work and I typically use 64-bit xen virtual machines.
0 Likes
blittrell2 Absent Member.
Absent Member.

Re: New SLP news, Anyone using it?

All I changed was the slp.conf and added the following:

net.slp.useScopes = Scope1,Scope2
net.slp.DAAddresses = 12.5.18.20
net.slp.isBroadcastOnly = false
net.slp.isDABackup = true
net.slp.DABackupInterval = 900
net.slp.DASyncReg = true
net.slp.DAAddresses = SLPServer1,SLPServer2

So I changed the identifiable info of course but DA Address 12.5.18.20 is actually a NetWare server running SLP and the isDA option is set to true in this config file( that was up top). We use Multiple scopes here as you can see and the other DAAddresses are the actual names of the other servers, now I try and keep the names of the Linux servers the same as the names of the Novell servers and that is the same as the DNS names so I am not sure if the resolution for the names is through DNS or SLP.

uname info is as follows: Linux SomeServer 2.6.16.60-0.67.1-smp #1 SMP Thu Aug 5 10:54:46 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

FYI, I did restart the slp service while logged in as root, so that may be why it worked, as you running it as root?

Hope that helps!!


gmarsh;2015716 wrote:
So for some people, it works. For others, like me, the backup file is created and timestamp gets updated, but no records are written. So wonder what are the differences between the two. Platform maybe? e.g. 32/64bit? Would you kindly post your platform details (uname -a) and whether it works or not for you. In my case, it doesn't work and I typically use 64-bit xen virtual machines.

Brett Littrell Network Manager Milpitas Unified School District
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: New SLP news, Anyone using it?

gmarsh wrote:

>
> So for some people, it works. For others, like me, the backup file is
> created and timestamp gets updated, but no records are written. So
> wonder what are the differences between the two. Platform maybe? e.g.
> 32/64bit? Would you kindly post your platform details (uname -a) and
> whether it works or not for you. In my case, it doesn't work and I
> typically use 64-bit xen virtual machines.


doesn't work for me.
Linux server 2.6.16.60-0.67.1-vmi #1 SMP Thu Aug 5 10:54:46 UTC 2010
i686 i686 i386 GNU/Linux

This is just in lab.

--
Cheers,
Edward
0 Likes
gmarsh Absent Member.
Absent Member.

Re: New SLP news, Anyone using it?

Did anyone create SR for this yet? If not, I might be inclined to do so.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: New SLP news, Anyone using it?

gmarsh wrote:

>
> Did anyone create SR for this yet? If not, I might be inclined to do
> so.


Go for it 🙂

--
Cheers,
Edward
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.