afiore Absent Member.
Absent Member.
10942 views

Nic Bonding to Cisco Switches

Good Afternoon,

I am trying to setup nic bonding on SUSE Linux 10.2 w/OES2 sp1 to use lacp (802.3ad) and connect to a channel group and lacp on a Cisco Catalyst 4500 or 3750 switch.

The only way I have been able to configure it to work is using NO port-channel group on the switch and using "balance-rr" on the Linux server.

Does anyone have any information on how to make this work correctly ?

Also, how do I verify the nic configuration and i/o performance of the nic's at the terminal command line ?

Thank you,

Tony
Labels (2)
0 Likes
4 Replies
Brunold Rainer
New Member.

Re: Nic Bonding to Cisco Switches

how do I verify the nic configuration and i/o performance of the nic's at the terminal command line ?

Ethtool should show you the nic configuration related to speed, duplex and so on:

# ethtool <nic>

a sample:

# ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes



Rainer
0 Likes
afiore Absent Member.
Absent Member.

Re: Nic Bonding to Cisco Switches

Good Morning,

I tried the commands you suggested, which work on the individual nic's eth0 & eth1, but the same command shows no results when using the "bond0" device. It just says "no data available".

Any suggestions ?

Tony
0 Likes
Brunold Rainer
New Member.

Re: Nic Bonding to Cisco Switches

Tony,

ethtool shows you the settings of physical interfaces (as eth0 and eth1 are) only.
The bond interface does not have that settings because it is just a virtual interface.
But the network speed is controlled with the eth0 and eth1 settings.

Rainer
0 Likes
rdseepaul Absent Member.
Absent Member.

Re: Nic Bonding to Cisco Switches

afiore wrote:
> Good Afternoon,
>
> I am trying to setup nic bonding on SUSE Linux 10.2 w/OES2 sp1 to use
> lacp (802.3ad) and connect to a channel group and lacp on a Cisco
> Catalyst 4500 or 3750 switch.
>
> The only way I have been able to configure it to work is using NO
> port-channel group on the switch and using "balance-rr" on the Linux
> server.
>
> Does anyone have any information on how to make this work correctly ?
>
> Also, how do I verify the nic configuration and i/o performance of the
> nic's at the terminal command line ?
>
> Thank you,
>
> Tony
>
>


Hello:
Hope this helps
The following seems to work for us re the Cisco Switch Side of the
fence. i.e. we have Cisco Switch Ports configured as members of a Cisco
Etherchannel group using LACP to talk to a server NIC teaming Driver
that supports IEEE 802.3ad.
I.e. It shows how to get the Cisco switch to support a Server Teaming /
Bonding NIC Driver that uses IEEE 802.3ad LACP
We get Load Balancing and fault tolerance etc with this.

However note that the load balancing method on the Cisco Switches is a
global config item for all EtherChannel groups on the switch. i.e it is
not possible to have different load balance methods for each Ether
Channel Group defined on your switch.
The question that you have to find an answer for is
Does your OS NIC Teaming Driver Support IEEE 802.3ad
If not then you have to find out which teaming type load balancing fault
tolerance combo you need and your switch would have to be configured
appropriately
i.e.
Does your OS NIC teaming Driver support:
1) Network Fault Tolerance Only (NFT)
2) NFT with Preference Order
3)TLB TRansmit Load Balancing with Fault Tolerance
4)TLB with FT and Preference Order
5) Switch Assisted Load Balancing with Fault Tolerance (SLB) similar to
802.3ad
6) 802.3ad Dynamic with Fault Tolerance.
Based on which of the above are supported by your OS NIC teaming Driver
and which of the above meets your needs. Your switch would need to be
configured to match, for things to work well.


show etherchannel 16 detail
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: LACP
Ports in the group:
-------------------
Port: Gi4/40
------------

Port state = Up Mstr Assoc In-Bndl
Channel group = 16 Mode = Active Gcchange = -
Port-channel = Po16 GC = - Pseudo port-channel =
Po16
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast
LACPDUs.
A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port
Port
Port Flags State Priority Key Key Number
State
Gi4/40 SA bndl 32768 0x10 0x10 0x61
0x3D

Partner's information:

Port Flags State Priority AdminKey DevID Age OperKey
PortNum Poe
Gi4/40 SA bndl 0 0x0 0023.7d62.82ba 2s 0x300
0x900 0x

Age of the port in the current state: 0d:00h:23m:57s

Port: Gi6/16
------------

Port state = Up Mstr Assoc In-Bndl
Channel group = 16 Mode = Active Gcchange = -
Port-channel = Po16 GC = - Pseudo port-channel =
Po16
Port index = 1 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast
LACPDUs.
A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port
Port
Port Flags State Priority Key Key Number
State
Gi6/16 SA bndl 32768 0x10 0x10 0x79
0x3D

Partner's information:

Port Flags State Priority AdminKey DevID Age OperKey
PortNum Poe
Gi6/16 SA bndl 0 0x0 0023.7d62.82ba 4s 0x300
0x100 0x

Age of the port in the current state: 0d:00h:23m:56s

Port-channels in the group:
---------------------------

Port-channel: Po16 (Primary Aggregator)

------------

Age of the Port-channel = 28d:22h:04m:16s
Logical slot/port = 11/16 Number of ports = 2
Port state = Port-channel Ag-Inuse
Protocol = LACP
Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi4/40 Active 0
1 00 Gi6/16 Active 0

Time since last port bundled: 0d:00h:23m:57s Gi6/16
Time since last port Un-bundled: 0d:00h:24m:46s Gi6/16

CR-C5-Stack1#show runn int port-channel 16
Building configuration...

Current configuration : 145 bytes
!
interface Port-channel16
description LACP Eth Channel for ZCM Svr Casius
switchport
switchport access vlan 813
switchport mode access
end

CR-C5-Stack1#show runn int gi 4/40
Building configuration...

Current configuration : 271 bytes
!
interface GigabitEthernet4/40
description CR-Cassius-ZenConfigMgmtServer-NIC1-teamed
switchport access vlan 813
switchport mode access
speed 1000
duplex full
no cdp enable
channel-group 16 mode active <The key word active forces LACP -
required by HP NIC Driver>
spanning-tree portfast
spanning-tree bpduguard enable
end

CR-C5-Stack1#show runn int gi 6/16
Building configuration...

Current configuration : 224 bytes
!
interface GigabitEthernet6/16
description CR-Cassius-ZenConfigMgmtServer-NIC2-teamed
switchport access vlan 813
switchport mode access
speed 1000
duplex full
no cdp enable
channel-group 16 mode active <The key word active forces LACP -
required by HP NIC Driver>
spanning-tree portfast
end
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.