Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
lagern Absent Member.
Absent Member.
3832 views

Novell client, causing SMB lag.

I'm working with a mixed environment. The majority of our file services are hosted on Sles/OES. I am working on one currently that is hosted on a RHEL server. The intention is to run Samba for users who need to access the files on this server via Windows/Mac.

All is working well, except for one little catch.

When i attempt to access an SMB share from a Windows workstation, with the Novell client installed. There's about 30-50 seconds worth of lag. It feels like the system is attempting to access something, and once it times out, it falls back to a second method, which succeeds.

I did some digging, and found the problem. Whenever a new SMB session is started, the system first attempts connections to the server on port 524, after about a dozen or so of these, it falls back to the standard SMB protocol.

This is a problem, because this particular server does not run any novell services, it's a vanilla RHEL server, with Samba installed. Port 524 isnt even open.

If i attemtp this same session on a clean Windows XP install, with no novell client installed, the transaction happens in a matter of about 3 seconds, and the connection is established.

Why does the novell client interfere with simple smb connections? And can this be stopped? All of the users who are going to be accessing this server also have the novell client installed. I can't have it poking its hands into a non-novell related connection.

Thanks!
Labels (1)
0 Likes
6 Replies
Knowledge Partner
Knowledge Partner

Re: Novell client, causing SMB lag.

lagern;1899531 wrote:
I'm working with a mixed environment. The majority of our file services are hosted on Sles/OES. I am working on one currently that is hosted on a RHEL server. The intention is to run Samba for users who need to access the files on this server via Windows/Mac.

All is working well, except for one little catch.

When i attempt to access an SMB share from a Windows workstation, with the Novell client installed. There's about 30-50 seconds worth of lag. It feels like the system is attempting to access something, and once it times out, it falls back to a second method, which succeeds.

I did some digging, and found the problem. Whenever a new SMB session is started, the system first attempts connections to the server on port 524, after about a dozen or so of these, it falls back to the standard SMB protocol.

This is a problem, because this particular server does not run any novell services, it's a vanilla RHEL server, with Samba installed. Port 524 isnt even open.

If i attemtp this same session on a clean Windows XP install, with no novell client installed, the transaction happens in a matter of about 3 seconds, and the connection is established.

Why does the novell client interfere with simple smb connections? And can this be stopped? All of the users who are going to be accessing this server also have the novell client installed. I can't have it poking its hands into a non-novell related connection.

Thanks!


basically that's how redirectors work. one of them has to be primary. if the delay is 30-50 seconds then likely your novell client settings are pretty untuned. anyway, to "resolve" this issue you'll have to make sure that the "bad server name cache" functionality is enabled. if so you can pre-populate this cache with the name of the RHEL server. you should find a description here:

10065560: Poor performance accessing Microsoft Office documents on a Novell server.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Novell client, causing SMB lag.

Along with PrePopulating "BadCache", which is a good idea for known servers,
setting "name resolution timeout" to 1 from the default of 10, will
significantly cut delay times for servers not marked as bad.

Also try disabling the FireWall on the server to see if that helps. I am
thinking there is a setting on there that will help as well. In short, with
the firewall down, the server will be able to respond back that it cannot
service the request and the timeout will not hang.

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.


"mathiasbraun" <mathiasbraun@no-mx.forums.novell.com> wrote in message
news:mathiasbraun.42o8ko@no-mx.forums.novell.com...
>
> lagern;1899531 Wrote:
>> I'm working with a mixed environment. The majority of our file services
>> are hosted on Sles/OES. I am working on one currently that is hosted on
>> a RHEL server. The intention is to run Samba for users who need to
>> access the files on this server via Windows/Mac.
>>
>> All is working well, except for one little catch.
>>
>> When i attempt to access an SMB share from a Windows workstation, with
>> the Novell client installed. There's about 30-50 seconds worth of lag.
>> It feels like the system is attempting to access something, and once it
>> times out, it falls back to a second method, which succeeds.
>>
>> I did some digging, and found the problem. Whenever a new SMB session
>> is started, the system first attempts connections to the server on port
>> 524, after about a dozen or so of these, it falls back to the standard
>> SMB protocol.
>>
>> This is a problem, because this particular server does not run any
>> novell services, it's a vanilla RHEL server, with Samba installed. Port
>> 524 isnt even open.
>>
>> If i attemtp this same session on a clean Windows XP install, with no
>> novell client installed, the transaction happens in a matter of about 3
>> seconds, and the connection is established.
>>
>> Why does the novell client interfere with simple smb connections? And
>> can this be stopped? All of the users who are going to be accessing
>> this server also have the novell client installed. I can't have it
>> poking its hands into a non-novell related connection.
>>
>> Thanks!

>
> basically that's how redirectors work. one of them has to be primary.
> if the delay is 30-50 seconds then likely your novell client settings
> are pretty untuned. anyway, to "resolve" this issue you'll have to make
> sure that the "bad server name cache" functionality is enabled. if so
> you can pre-populate this cache with the name of the RHEL server. you
> should find a description here:
>
> '10065560: Poor performance accessing Microsoft Office documents on a
> Novell server.'
> (http://support.novell.com/docs/Tids/Solutions/10065560.html)
>
>
> --
> mathiasbraun
> ------------------------------------------------------------------------
> mathiasbraun's Profile: http://forums.novell.com/member.php?userid=9494
> View this thread: http://forums.novell.com/showthread.php?t=394797
>



--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
hspeirs Absent Member.
Absent Member.

Re: Novell client, causing SMB lag.

lagern,

> Why does the novell client interfere with simple smb connections? And
> can this be stopped? All of the users who are going to be accessing
> this server also have the novell client installed. I can't have it
> poking its hands into a non-novell related connection.


Go into the client properties, Protocol Preferences, for IP select just
SLP and NDS; then, still in the client properties, go into Advanced
Settings and change the Name Resolution timeout to 1 second from the
original 10.

Close Client settings, go into Control Panel -> Networking, then from
the Top menu Bar Go to Advanced -> Advanced Settings -> Provider Order.
Move the Microsoft Windows Network to the top, followed by the NetWare
Services.

Save, possibly reboot, then try connecting to a Windows share.

H.

--
Hamish
Run multi-processor NetWare VM's with vmBoost
http://www.haitch.net
0 Likes
Highlighted
lagern Absent Member.
Absent Member.

Re: Novell client, causing SMB lag.

mathiasbraun;1899818 wrote:
basically that's how redirectors work. one of them has to be primary. if the delay is 30-50 seconds then likely your novell client settings are pretty untuned. anyway, to "resolve" this issue you'll have to make sure that the "bad server name cache" functionality is enabled. if so you can pre-populate this cache with the name of the RHEL server. you should find a description here:

10065560: Poor performance accessing Microsoft Office documents on a Novell server.


This did the trick! Thank you very much!
0 Likes
lagern Absent Member.
Absent Member.

Re: Novell client, causing SMB lag.

Hspeirs;1900175 wrote:
lagern,

> Why does the novell client interfere with simple smb connections? And
> can this be stopped? All of the users who are going to be accessing
> this server also have the novell client installed. I can't have it
> poking its hands into a non-novell related connection.


Go into the client properties, Protocol Preferences, for IP select just
SLP and NDS; then, still in the client properties, go into Advanced
Settings and change the Name Resolution timeout to 1 second from the
original 10.

Close Client settings, go into Control Panel -> Networking, then from
the Top menu Bar Go to Advanced -> Advanced Settings -> Provider Order.
Move the Microsoft Windows Network to the top, followed by the NetWare
Services.

Save, possibly reboot, then try connecting to a Windows share.

H.

--
Hamish
Run multi-processor NetWare VM's with vmBoost
http://www.caledonia.net


The badcache mentioned before seems to have done the job, but i'm going to give this one a shot as well. It seems that this is a more unanimous fix, and would require less maintenance as possible more smb shares are brought online.

Thanks!
0 Likes
lagern Absent Member.
Absent Member.

Re: Novell client, causing SMB lag.

Hspeirs;1900175 wrote:
lagern,

> Why does the novell client interfere with simple smb connections? And
> can this be stopped? All of the users who are going to be accessing
> this server also have the novell client installed. I can't have it
> poking its hands into a non-novell related connection.


Go into the client properties, Protocol Preferences, for IP select just
SLP and NDS; then, still in the client properties, go into Advanced
Settings and change the Name Resolution timeout to 1 second from the
original 10.

Close Client settings, go into Control Panel -> Networking, then from
the Top menu Bar Go to Advanced -> Advanced Settings -> Provider Order.
Move the Microsoft Windows Network to the top, followed by the NetWare
Services.

Save, possibly reboot, then try connecting to a Windows share.

H.

--
Hamish
Run multi-processor NetWare VM's with vmBoost
http://www.caledonia.net


This works! Thanks!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.