UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Commodore
Commodore
938 views

Nss issue with an application

HI,

we are using an application since 10 years now. This application use a share on an oes11 cluster. (it was on a Netware 6 before)
Workstation are Windows seven x64 mainly and some Windows XP (Novell Client 2sp3ir1+ Xp Workstation 4.91sp5ir1).

The application is used to managed business case. For each business case it creates a directory and several files in it. When you open the application on a device it open the last business case you were working on last time. You can decide to open another case, so the application create the list of all the busness case, then you pick up a case to work on it.

So our issue is the following :

user A open a case
user B launch the application and try to open a new case. When he do that the application failed when it browse the file system on a file from the case open by user A.

Normally the application browse the file system and display the list of the case. If a case is open by another user it just show that this case number is in use.

It used to work perfectly on a Netware 6 box, but it does not work on our OES 11 box.
If i put the share on a Windows box, the application is working.

This application is very important for us and our business, and i don't understand why it is not working anymore on an oes 11 share.
Can you help me to find out what it is going wrong ? I pick up a procmon trace and it only show INVALID HANDLE on the file open by user A
With Wireshark i don't see any error.

Any idea ?

NMAS is disabled, File caching is disable also.

Stephane
Labels (2)
0 Likes
5 Replies
Absent Member.
Absent Member.

Hello,

maybe you have got a similar error than we get with case/4/0-software
(30 users). It has worked all day long when the file share was on a
netware server or when we have put it on a windows share but then the
behaviour changed when we migrated to OES11. We have opened a call (SR
10813788341) with novell (LAN traces were taken when the error happens)
and it turned out to be an error with the current NCP server and novell
is going to present a fix for that.
If you have the option to open a call please do so. May be your case
points to the same direction

Regards

Burkhard Wiegand
Novell Admin
Debeka-Versicherungen
D-56068 Koblenz
0 Likes
Absent Member.
Absent Member.

Can you elaborate a bit on what actually happens ?
I am having txt file corruption when recording hyperterminal to an OES 11 server from an XP workstation with 4.91sp5 client and a W7 workstation with Client 2 sp2 ir4 (needs an update) which still worked with OES2
Trying to figure out what I'm dealing with before contacting Novell.
0 Likes
Absent Member.
Absent Member.

On Fri, 26 Apr 2013 16:56:01 +0000, nwadmsitn wrote:

Hi nwadmsitn

[...]
> It used to work perfectly on a Netware 6 box, but it does not work on
> our OES 11 box.
> If i put the share on a Windows box, the application is working.
>


What application are you referring to ?

[...]

Thank you
Hans
0 Likes
Commodore
Commodore

The application is a very specific one. The name is Winchant and has been done using Windev.
I have open a case and i have done some trace using Wireshark and processmonitor.

The application is presenting to the user a list of busness case. Each of this busness case are a directory with multiple files :
OES11SHARE\WInchant\case001
OES11SHARE\WInchant\case002
OES11SHARE\WInchant\casexxx

The application root directory settings is OES11SHARE\WInchant\
So when you open the application it is browsing and after a few seconds you have a window with all the cases. Then you open a case. Let's say case010.

On a second device you open Winchant, the application browse the directory and failed on a case10 file.

In Wireshark and ProcessMonitor the error happen on the case10 file and it is : "Invalid File Handle"

If i put the Winchant directory and subdirectory to a Windows Share, the application show you all he case with and grey line on the case010 to reflect the fact that it is open on another device.

I have put the application directory on a OES11sp1 box with latest update (April Maintenance) but it is the same. I have disable Oplock, File caching and Cross protocol file locking.
I have update the Novell client on the seven box to 2sp3ir1.

No change.

I will also update my SR number with yours (10813788341) and let you know.

Thanks

Stephane
0 Likes
Commodore
Commodore

Hi,

Finally after NTS analyse the lan trace it appears that there is a defect in NCP (defect 813258), where ERR_INVALID_FILE_HANDLE is returned by the server instead of ERR_IO_LOCKED

Now waiting for a patche

Stephane
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.