MLWeiner Absent Member.
Absent Member.

OES 2018 - getSSCert fails - cannot migrate anything

I'm trying to consolidate a few OES2015 servers' iPrint queues onto a new OES2018 server, but the migration fails every time I try. I've done it through the GUI and through the CLI and it seems to fail at the same spot, the certificate, with the following error:

Failed to get password
getSSCert failed - the self-signed root certificate was not extracted from the directory

I've tried running the getSSCert command manually with the same error. However, if I try the exact same command on my OES2015 server it works fine. It seems like something is wrong with the getSSCert utility on OES2018. Running it in debug mode shows it recognizes all the command line attributes and has them all correct, but then it immediately fails. eDirectory, LUM, all that is working, and it's in an established tree. Even if I point it to the partition master's IP I get the same error. It must have worked at one point because I could get the server into the tree, but for some reason now it tells me it has a password failure no matter what inputs I feed into it, but the exact same command will work without issue on my older servers.
Labels (1)
2 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: OES 2018 - getSSCert fails - cannot migrate anything

As I've never used the tool, I'm not sure exactly how it works, but I'll
guess it goes over the wire to the HTTPS or LDAPS connection to get a
certificate. That means networking, including host-based or network-based
firewalls, may block you. Have you verified you can make a connection
from this box to the target of your query (the 2015 box I presume)?

netcat -zv remote.box.goes.here 636
netcat -zv remote.box.goes.here 8030

You may want to open tcpdump in another shell to see what it shows, either
on the source or destination boxes, or even both:

sudo /usr/sbin/tcpdump -n -s 0 -i any port 636 or port 8030

Feel free to post back the output here for review; nothing sensitive
should show up since it's all encrypted and the rest is just going to be
low-level network data.

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
Knowledge Partner
Knowledge Partner

Re: OES 2018 - getSSCert fails - cannot migrate anything

what do you see on an
openssl s_client -connect xx.xx.xx.xx:636
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.