UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
1998 views

OES11 - NSS export though NFS

Hello,

I am trying to export an NSS volume though NFS.
I was able to do so without issues on OES2 servers, however a OES11 server is giving me problems.

I have NFSv4 turned off in YaST, as well as GSS security.
The exports file is:
/media/nss/DATA1 backup.example.com(fsid=1,ro,sync,no_root_squash,no_subtree_check)

I took the options from the documentation, except the "no_subtree_check", and "ro". (I am using these options on OES2 without issues.)
Changing the export to "rw" from "ro" does not fix the problem.

When I start the nfsserver service, it complains:
exportfs: Warning: /media/nss/DATA1 does not support NFS export.

Is anyone else having these issues, or any idea how to fix this?

Thanks!

-Scott
Labels (2)
0 Likes
6 Replies
Absent Member.
Absent Member.

Curious... I haven't set up OES 11 yet, so I can't yet check on my own. But I'm curious: If you try to export a subdir of DATA1 rather than DATA1 itself, does that work any better?
0 Likes
Absent Member.
Absent Member.

FYI... this has now been reproduced by Novell and a bug filed. Thank you skoerbel for the post, it brought about our test / duplication of the problem.

(And to answer my own previous question, no, it doesn't matter if you export DATA1 itself or a subdir of it).
0 Likes
Absent Member.
Absent Member.

FYI bug number is 740925, https://bugzilla.novell.com/show_bug.cgi?id=740925
though it is probably not visible outside Novell.
0 Likes

Hello,

Is there a work around for this?

I get access denied when trying to look at the details of the bug, and I was not able to find a TID for the issue.

I had tried mounting a subdirectory as you said but it didn't work.

Regards,
Scott
0 Likes
Absent Member.
Absent Member.

There is not a known workaround at this time. A TID has just been published... 7010047. It might take an hour or so to become visible on the knowledgebase. It will be updated as new information is available.
0 Likes

dpartrid;2169952 wrote:
There is not a known workaround at this time. A TID has just been published... 7010047. It might take an hour or so to become visible on the knowledgebase. It will be updated as new information is available.


Thanks for the update. I'll keep an eye on the TID. I'll look into getting an SR open later today so I can get updates or help test any ftf's, if need be.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.