tcsabina Absent Member.
Absent Member.
1410 views

OES2 DHCP in eDir with chroot

Does anyone successfully configured DHCP on OES2SP1 with LDAP and chroot together?

For me it seems that whenever the `-chroot` option is added as parameter, dhcpd wont start. (Giving error that the dhcp server object is not found.)

But only if the configuration is stored in eDir (LDAP), and only if the chroot switch is there. If I use a traditional dhcpd.conf file, there is of course no problem with the `-chroot` switch.


Any ideas?
Labels (2)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: OES2 DHCP in eDir with chroot

Try turning off AppArmor.

0 Likes
tcsabina Absent Member.
Absent Member.

Re: OES2 DHCP in eDir with chroot

utlemming;1811792 wrote:
Try turning off AppArmor.


If removing the usr.sbin.dhcpd file from the /etc/apparmor.d directory means `disable`, then that didn`t helped.

Thanks for the tip anyway.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: OES2 DHCP in eDir with chroot

No, I would try booting without apparmor on -- i.e. "chkconfig boot.apparmor
off"

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.