Highlighted
Absent Member.
Absent Member.
4730 views

OES2 Time Sync Issues with NW65 NTP server

I have a NW65 sp7 network with 24 sites and 30 servers. All of them are
completely in syn except for my two new OES2 servers. I am not versed in
Linux to well. So I am not sure what to look for. The servers were setup by
a consultant who is not sure what is happening. Edir version on them is
20216.55. Both are running under XEN server on Suse 10sp1. Both servers
point to the Nw65sp7 time source server that all of the NW65 servers and my
one win2k server running IDM point to.When you run the test time button it
works. But for some reason one server is out by 1.38 minuets and one is out
by 3.12 minuets. If I try to change the minuets manually the time does not
change after hitting the accept button. Hardware clock is set to UTC. NTP
options are to run the ntp daemon in Chroot Jail. Automaticly to start at
boot. Sync type is "undisciplined local clock". The NTP server address is
aslo listed in the advanced NTP settings. These servers are on the same
network and IP scheme as the NTP NW server. Any suggestions?



Labels (2)
0 Likes
6 Replies
Highlighted
Absent Member.
Absent Member.

Add to you OES2 servers /boot/grub/menu.lst, kernel options "clock=pit"
Remark the servers local etc from ntp.conf.


"CCPS" <net.man2@verizon.net> skrev i meddelandet
news:u_d9j.9957$k06.2230@kovat.provo.novell.com...
>I have a NW65 sp7 network with 24 sites and 30 servers. All of them are
> completely in syn except for my two new OES2 servers. I am not versed in
> Linux to well. So I am not sure what to look for. The servers were setup
> by
> a consultant who is not sure what is happening. Edir version on them is
> 20216.55. Both are running under XEN server on Suse 10sp1. Both servers
> point to the Nw65sp7 time source server that all of the NW65 servers and
> my
> one win2k server running IDM point to.When you run the test time button it
> works. But for some reason one server is out by 1.38 minuets and one is
> out
> by 3.12 minuets. If I try to change the minuets manually the time does not
> change after hitting the accept button. Hardware clock is set to UTC. NTP
> options are to run the ntp daemon in Chroot Jail. Automaticly to start at
> boot. Sync type is "undisciplined local clock". The NTP server address is
> aslo listed in the advanced NTP settings. These servers are on the same
> network and IP scheme as the NTP NW server. Any suggestions?
>
>
>


0 Likes
Highlighted
Absent Member.
Absent Member.

Sorry but I need a little bit more exacting instructions. I see the file you
are speaking of. There are many lines in it. I don't want to put the in the
wrong place. Where exactly should this line go?


"Anders Bengtsson" <apan@apa.com> wrote in message
news:nNw9j.10149$k06.6541@kovat.provo.novell.com...
> Add to you OES2 servers /boot/grub/menu.lst, kernel options "clock=pit"
> Remark the servers local etc from ntp.conf.
>
>
> "CCPS" <net.man2@verizon.net> skrev i meddelandet
> news:u_d9j.9957$k06.2230@kovat.provo.novell.com...
>>I have a NW65 sp7 network with 24 sites and 30 servers. All of them are
>> completely in syn except for my two new OES2 servers. I am not versed in
>> Linux to well. So I am not sure what to look for. The servers were setup
>> by
>> a consultant who is not sure what is happening. Edir version on them is
>> 20216.55. Both are running under XEN server on Suse 10sp1. Both servers
>> point to the Nw65sp7 time source server that all of the NW65 servers and
>> my
>> one win2k server running IDM point to.When you run the test time button
>> it
>> works. But for some reason one server is out by 1.38 minuets and one is
>> out
>> by 3.12 minuets. If I try to change the minuets manually the time does
>> not
>> change after hitting the accept button. Hardware clock is set to UTC. NTP
>> options are to run the ntp daemon in Chroot Jail. Automaticly to start at
>> boot. Sync type is "undisciplined local clock". The NTP server address is
>> aslo listed in the advanced NTP settings. These servers are on the same
>> network and IP scheme as the NTP NW server. Any suggestions?
>>
>>
>>

>



0 Likes
Highlighted
Absent Member.
Absent Member.

Like this:

"kernel /vmlinuz............... bla bla bla bla splash=silent clock=pit
showopts"

Make sure you add clock=pit to the default kernel row.


"CCPS" <net.man2@verizon.net> skrev i meddelandet
news:1Wz9j.10247$k06.6038@kovat.provo.novell.com...
> Sorry but I need a little bit more exacting instructions. I see the file
> you are speaking of. There are many lines in it. I don't want to put the
> in the wrong place. Where exactly should this line go?
>
>
> "Anders Bengtsson" <apan@apa.com> wrote in message
> news:nNw9j.10149$k06.6541@kovat.provo.novell.com...
>> Add to you OES2 servers /boot/grub/menu.lst, kernel options "clock=pit"
>> Remark the servers local etc from ntp.conf.
>>
>>
>> "CCPS" <net.man2@verizon.net> skrev i meddelandet
>> news:u_d9j.9957$k06.2230@kovat.provo.novell.com...
>>>I have a NW65 sp7 network with 24 sites and 30 servers. All of them are
>>> completely in syn except for my two new OES2 servers. I am not versed in
>>> Linux to well. So I am not sure what to look for. The servers were setup
>>> by
>>> a consultant who is not sure what is happening. Edir version on them is
>>> 20216.55. Both are running under XEN server on Suse 10sp1. Both servers
>>> point to the Nw65sp7 time source server that all of the NW65 servers and
>>> my
>>> one win2k server running IDM point to.When you run the test time button
>>> it
>>> works. But for some reason one server is out by 1.38 minuets and one is
>>> out
>>> by 3.12 minuets. If I try to change the minuets manually the time does
>>> not
>>> change after hitting the accept button. Hardware clock is set to UTC.
>>> NTP
>>> options are to run the ntp daemon in Chroot Jail. Automaticly to start
>>> at
>>> boot. Sync type is "undisciplined local clock". The NTP server address
>>> is
>>> aslo listed in the advanced NTP settings. These servers are on the same
>>> network and IP scheme as the NTP NW server. Any suggestions?
>>>
>>>
>>>

>>

>
>


0 Likes
Highlighted
Absent Member.
Absent Member.

I know this is an older thread but for those who are less comfortable with Linux text file based administration. Those who either are used to using a GUI tool to configure like NWAdmin, ConsoleOne, NWconfig, etc. or those who are even used to Netware with it's well documented simpler text base configuration files. You can change the bootloader options using YaST.

1.) Open YaST go to System and choose Boot Loader Settings.
2.) The entry for the SUSE Linux server which is selected as Def. with a check box, it should be highlighted blue.
Click the Edit button at the bottom.
3.) Under the text that says "Optional Kernel Command Line Parameter there are some options listed usually ending with showopts.
SAMPLE: resume=/dev/sda2 splash=silent showopts
Before the showopts entry put this in ---> clock=pit
The line will now read - resume=/dev/sda2 splash=silent clock=pit showopts
4.) Then click OK - Then click Finish (On next server boot the clock should behave better)

This has to do with how a virtual server handles keeping the clock updated versus a real hardware server. It appears to affect SLES on but Xen and VMWare. There is a good TID with more details on it here - 10100597: Time drifting when running eDirectory on a Linux guest under VMware ESX server.

If you still have problems you may need to also add the ----> noapic option right after the clock=pit using the above instructions.

You would be better off manually editing the ntp.conf file in the /etc/ directory to comment out the
#server 127.127.1.0 # local clock
#fudge 127.127.1.0 stratum 10

lines but if you aren't comfortable with that you could use YaST again and open the NTP Configuration under Network Servcies and delete the LOCAL clock and make sure you have reliable NTP servers listed.
Then click Finish

I hope this helps someone else.

Let me add a PLEA to Novell. When installing SLES into a virtual environment, would it be that hard for the installer to add at least the clock=pit option to the bootloader options? It seems like it is required and you could also prompt for NTP configuration and properly set up the NTP servers without the local clock. I know that Linux Admins pride themselves on knowing how to properly configure the each part on the system using vi but there is no reason it has to be complicated. YaST makes it a lot simpler for regular admins but in some cases things should be done by the installation process.

Maybe this is fixed in SuSe 11?
0 Likes
Highlighted
Absent Member.
Absent Member.

Brief follow up - Ultimately, in our environment, currently on Virtual Center 2.5/ESX 3.5 - We ended up adding --> clock=pit noapic nohz=on to the bootloader options based on research.

I do not think that the nohz=on is necessary on newer "tickless" kernals. Can someone clarify that for me and others who might read this? What kernel version is required to remove the nohz=on option from the bootloader. Thanks.
0 Likes
Highlighted
Absent Member.
Absent Member.

We have never used the nohz=on option, we always just used the clock=pit noapic and its been working fine with all kernel release we have had (SLES8/9 up to SLES11)


- Joakim Jader
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.