moorern Absent Member.
Absent Member.
1142 views

OSX resrouce fork files not hidden

I don't think this issue is directly related to Kanaka, but perhaps someone here has experienced the same thing and might know how to fix it.

When users connect to our OES 11 NSS volumes through the Kanaka client (using AFP) and open a file, OSX creates a resource fork file (._<filename>.<ext>). To the Mac user this file is hidden, but when you access the share from a Windows workstation you can see all of these files (also our Filr install is picking these up). This is creating some confusion for users. I'm not too concerned that these files are created, but more so that they are not hidden. I've searched and searched and can not find any information about why this is happening or how to fix it.

OSX version does not seem to matter as I have tested on different versions (from 10.7-10.9) and newer office files (ie, docx) do not create this file. I can manually hide the files, but would like them to be hidden by default. My best guess is that something is not configured correctly with AFP, but I can't seem to figure out what.

Has anyone experienced something similar? Thanks in advance for you help.

Ryan
Labels (1)
0 Likes
1 Reply
Knowledge Partner
Knowledge Partner

Re:OSX resrouce fork files not hidden

moorern Wrote in message:

> I don't think this issue is directly related to Kanaka, but perhaps
> someone here has experienced the same thing and might know how to fix
> it.
>
> When users connect to our OES 11 NSS volumes through the Kanaka client
> (using AFP) and open a file, OSX creates a resource fork file
> (._<filename>.<ext>). To the Mac user this file is hidden, but when you
> access the share from a Windows workstation you can see all of these
> files (also our Filr install is picking these up). This is creating some
> confusion for users. I'm not too concerned that these files are created,
> but more so that they are not hidden. I've searched and searched and can
> not find any information about why this is happening or how to fix it.
>
> OSX version does not seem to matter as I have tested on different
> versions (from 10.7-10.9) and newer office files (ie, docx) do not
> create this file. I can manually hide the files, but would like them to
> be hidden by default. My best guess is that something is not configured
> correctly with AFP, but I can't seem to figure out what.
>
> Has anyone experienced something similar? Thanks in advance for you
> help.


Whilst you can stop the creation of the .DS_Store files[1] Apple
deliberately don't provide a way to disable creating the ._
(dot-underscore) files and instead you'd need to use third-party
software to either stop creating them (for example BlueHarvest)
or tidy up after they have.

HTH.

[1] http://support.apple.com/kb/ht1629
--
Simon
Novell Knowledge Partner

----Android NewsGroup Reader----
http://www.piaohong.tk/newsgroup
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.