lem9 Absent Member.
Absent Member.
996 views

One server in the tree asks for credentials

Hi,
On Windows 7 with Novell client 2 SP3 (IR3), I am able to type \\SERVERA in the file explorer and I am connected to this server. However, typing \\SERVERB (which is in the same tree) asks for my credentials. This happens not only on my workstation.

If I reboot SERVERB, all is fine for some days, but the problem comes back. I suspect that one of the novell processes is dying but I cannot see which one.

thanks,
Marc Delisle
Labels (2)
0 Likes
5 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: One server in the tree asks for credentials

lem9;2331188 wrote:
Hi,
On Windows 7 with Novell client 2 SP3 (IR3), I am able to type \\SERVERA in the file explorer and I am connected to this server. However, typing \\SERVERB (which is in the same tree) asks for my credentials. This happens not only on my workstation.

If I reboot SERVERB, all is fine for some days, but the problem comes back. I suspect that one of the novell processes is dying but I cannot see which one.

thanks,
Marc Delisle


If I had to guess I'd say ndsd is not running.
Next time it happens again do:
rcndsd status

does it show "dead"?
0 Likes
lem9 Absent Member.
Absent Member.

Re: One server in the tree asks for credentials

No, the output is normal, showing it running with the correct tree name.
0 Likes
Knowledge Partner
Knowledge Partner

Re: One server in the tree asks for credentials

lem9;2331225 wrote:
No, the output is normal, showing it running with the correct tree name.


You may need to enable ncp debug logging then and see what the logs show

I think there's 3 logs (if you count the nss2ncp or whatever). I believe it's in the docs on how to set the log level to debug (ncpcon command I think).
It's been a while.

When the problem happens, can you login to NRM as "root"?
If so, then that at least rules out networking issues, and more likely ncp/ndsd issues (can't use CIFS to troubleshoot because CIFS relies upon ncpengine)
0 Likes
lem9 Absent Member.
Absent Member.

Re: One server in the tree asks for credentials

After enabling ncp debug logging and watching the two logs, I see nothing happenning when I try to connect on my workstation with \\SERVERB. Connecting to NRM as "root" on this server works fine.
0 Likes
Knowledge Partner
Knowledge Partner

Re: One server in the tree asks for credentials

lem9;2332049 wrote:
After enabling ncp debug logging and watching the two logs, I see nothing happenning when I try to connect on my workstation with \\SERVERB. Connecting to NRM as "root" on this server works fine.


If the logs show nothing at all, then I'd say the culprit is ncp or ncpengine died or is having issues.
Normally it would log things and you'll see the userid and attempts to access files, etc. showing up.

You may need to open an SR to figure out why ncp is dying.
I'm not sure if you can restart the ncp processes, to be honest, and maybe that would show something.

NRM doesn't use ncp for authentication, that I'm aware of. If you use a non-root user I believe it uses LUM at that point.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.