Anonymous_User Absent Member.
Absent Member.
3025 views

PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!

I have novell 6.0 sp5. Tomorrow I 'll upgrade to NW65.sp6.

I have run PKIDIAG and then I have noticed this:

Step 6 Creating IP and DNS Certificates if necessary.
--> Number of Server IP addresses = 2
--> The default IP address is: 10.x.x.x
--> The KMO SSL CertificateIP's IP Address is: 10.x.x.x
----> The IP addresses match.
WARNING: We could not discover a DNS name.
--> The KMO SSL CertificateDNS's DNS name is: s1.dom1.com
WARNING: Automatic detection of DNS names failed!
---> Setting the default DNS name to s1.dom1.com.
----> The DNS names match.
Step 6 succeeded.

Note: Occasionally multiple problems will be solved with a single fix.

Fixable problems found: 0
Problems fixed: 0
Un-fixable problems found: 0

I have verified by consoleOne the certificate with press "validate".
The answer is ok.

I have two NIC installed into my server but for now I use only one NIC.
it could be this the problem?

These "warning" could be stop the upgrade from NW6.0 to NW65 ?
Or they could be effect later?

Please, can someone help me?

thanks for all
Regards
Monica
Labels (2)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!

,
> WARNING: We could not discover a DNS name.
>

And you have set up a valid DNS resolver in INETCFG? Checked hosts and
hostname in sys:etc?

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2600

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!

> ,
> > WARNING: We could not discover a DNS name.
> >

> And you have set up a valid DNS resolver in INETCFG? Checked hosts and
> hostname in sys:etc?
>


Here is the file hosts:

#
# SYS:ETC\HOSTS
#
# Mappings of host names and host aliases to IP address.
#
127.0.0.1 loopback lb localhost # normal loopback address

#
# examples from Novell network
#
130.57.4.2 ta tahiti ta.novell.com loghost
130.57.6.40 osd-frog frog
130.57.6.144 sj-in5 in5
192.67.172.71 sj-in1 in1

#
# interesting addresses on the Internet
#
192.67.67.20 sri-nic.arpa nic.ddn.mil nic
26.2.0.74 wsmr-simtel20.army.mil simtel20
10.x.x.x s1.dom1.com S1

---------------------------------------

while the file hostname is :

10.x.x.x s1.dom1.com

---------------------------------------

there isn't the second ip of the second NIC because for now, I will not
use it.

Please, what must I still verify ?
Because I'm a little worry about this when tomorrow I 'll upgrade the SO.

thanks for all.
Regards,
Monica


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!


make your files look like this:

hosts (one line):
127.0.0.1 loopback lb localhost # normal loopback address

hostname (one line):
x.x.x.x s1.dom1.com
where x.x.x.x is the real IP and s1.dom1.com is the real dns name

resolve.cfg (two lines):
domain dom1.com
nameserver x.x.x.x
where dom1.com is your real domain and x.x.x.x is a valid nameserver


after this, type the following commands at the server console to reset
the files:
WS2_32 RELOAD HOSTS
WS2_32 RELOAD RESOLVE

Then, try pkidiag again.


--
Cheers!
Richard Beels
~ Network Consultant
~ Sysop, Novell Support Connection
~ MCNE, CNE*, CNA*, CNS*, N*LS


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!

> make your files look like this:
>
> hosts (one line):
> 127.0.0.1 loopback lb localhost # normal loopback address
>
> hostname (one line):
> x.x.x.x s1.dom1.com
> where x.x.x.x is the real IP and s1.dom1.com is the real dns name
>
> resolve.cfg (two lines):
> domain dom1.com
> nameserver x.x.x.x
> where dom1.com is your real domain and x.x.x.x is a valid nameserver
>
>
> after this, type the following commands at the server console to reset
> the files:
> WS2_32 RELOAD HOSTS
> WS2_32 RELOAD RESOLVE
>
> Then, try pkidiag again.
>


I have done the upgrade to NW65sp6.

Now I have this error into PKIDIAG:


Step 6 Creating IP and DNS Certificates if necessary.
--> Number of Server IP addresses = 2
--> The default IP address is: 10.11.x.x
--> The KMO SSL CertificateIP's IP Address is: 10.1.y.y.O=.MY_TREE.
PROBLEM: The IP address in KMO SSL CertificateIP (10.1.y.y.O=.MY_TREE.)
does not match the default IP address (10.11.x.x).
--> Run in Fixing mode to correct this problem(s).
--> Number of Server DNS names for the IP address 10.11.x.x = 1
--> The server's default DNS name is:
S1
--> The KMO SSL CertificateDNS's DNS name is: S1.dom1.com.O=.MY_TREE.
----> The DNS names match.
--> Run in Fixing mode to correct this problem(s).
Step 6 succeeded.

The default Ip must be 10.1.y.y and not 10.11.x.x !!
I have two NIC but I use only 10.1.y.y.

I 'm worring about this and I don't know if I run fix mode , the utility
can fix correctly the problem.

Please what can I do?

thanks
Monica
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!

>
> make your files look like this:
>
> hosts (one line):
> 127.0.0.1 loopback lb localhost # normal loopback address
>
> hostname (one line):
> x.x.x.x s1.dom1.com
> where x.x.x.x is the real IP and s1.dom1.com is the real dns name
>
> resolve.cfg (two lines):
> domain dom1.com
> nameserver x.x.x.x
> where dom1.com is your real domain and x.x.x.x is a valid nameserver
>
>
> after this, type the following commands at the server console to reset
> the files:
> WS2_32 RELOAD HOSTS
> WS2_32 RELOAD RESOLVE
>
> Then, try pkidiag again.


I have disabled the second NIC by inetcfg. then I have reboot the server
and now I have the same problem :

Step 6 Creating IP and DNS Certificates if necessary.
--> Number of Server IP addresses = 1
--> The default IP address is: 10.1.y.y
--> The KMO SSL CertificateIP's IP Address is: 10.1.y.y.O=.MY_TREE.
----> The IP addresses match.
--> Number of Server DNS names for the IP address 10.1.y.y = 1
--> The server's default DNS name is:
s1.dom1.com
--> The KMO SSL CertificateDNS's DNS name is: s1.dom1.com.O=.MY_TREE.
----> The DNS names match.
Step 6 succeeded.

Fixable problems found: 0
Problems fixed: 0
Un-fixable problems found: 0


Excuse me , But in the hostname must I have this?

10.1.y.y s1.dom1.com S1
or only
10.1.y.y s1.dom1.com

Which is the difference?

thanks for your patience.
Regards,
Monica
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!


in your posts here, feel free to post the whole 10.x.x.x address. It's
private anyways...

"10.x.x.x s1.dom1.com" is what you want.


--
Cheers!
Richard Beels
~ Network Consultant
~ Sysop, Novell Support Connection
~ MCNE, CNE*, CNA*, CNS*, N*LS


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: PKIDIAG -> WARNING:We could not discover a DNS name - WARNING: Automatic detection of DNS names failed!

>
> in your posts here, feel free to post the whole 10.x.x.x address. It's
> private anyways...
>
> "10.x.x.x s1.dom1.com" is what you want.
>


Now I have understood.
thanks, thanks

Have a nice day.
Reagards,
Monica
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.