Absent Member.
Absent Member.
6518 views

Passive Mode in Windows 7 with Client 2 IR1A

With our XP clients if we logon WS only and then try to map a drive to a novell server as long as the user name and password are the same for the windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this to work in Windows 7. Logging on either locally or to a windows domain, if I then try to map to a novell drive I am always prompted for the password again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]
"PassiveModeNDSLogin"=dword:00000001
"PassiveModeNDSLoginSilent"=dword :00000001
"PassiveModeNDSLoginRequired"=dword: 00000001
This didn't make any difference though. I've tried it with the "novell logon" in Properties/Advanced Logon both on and off.
Any help you could give would be much appreciated, we want to bring out some Windows 7 PCs and allow them to connect to our existing novell drives but without users being asked for their password again.
Stephen
Labels (1)
0 Likes
11 Replies
Absent Member.
Absent Member.

Try this as a test.

Logon to the PC using a Domain Account.
Shutdown the PC.
Remove the LAN Cable.
Boot the PC and try to logon to the PC using the Domain Credentials with the
LAN cable removed.

Are you abel to logon?

(Note: I realize we are not testing eDir Logon with this, but humor me :>)

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote in message
news:4ABCD623.78FC.0098.0@wbs.ac.uk...
With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]
"PassiveModeNDSLogin"=dword:00000001
"PassiveModeNDSLoginSilent"=dword :00000001
"PassiveModeNDSLoginRequired"=dword: 00000001
This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.
Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.
Stephen


--------------------------------------------------------------------------------


With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]

"PassiveModeNDSLogin"=dword:00000001

"PassiveModeNDSLoginSilent"=dword :00000001

"PassiveModeNDSLoginRequired"=dword: 00000001

This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.

Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.

Stephen










0 Likes
Absent Member.
Absent Member.

Thanks for you help. I did as you asked and I was able to logon with the LAN cable unplugged (after a reboot), using the same credentials to logon to the domain as previously. No errors or messages - desktop loaded OK.

Cheers,

Stephen

>>> Craig Wilson<craig_d_wilson@yahoo.com> 25/09/2009 15:01 >>>

Try this as a test.

Logon to the PC using a Domain Account.
Shutdown the PC.
Remove the LAN Cable.
Boot the PC and try to logon to the PC using the Domain Credentials with the
LAN cable removed.

Are you abel to logon?

(Note: I realize we are not testing eDir Logon with this, but humor me :>)

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote in message
news:4ABCD623.78FC.0098.0@wbs.ac.uk...
With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]
"PassiveModeNDSLogin"=dword:00000001
"PassiveModeNDSLoginSilent"=dword :00000001
"PassiveModeNDSLoginRequired"=dword: 00000001
This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.
Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.
Stephen


--------------------------------------------------------------------------------


With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]

"PassiveModeNDSLogin"=dword:00000001

"PassiveModeNDSLoginSilent"=dword :00000001

"PassiveModeNDSLoginRequired"=dword: 00000001

This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.

Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.

Stephen
0 Likes
Absent Member.
Absent Member.

Dang 😆 I was hoping that would fail.
There are some settings regarding "Cached Credentials" that I was hoping was
disabled by default in Win7. (Still need to Install Win7 here :>)
However, that does not appear to be the case.

Perhaps playing with some of these security policies may help? Just
guessing :>>
http://developers.de/blogs/damir_dobric/archive/2009/08/16/enabling-of-ntlm-on-windows-7-and-windows-server-2008-r2.aspx


--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote in message
news:4ABCDFF5.78FC.0098.0@wbs.ac.uk...
Thanks for you help. I did as you asked and I was able to logon with the
LAN cable unplugged (after a reboot), using the same credentials to logon to
the domain as previously. No errors or messages - desktop loaded OK.

Cheers,

Stephen

>>> Craig Wilson<craig_d_wilson@yahoo.com> 25/09/2009 15:01 >>>

Try this as a test.

Logon to the PC using a Domain Account.
Shutdown the PC.
Remove the LAN Cable.
Boot the PC and try to logon to the PC using the Domain Credentials with the
LAN cable removed.

Are you abel to logon?

(Note: I realize we are not testing eDir Logon with this, but humor me :>)

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote in message
news:4ABCD623.78FC.0098.0@wbs.ac.uk...
With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]
"PassiveModeNDSLogin"=dword:00000001
"PassiveModeNDSLoginSilent"=dword :00000001
"PassiveModeNDSLoginRequired"=dword: 00000001
This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.
Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.
Stephen


--------------------------------------------------------------------------------


With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]

"PassiveModeNDSLogin"=dword:00000001

"PassiveModeNDSLoginSilent"=dword :00000001

"PassiveModeNDSLoginRequired"=dword: 00000001

This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.

Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.

Stephen


--------------------------------------------------------------------------------


Thanks for you help. I did as you asked and I was able to logon with the
LAN cable unplugged (after a reboot), using the same credentials to logon to
the domain as previously. No errors or messages - desktop loaded OK.

Cheers,

Stephen

>>> Craig Wilson<craig_d_wilson@yahoo.com> 25/09/2009 15:01 >>>

Try this as a test.

Logon to the PC using a Domain Account.
Shutdown the PC.
Remove the LAN Cable.
Boot the PC and try to logon to the PC using the Domain Credentials with the
LAN cable removed.

Are you abel to logon?

(Note: I realize we are not testing eDir Logon with this, but humor me :>)

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Support Forums Volunteer Sysop

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote in message
news:4ABCD623.78FC.0098.0@wbs.ac.uk...
With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]
"PassiveModeNDSLogin"=dword:00000001
"PassiveModeNDSLoginSilent"=dword :00000001
"PassiveModeNDSLoginRequired"=dword: 00000001
This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.
Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.
Stephen


--------------------------------------------------------------------------------


With our XP clients if we logon WS only and then try to map a drive to a
novell server as long as the user name and password are the same for the
windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this
to work in Windows 7. Logging on either locally or to a windows domain, if
I then try to map to a novell drive I am always prompted for the password
again, the user name is already filled in in the logon box.

I've added this registry keys from
http://www.novell.com/documentation/noclienu/noclienu/?page=/documentation/noclienu/noclienu/data/b7gx7eq.html
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login]

"PassiveModeNDSLogin"=dword:00000001

"PassiveModeNDSLoginSilent"=dword :00000001

"PassiveModeNDSLoginRequired"=dword: 00000001

This didn't make any difference though. I've tried it with the "novell
logon" in Properties/Advanced Logon both on and off.

Any help you could give would be much appreciated, we want to bring out some
Windows 7 PCs and allow them to connect to our existing novell drives but
without users being asked for their password again.

Stephen














0 Likes
Absent Member.
Absent Member.

"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote:

> With our XP clients if we logon WS only and then try to map
> a drive to a novell server as long as the user name and password
> are the same for the windows and novell logon then the user isn't
> prompted for their password.
>
> If I understand correctly (?) then this is Passive Logon. I can't
> get this to work in Windows 7.


Unfortunately this is correct for the Novell Client for Windows
Vista/2008, and is indeed different from the Novell Client for Windows
XP/2003. Whereas the XP/2003 client does have a cache of the Windows
account credentials used at logon which are then attempted by default
for any future eDirectory- or bindery-mode connections that are
attempted at the file system redirector level, the Vista/2008 client
does not provide such a cache.

When running the Novell Client login dialog, the credentials used for
the primary eDirectory logon will be attempted for any additional
connections made during the eDirectory login script processing for
that logon. But otherwise, if you're not already authenticated to the
resource being accessed (and explicit credentials were not provided,
e.g. on a NET USE command line), then you will be prompted for
credentials to make the connection with.

Just as a general clarification, while it is correctly referred to as
"passive authentication" or in some cases "pass through
authentication", this behavior is actually different than the
"PassiveMode" functionality and configuration described for the Novell
Client for Windows XP/2003. "PassiveMode" refers more specifically to
which Windows GINA-based logon UI will be presented, as opposed to
whether credentials are cached and re-used during later
authentications.

Alan Adams
Novell Client CPR Group
alan.adams@novell.com

Novell
Making IT Work As One
www.novell.com

Upgrade to OES Community
http://www.novell.com/communities/coolsolutions/upgradetooes/
0 Likes
Absent Member.
Absent Member.

Alan and Craig,

Thanks for your help, I'll need to think again about how we want to do this. Maybe they'll just have to enter the password twice,

Cheers,

Stephen

>>> Alan Adams<alan.adams@novell.com> 28/09/2009 00:02 >>>

"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote:

> With our XP clients if we logon WS only and then try to map
> a drive to a novell server as long as the user name and password
> are the same for the windows and novell logon then the user isn't
> prompted for their password.
>
> If I understand correctly (?) then this is Passive Logon. I can't
> get this to work in Windows 7.


Unfortunately this is correct for the Novell Client for Windows
Vista/2008, and is indeed different from the Novell Client for Windows
XP/2003. Whereas the XP/2003 client does have a cache of the Windows
account credentials used at logon which are then attempted by default
for any future eDirectory- or bindery-mode connections that are
attempted at the file system redirector level, the Vista/2008 client
does not provide such a cache.

When running the Novell Client login dialog, the credentials used for
the primary eDirectory logon will be attempted for any additional
connections made during the eDirectory login script processing for
that logon. But otherwise, if you're not already authenticated to the
resource being accessed (and explicit credentials were not provided,
e.g. on a NET USE command line), then you will be prompted for
credentials to make the connection with.

Just as a general clarification, while it is correctly referred to as
"passive authentication" or in some cases "pass through
authentication", this behavior is actually different than the
"PassiveMode" functionality and configuration described for the Novell
Client for Windows XP/2003. "PassiveMode" refers more specifically to
which Windows GINA-based logon UI will be presented, as opposed to
whether credentials are cached and re-used during later
authentications.

Alan Adams
Novell Client CPR Group
alan.adams@novell.com

Novell
Making IT Work As One
www.novell.com

Upgrade to OES Community
http://www.novell.com/communities/coolsolutions/upgradetooes/
0 Likes
Absent Member.
Absent Member.

Wow, that is crazy. This is essentially a step back to the NetWare 3.11 days
when you had to login to each server individually. The ability to login to
the "network" rather than to "servers" was a huge selling point back then.
Is this not going to be fixed? Currently, a number of our users attach to
server volumes long after the login script runs, and a login dialog is going
to really complicate things for them, not to mention for me!

Rick P
Walla Walla Public Schools

>>> Alan Adams<alan.adams@novell.com> 9/27/2009 4:02 PM >>>

"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote:

> With our XP clients if we logon WS only and then try to map
> a drive to a novell server as long as the user name and password
> are the same for the windows and novell logon then the user isn't
> prompted for their password.
>
> If I understand correctly (?) then this is Passive Logon. I can't
> get this to work in Windows 7.


Unfortunately this is correct for the Novell Client for Windows
Vista/2008, and is indeed different from the Novell Client for Windows
XP/2003. Whereas the XP/2003 client does have a cache of the Windows
account credentials used at logon which are then attempted by default
for any future eDirectory- or bindery-mode connections that are
attempted at the file system redirector level, the Vista/2008 client
does not provide such a cache.

When running the Novell Client login dialog, the credentials used for
the primary eDirectory logon will be attempted for any additional
connections made during the eDirectory login script processing for
that logon. But otherwise, if you're not already authenticated to the
resource being accessed (and explicit credentials were not provided,
e.g. on a NET USE command line), then you will be prompted for
credentials to make the connection with.

Just as a general clarification, while it is correctly referred to as
"passive authentication" or in some cases "pass through
authentication", this behavior is actually different than the
"PassiveMode" functionality and configuration described for the Novell
Client for Windows XP/2003. "PassiveMode" refers more specifically to
which Windows GINA-based logon UI will be presented, as opposed to
whether credentials are cached and re-used during later
authentications.

Alan Adams
Novell Client CPR Group
alan.adams@novell.com

Novell
Making IT Work As One
www.novell.com

Upgrade to OES Community
http://www.novell.com/communities/coolsolutions/upgradetooes/


0 Likes
Absent Member.
Absent Member.

Actually, after my post below, I experimented with Win 7 and Client 2 IR1a
myself. It appears to work just as seamlessly now as it ever has, so maybe I
misunderstood what was being described by Alan.

I tried a few different scenarios:

1. I logged in with a unique Windows account (different than any eDirectory
account we have). After the desktop loaded, I logged into eDirectory,
mapping drives to a couple servers via the login script. I then browsed the
tree to several servers (in the same tree) and was not prompted for
credentials.

2. I created a local Windows account with the same ID and password as an
eDirectory account. I rebooted, and at the Windows login screen, I selected
the Novell Logon and then logged into the eDirectory account. Windows
seamlessly logged me into both Windows and eDirectory.

3. After logging out, I did a "Computer Only" login. Obviously, this did not
authenticate me with eDirectory. I then tried to browse the network, and
when I attempted to browse the eDirectory tree, I was presented with a
Novell login box, which I would expect.

Rick P

>>> Rick Pummel<rpummel@wwps.org> 10/26/2009 9:07 AM >>>

Wow, that is crazy. This is essentially a step back to the NetWare 3.11
days
when you had to login to each server individually. The ability to login to
the "network" rather than to "servers" was a huge selling point back then.
Is this not going to be fixed? Currently, a number of our users attach to
server volumes long after the login script runs, and a login dialog is
going
to really complicate things for them, not to mention for me!

Rick P
Walla Walla Public Schools

>>> Alan Adams<alan.adams@novell.com> 9/27/2009 4:02 PM >>>

"Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote:

> With our XP clients if we logon WS only and then try to map
> a drive to a novell server as long as the user name and password
> are the same for the windows and novell logon then the user isn't
> prompted for their password.
>
> If I understand correctly (?) then this is Passive Logon. I can't
> get this to work in Windows 7.


Unfortunately this is correct for the Novell Client for Windows
Vista/2008, and is indeed different from the Novell Client for Windows
XP/2003. Whereas the XP/2003 client does have a cache of the Windows
account credentials used at logon which are then attempted by default
for any future eDirectory- or bindery-mode connections that are
attempted at the file system redirector level, the Vista/2008 client
does not provide such a cache.

When running the Novell Client login dialog, the credentials used for
the primary eDirectory logon will be attempted for any additional
connections made during the eDirectory login script processing for
that logon. But otherwise, if you're not already authenticated to the
resource being accessed (and explicit credentials were not provided,
e.g. on a NET USE command line), then you will be prompted for
credentials to make the connection with.

Just as a general clarification, while it is correctly referred to as
"passive authentication" or in some cases "pass through
authentication", this behavior is actually different than the
"PassiveMode" functionality and configuration described for the Novell
Client for Windows XP/2003. "PassiveMode" refers more specifically to
which Windows GINA-based logon UI will be presented, as opposed to
whether credentials are cached and re-used during later
authentications.

Alan Adams
Novell Client CPR Group
alan.adams@novell.com

Novell
Making IT Work As One
www.novell.com

Upgrade to OES Community
http://www.novell.com/communities/coolsolutions/upgradetooes/




0 Likes
Absent Member.
Absent Member.

Yes, you missed what Alan was saying.

In some cases in example #3, it could be possible for you to never be
presented a logon screen but have your credentials just passed to eDir and
authenticated w/o ever seeing a prompt.
Generally for this to work the Clients default context had to have an
account with the same ID/PWD as used to logon to Windows.



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.


"Rick Pummel" <rpummel@wwps.org> wrote in message
news:4AE574AE.8D5D.0036.0@wwps.org...
> Actually, after my post below, I experimented with Win 7 and Client 2 IR1a
> myself. It appears to work just as seamlessly now as it ever has, so maybe
> I
> misunderstood what was being described by Alan.
>
> I tried a few different scenarios:
>
> 1. I logged in with a unique Windows account (different than any
> eDirectory
> account we have). After the desktop loaded, I logged into eDirectory,
> mapping drives to a couple servers via the login script. I then browsed
> the
> tree to several servers (in the same tree) and was not prompted for
> credentials.
>
> 2. I created a local Windows account with the same ID and password as an
> eDirectory account. I rebooted, and at the Windows login screen, I
> selected
> the Novell Logon and then logged into the eDirectory account. Windows
> seamlessly logged me into both Windows and eDirectory.
>
> 3. After logging out, I did a "Computer Only" login. Obviously, this did
> not
> authenticate me with eDirectory. I then tried to browse the network, and
> when I attempted to browse the eDirectory tree, I was presented with a
> Novell login box, which I would expect.
>
> Rick P
>
>>>> Rick Pummel<rpummel@wwps.org> 10/26/2009 9:07 AM >>>

> Wow, that is crazy. This is essentially a step back to the NetWare 3.11
> days
> when you had to login to each server individually. The ability to login to
> the "network" rather than to "servers" was a huge selling point back then.
> Is this not going to be fixed? Currently, a number of our users attach to
> server volumes long after the login script runs, and a login dialog is
> going
> to really complicate things for them, not to mention for me!
>
> Rick P
> Walla Walla Public Schools
>
>>>> Alan Adams<alan.adams@novell.com> 9/27/2009 4:02 PM >>>

> "Stephen Burke" <Stephen.Burke@wbs.ac.uk> wrote:
>
>> With our XP clients if we logon WS only and then try to map
>> a drive to a novell server as long as the user name and password
>> are the same for the windows and novell logon then the user isn't
>> prompted for their password.
>>
>> If I understand correctly (?) then this is Passive Logon. I can't
>> get this to work in Windows 7.

>
> Unfortunately this is correct for the Novell Client for Windows
> Vista/2008, and is indeed different from the Novell Client for Windows
> XP/2003. Whereas the XP/2003 client does have a cache of the Windows
> account credentials used at logon which are then attempted by default
> for any future eDirectory- or bindery-mode connections that are
> attempted at the file system redirector level, the Vista/2008 client
> does not provide such a cache.
>
> When running the Novell Client login dialog, the credentials used for
> the primary eDirectory logon will be attempted for any additional
> connections made during the eDirectory login script processing for
> that logon. But otherwise, if you're not already authenticated to the
> resource being accessed (and explicit credentials were not provided,
> e.g. on a NET USE command line), then you will be prompted for
> credentials to make the connection with.
>
> Just as a general clarification, while it is correctly referred to as
> "passive authentication" or in some cases "pass through
> authentication", this behavior is actually different than the
> "PassiveMode" functionality and configuration described for the Novell
> Client for Windows XP/2003. "PassiveMode" refers more specifically to
> which Windows GINA-based logon UI will be presented, as opposed to
> whether credentials are cached and re-used during later
> authentications.
>
> Alan Adams
> Novell Client CPR Group
> alan.adams@novell.com
>
> Novell
> Making IT Work As One
> www.novell.com
>
> Upgrade to OES Community
> http://www.novell.com/communities/coolsolutions/upgradetooes/
>
>
>
>



0 Likes
Absent Member.
Absent Member.

Craig... Do you have any more information on this?

I am sort of trying something similar and am trying to pass local windows credentials to login to edir.

Essentially we run DLU (so local and edir accounts match) and I was trying to figure out a way to just pass the local credentials to loginw32.exe to login without logging in again (using /DUI or /CONT switches).

Access to workstation would be via "Workstation Only" option to login to the local account, then after VPN connected THEN authenticate and run scripts via novell client...

Any ideas, I sort of ran into a brick wall...



Craig Wilson;1878447 wrote:
Yes, you missed what Alan was saying.

In some cases in example #3, it could be possible for you to never be
presented a logon screen but have your credentials just passed to eDir and
authenticated w/o ever seeing a prompt.
Generally for this to work the Clients default context had to have an
account with the same ID/PWD as used to logon to Windows.



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.

0 Likes
Absent Member.
Absent Member.

dandirk;1881757 wrote:
Craig... Do you have any more information on this?

I am sort of trying something similar and am trying to pass local windows credentials to login to edir.

Essentially we run DLU (so local and edir accounts match) and I was trying to figure out a way to just pass the local credentials to loginw32.exe to login without logging in again (using /DUI or /CONT switches).

Access to workstation would be via "Workstation Only" option to login to the local account, then after VPN connected THEN authenticate and run scripts via novell client...

Any ideas, I sort of ran into a brick wall...


It's been awhile without activity, did you eventually manage to find a solution to this issue?
I ran into the same problem today 😞
0 Likes
Absent Member.
Absent Member.

ok, found it:
Passive Mode on Novell Client for Windows Vista
This did the trick for me 😉
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.