tanner1 Absent Member.
Absent Member.

Reboot Hangs Turning off Swap

I am having problem restarting my Sles 10.3, OES 2.3 64bit server. The server is running the iSCSI connector and connected to a SAN.

When doing a restart the server hangs, the last thing on the console is "Turning off Swap" then I have to power it off. I thought it might be caused by iSCSI but I can see the connector is stopped, later the nics then later hung on Turning off Swap.


Any ideas or help would be gratefully appreciated.


Master Resource Control: previous runlevel: 5, switching to runlevel: 0
<notice>killproc: kill(3737,15)
<notice>killproc: kill(4841,15)
<notice>killproc: kill(4045,15)
Stopping jexec services<notice>killproc: kill(3876,15)
<notice>killproc: kill(3958,15)
<notice>killproc: kill(3960,15)
Shutting down auditd done
<notice>checkproc: /opt/novell/ncl/bin/novfsd 4903
Shutting down irqbalance done

Shutting down miCASA daemondone
Shutting down CRON daemondone
<notice>killproc: kill(5903,15)
Shutting down Novell TFTP Daemondone
/etc/init.d/kbd stopdone
<notice>killproc: kill(4217,15)
Shutting down Novell ZENworks Preboot Policy Daemondone
<notice>killproc: kill(3950,15)
<notice>killproc: kill(4291,15)
<notice>killproc: kill(4903,15)
Shutting down OpenWBEM CIMOM Daemondone
Shutting down Name Service Cache Daemondone
Shutting down network time protocol daemon (NTPD)done
Saving random seeddone
<notice>killproc: kill(4426,15)
<notice>killproc: kill(4345,15)
<notice>killproc: kill(3943,15)
Stopping iSCSI initiator service: skipped ********* I find this line interesting ************
Stopping ZENworks Daemon Monitor done
<notice>killproc: kill(3963,15)
<notice>killproc: kill(4049,15)
Shutting down slpd done
Shutting down service gdmdone
Shutting down Novell ZENworks Loaderdone
<notice>killproc: kill(4326,15)
Shutting down SSH daemondone
Shutting down mail service (Postfix)done
Shutting down xinetd: (waiting for all children to terminate) done
iAnywhere Solutions, Inc. One Sybase Drive, Dublin, CA 94568, USA
Copyright (c) 2001-2007, iAnywhere Solutions, Inc. Portions copyright (c)
1988-2007, Sybase, Inc. All rights preserved. All unpublished rights reserved.

Shutting down Sybase Adaptive Server Anywheredone
Shutting down powersaved done
Shutting down smdr daemondone
<notice>killproc: kill(4045,9)
Shutting down Novell ZENWorks Imaging Servicedone
<notice>killproc: kill(4903,9)
Stopping Novell novfs daemon...
<notice>killproc: kill(4857,15)
<notice>killproc: kill(4326,9)
Stopping casa_atsd...done
Stopping novell-xregd...done
Shutting down Novell ZENworksdone
Shutting down ZENworks Adaptive Agent done
Stopping NAM Cache Daemon ...
Please Wait. Flushing cache to the file
Shutting down ZENworks Management Daemonfailed
Remove Net File System (NFS)unused
<notice>killproc: kill(4010,15)
Umount SMB/ CIFS File Systems done
<notice>killproc: kill(3730,15)
Shutting down RPC portmap daemondone
Executing customized settings before stopping the Novell eDirectory server...
Stopping Novell eDirectory server...
..............<notice>killproc: kill(4010,9)
<notice>killproc: kill(2742,15)
<notice>killproc: kill(2738,15)
Executing customized settings after stopping the Novell eDirectory server...
Shutting down Novell ZENworks Linux Imaging Agentdone
Shutting down syslog servicesdone
Shutting down network interfaces:
eth0 device: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
eth0 configuration: eth-id-00:1e:c9:b1:3f:0b
done eth1 device: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
eth1 configuration: eth-id-00:1e:c9:b1:3f:09
doneShutting down service network . . . . . . . . . . . . . . .done
Shutting down HAL daemon<notice>killproc: kill(2783,15)
<notice>killproc: kill(2735,15)
[acpid]: exiting

<notice>killproc: kill(2752,15)
<notice>killproc: kill(2696,15)
Shutting down acpid done
Shutting down D-BUS daemondone
Shutting down resource managerdone
Running /etc/init.d/halt.local
done<notice>killproc: kill(29372,3)
Sending all processes the TERM signal...
Labels (2)
9 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team

tanner1 Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap

Work around ....
Turning off Swap is the last thing in the log but it is not the problem.
What I see, iSCSI is shut down before the "NSS" volumes are dismounted. While testing I found if the NSS volume is unmounted, the pool deactivated and iSCSI service turned off the server would shut down properly.
My fix - I added the following command to halt.local:
nss /volumedeactivate=VOLUME
nss /volumedeactivate=POOL
/etc/init.d/open-iscsi stop
I believe iSCSI is already stopped and that is why in the log file is says “skipping” but I added it to the file anyway.
Now the server will reboot and shutdown without hanging.
markovhe Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap


We've encountered the same thing.

My boss found that just trying to shut down open-iscsi with the /etc/init.d script itself was failing if he hadn't unmounted the volumes.

I found that Novell released an updated open-iscsi rpm to the patch channel for SLES10 SP3 on 4/4/11. I back-rev'd to the original from the install media and my test server reboots fine again.

I will test on a production server to make sure this fixes it in that case but I believe I'll be starting a ticket with Novell after confirming it.

Problem version:

Backrev'd to working version:

By the way, this was all on x86_64

mitzelj Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap

Back revving the open-scsi module to open-iscsi-2.0.868-0.6.11 fixed my issue as well. Jeff
smonaldo Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap

mitzelj;2110883 wrote:
Back revving the open-scsi module to open-iscsi-2.0.868-0.6.11 fixed my issue as well. Jeff
smonaldo Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap

This workaround comes diectly from Novell Support, and I have an open bug incident with them on this. Modify your novell-nss script in the /etc/init.d directory and add the following lines after the start section:

echo -n "Umounting NSS volumes"
umount -a -t nsspool
echo "/pooldeactivate=all" > /dev/nsscmd
rc_status -v

save the file and KEEP a copy of this file in a safe place because ever e-Directory or OES2 update seems to overwrite this file and the change has not been officially adopted by Novell.

ccalvert Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap


Thank you very much for posting that fix. Our old file server has been having the same problem lately. I had to go out to work the other day to hold in the power button after trying to reboot it from home.

I am in the processing of moving everything over to a new server and I suddenly started getting the same problem on there after setting up the iSCSI initiator. I hope that this gets worked into an official update soon, but at least I can reboot without hanging in the mean time.

Thanks again.
markovhe Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap

We've had a ticket open on this for about a month and are finally seeing some resolution.

We tried several versions of open-iscsi rpms with no luck. We finally got a PTF file for sysconfig that did resolve the issue.

The engineer at Novell said that it had to go through Mantenance and QA but was on it's way to the patch channel for SLES 10 SP3 and SP4.
mekki08 Absent Member.
Absent Member.

Re: Reboot Hangs Turning off Swap


nice to hear that there is a bugfix on the way.
Because the forum was not reachable today I figure out the problem by myself.

Problem: open-iscsi did not stop if there are mounted partitions on the iscsi-target and do a "skipped"
Solution (for me 😉 😞 is this initscript:

#! /bin/sh
# /etc/init.d/stop-nss
# NO WARRANTY for this script
# Provides: stop-nss
# Required-Start: $network ndsd
# Should-Start:
# Required-Stop: ncp2nss grpwise nss novell-cifs novell-dfs novell-ark novell-shadowfs novell-ncs
# Should-Stop:
# Default-Start: 3 5
# Default-Stop: 0 1 2 6
# Description: Unmount NSS Volumes/Pools safe

# Note on runlevels:
# 0 - halt/poweroff 6 - reboot
# 1 - single user 2 - multiuser without network exported
# 3 - multiuser w/ network (text mode) 5 - multiuser w/ network and X11 (xdm)

# Shell functions sourced from /etc/rc.status:
. /etc/rc.status

# First reset status of this service

case "$1" in
echo -n "Nothing to do on startup... ;-)"
rc_status -v
echo -e "Deactivate NSS Volumes and Pools \n"

cat /proc/mounts | grep nssvol | cut -d " " -f 1 | while read line
echo -e "deactivate Volume $line"
nss /volumedeactivate=$line

cat /proc/mounts | grep nsspool | cut -d "/" -f 4 | while read line
echo -e "deactivate Pool $line"
nss /pooldeactivate=$line
umount -a -t nsspool
rc_status -v
echo -n "I have no status ;-)"
rc_status -v
echo "Usage: $0 {stop}"
exit 1

  1. put it in /etc/init.d
  2. do a 'chmod +x /etc/init.d/stop-nss'
  3. activate it: 'chkconfig stop-nss on'
  4. change the flag for "RUN_PARALLEL=" in /etc/sysconfig/boot from "on" to "off",
    because the open-iscsi script runs randomly on shutdown and not on the given init number.

    NO WARRANTY for this script !!

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.